WD external Hardrive not appearing on computer

Just wondering if anyone would be able to help me. A few days ago my external hardrive was not appearing under my computer to access the it however it is recognising that the hardrive is plugged in and allows me to click to safely remove the device.

Under Disk Management it shows the following

Disk 0 shows as online NTFS

Disk 1 - unknown - not initialized.


The capacity under each of these does not match the terrabyte of storage on my external hardrive.

I tried plugging my device into my SMART TV as well however this did not recognise the device either.

Any help would be greatly appreciated.



1 Like

i have the same problem and i tried my best to solve it… but just i can’t, i hope anyone answer now please

Sunnds like the drive may be corrupt. See if TestDisk   http://www.cgsecurity.org/wiki/TestDisk helps.


My 1TD Passport similarily failed and there is no way to retrevieve the date.  It’s a huge loss to me as I stored much of my business correspondence on the device and now I have to recreate hundreds of documents.  I have purchased a new Passort (Slim) 1TB but will come up with an additional solution as my confidence in the equipment is low.

You never want to trust important data to just one drive internal or external no matter who makes it. Use atleast 2 different drives or look into something like Carbonite.


At least 2 externals AND make a DVD of the really critical stuff.  Send the DVD to a friend in another city of a tornado or hurricane doesn’t wipe out all your backups - whihc could happen if they are only a mile or so apart.

Also have a second DVD handy at your place.