WD Discovery Install hangs/hung/stuck at 18% on Windows 10


Any guidance on how to properly & safely stop the install since there is no “Cancel” button, and then how to properly “clean up” after stopping an install, would be appreciated. As well as any other pointers/suggestions.

2 Likes

Hello,

Please refer to the following KBA article: WD Discovery Failure to Install on Windows

1 Like

SOLVED (Windows 10):

  • WD Discovery installation hangs at 18% if you did NOT agree to share Product Improvement info. If you allow info-sharing (default), the installation works. After installation, you can switch off sharing in the installed app (Settings > Product Improvement Program).
  • No Cancel button: Use Task Manager to kill the process.
    • To open Task Manager press Ctrl+Shift+Esc.
    • Right click on the WD Installation app and select End Task.
  • Cleanup: The installation doesn’t appear to do anything on disk in the first (and only) 18% of its life. However, if you kill the installation process using Task Manager and then immediately again try to install (with info-sharing allowed), you get an error message telling you that there is a problem and to try again later. What they don’t tell you is that “later” actually means “after rebooting”.

NOT SOLVED:
Having spent half of last night trying to install WD Discovery and eventually succeeding, I opened it this morning only to find that it doesn’t recognize any connected USB devices any more, regardless of whether Product Improvement is switched on or off.
I shall now take great pleasure in uninstalling the thing.

3 Likes

Weirdly, I also have a Dell running windows 10, chose not to share information, and my install stopped at 18%. Going to try your advice of agreeing to share and see what happens. That is pretty shady if that is something automatic.

My install also stops at 18% even with sharing product improvement. On a windows 10 machine

1 Like

Hi, same for me too it stops at 18%

Easy to find this topic via Google. Same 18% issue going on this morning with new drive. I do not find any “fix” in this topic thread short of contacting MS which is BS for a brand new drive on a Dell Win10 machine. This will go right in the box and be sent back as fast as Amazon Prime sent it to me. And to think this was all caused by WD killing my My Book NAS drive support.

Oh Hell what a mess. So here is my plan. The drive appears to be fully functional, it is just this software install which does not work?? If that is the true, Go here: https://support-en.wd.com/app/products/product-detail/p/119#WD_downloads and download the Utilities, Security and Acronis (Backup) software. Install these and call it a day. If this fails I will be back to let you know.

So, I was having the exact same problem – initialization stuck at 18%. I opened task manager (CTRL+ALT+DEL) and noticed there were 2 instances of the installer running for some reason, one of which was a 32-bit version. I ended this task while leaving the other, 64-bit process running. I got a couple of error messages which I didn’t bother reading and just “OK’d” or X’d out of, and whaddya know, the thing finished initializing and now it’s fully operational. It was as simple as that.

Hope this helps someone.

3 Likes

CelticHammer, this seems to have worked for me. Thanks! The first time I killed the 32bit task, all WD tasks closed, but I reran the install and this time when I killed the 32bit task, I got and ignored a couple messages (like you did) yet the install completed. I’m now running my first backup. (@ 24% of 92 GB so far) btw. I had chosen to have Product Improvement Off, and I’m on a DELL w/Windows 10.

1 Like

The use of the full installer has always been available. A full uninstall of the existing version is required to prevent just this problem.
Published 08/20/2018 | Updated 12/17/2021

Download WD Discovery Full Installers

The package will install WD Discovery, WD Drive Utilities, Universal Firmware Updater and the Desktop App for My Cloud Home.

IMPORTANT35pxx45px Important:

WD Discovery for Windows

WD Discovery Full installer for Windows

WD Discovery for macOS

WD Discovery Full installer for Mac

create the following directory manually.
in C:\Program Files (x86)\ create the subfolders \Western Digital\Discovery\Current

C:\Program Files (x86)\Western Digital\Discovery\Current

then run the installer again.

What worked for me is running WD with ADMINISTRATOR PRIVILEGES (right click, run as administrator)
I hope this solve the problem

Regards,
Gonzalo

1 Like

Hey, my install also drops. How to fix this ?

Mini Militia App Lock

This worked for me. I deleted the other two 32 bit processes and allowed the 64 bit to continue. Thank you Celtic Hammer! It will go back and forth on % for a while, but it will eventually finish.

Or right click and run the .exe as an administrator

Windows 11-After watching 18% for 10 min, I opened the task manager and ended the application in Processes and Apps completely. I went back to download it and was successful. It took less than a minute. If it stalls at 18%, delete and download again. Worked for me.

Yes, this worked for me, thanks!

Experience similar issue with was fixed by accepting “Share Product”… but I got the other problem: cannot find it in File C:\Program Files (x86)… but after click OK, ( like 2 times), it finished the installation.

Ok SOLVED! You literally need to think outside the box. I experienced everything as you all were. It took me maybe an hour to figure this out. Drag the WD software off the storage to downloads or where ever you like to put your software and extract it from there. It completely installed and worked perfectly, synced all my drives and the WD is completely loaded and I can see the 100% space on it. I hope this helps you all. Also I am using Windows 11.