WD Backup not working on schedule

I’m confused. I have WD Backup scheduled to do a daily backup at 3PM. At the allotted hour I’ll get a notification in the Windows 10 notification area that a backup has started. Several minutes later I’ll receive another notification stating the backup was successful. Despite being told the backup had finished I noticed the LED light on my WD Passport was fast flashing indicating it was still active, yet when I open the WD Backup software it’s showing no activity and is indicating the last backup completed was from the previous day, not today. I’ll then close the software and right click on the WD Backup icon in the Windows 10 System Tray and select “view notifications.” It shows the backup was started and completed today. ??? This has been going on for the past three days now. I’ve had to do a manual backup each time. The activity light on my Passport drive will continue fast flashing despite there being no apparent activity according to the WD Backup software. It will go on for hours until I finally restart my computer.

I’m using WD Backup software version 1.9.7435.38388 on the latest version of Windows 10 ( Build 19041.388)

skiman…I’m not normally on this thread…Software & Mobil, but saw your post today about this issue…I posted my issue here: My Scheduled Passport Backup did not run on my Schedule and no Indicator as to WHY not,

  • I have 2 Passport devices, that I backup my 1 PC, daily and weekly. The weekly one started failing to execute, even with start/end notifications appearing. The WD display would say Missed…and not reason at all.
  • it was working fine for 6mo, till I ran into a huge backup issue of 4million files accumulating from my Mozilla cache2 folder. I cleaned up and redid my schedule and file selection about 3weeks ago.
  • what I found was a comment about Pausing and Resuming a Backup schedule. I toggled this item and will wait till Sunday. I don’t know if you, like me, might have changed any of your target files, or date/time…I’m not saying that this is it, but that was the only thing I can remember doing…I went from Daily to weekly and reduced the file/folder selection.
  • my other daily backup has been going off without a hitch, and I’ve been checking every day, especially with the weekly failure.
  • I wondered about sleep mode on a devices, and maybe changing to that…however, I don’t think that would do it. I’ve tried accessing the drive prior to scheduled time.
  • my ver is 1.9.7375.5719, older, that was loaded in Apr…not sure how to find a newer version.

Thanks for the reply. I had actually read your post on the other thread when I was searching for anyone having a similar issue.

I deleted my copies of WD Backup and WD Discovery and found a older version of Backup on their support site here.

https://support-en.wd.com/app/products/product-detail/p/1539

I did a manual backup using this older Backup software last night. When I logged into the reloaded copy of Discovery it notified me of the newer version of Backup, which I downloaded. Turns out it is the same version number that was giving me trouble. Today my backup worked as scheduled with no apparent issues. Prior to this I had not made any changes to my backup plan or to any of the target folders. Hopefully deleting and reloading the software solved the issue for me. Time will tell.

Hope you’re also able to find a resolution to your problem as well. Thanks again for sharing.

Skinman1818…so let me get this…

  • you reverted back to the older version of Backup from the link to v 1.9.7375. as indicated from the download link…That’s the one I’m on.
  • I did see that notice about Update under Discovery/backup. you say that this one is the 1.9.7435 version? …I was going to wait till my original issue of backups not starting gets resolved or failed before switching or not.
  • I’m waiting to see if the pause/resume toggle does anything…a little skeptical about it, but hey…got to try something…
  • I’m a little amazed the more users are not having issues…people are reading but not commenting, like you.
  • my daily backup seems to be working, it’s just the weekly one that started failing after I tweaked the schedule and folders.

Please comeback a post your successes.

HowAboutMe; You are correct. After deleting my copy of Backup I initially downloaded 1.9.7375 from their website and immediately did a manual backup. After deleting and reinstalling Discovery it directed me to download an update to Backup which turned out to be the version I had initially deleted, 1.9.7435. All I do is run a daily backup each day and, so far, it has worked for the past 2 days.

I’ll bet more people are having issues. Perhaps their calling tech support rather than post on here.

Sorry skiman…my weekly scheduled backup Failed to initiate. I added comments to my ongoing thread overthere.

  • the backup that I have going daily works to my 2nd drive. The 1st is weekly from the same App.
  • I don’t want to load the newer Backup that you found to fail, till all other options are tried.
  • I will pause, change schedule to Monday and resume.
  • question, when you deleted the previous version, did you worry about the existing schedule and file/folder choices being dumped. If you download another version, you said you deleted the first…does all the settings and pointers have to be reset? Kinda wondering, especially the files/folders…also, on the backup drive, does it create a new swstor folder…thinks like this bother me.

I assumed everything would be removed when I deleted the program but my preferences remained in place including all the folders I selected for backup along with the daily schedule at 3PM.

skiman1818… Just wanted to inform you that I made another note into that other link.

  • redid the schedule for Mon 10am, weekly
  • the new setup went off without a failure.
  • so far, my daily works, and will wait to see if the weekly goes off next Monday
  • I’m gong to send WD support an email
    Thanks for commenting

Thank you as well for your valuable input. I’m glad the software for your daily backup is working. I hope you have similar luck with your weekly. If I encounter any further issues I’ll post them here. :smile:

skiman1818…sorry for adding to this thread of yours, but since you were kind enough to dialog with me, I thought I would update you. I also posted a reply on the other thread I had.

  • backups are still proceeding on both my weekly and daily.
  • I’ve tried the Sleep setting that WD said was my problem…I could not evoke any failure…could not see when a drive goes into sleep. My backups started even when I let the drive go idle for a long time…I’m guessing that sleep mode get interrupted because of the WD backround Apps are always running (as viewed by Task Manager)
  • WD said sleep could make drive not viewable from Explorer…I have never seen this happen except when you Save Eject.
  • I asked about a complete uninstall/reinstall the software vs. updating from Discovering. You said earlier that you did the uninstall method. Was told that all previous backup configurations would have to be initialized…but, using update, the configuration of file/folder would remain intact. Now, I’m not sure if the swstor backup folder will now contain a new additional folder (I’m guessing it will).
  • How are your backups going…any issues?

Since I uninstalled and reinstalled the software I’m not having any issues at all with my daily backups. I’ve even gone into the backup drive itself to verify a new file I added that day was in fact backed up. So far so good. Glad your backups seem to be working as well. Hopefully WD addresses the issues we both had with future upgrades.

Since you did a complete uninstall/reinstall, did you notice that you had to completely reset your configurations from the previous?

Also, have you ever wondered about the Sleep function of these devices…the one on the Discovery App?

How about Safe Eject…do you do this and have you overcome the error msg about drive in use?
Sorry for the questions, just trying to extract some knowledge from anyone.

I anticipated having to reset my configuration but turns out I didn’t need to. All my settings remained in place with the reinstall.

I leave my laptop plugged in all the time so I have my sleep function set to 4 hours. I haven’t had my computer go to sleep prior to a daily update so I’m not sure if that would be an issue for me.

I haven’t used safe eject to unplug my drive. I make sure the drive isn’t reading or writing before I unplug it. I haven’t noticed any issues doing it this way.

Thanks skiman1818…

  • very interesting about the configuration not needing updating. I guess I won’t know how it works till I need to. I tried to get WD to tell/point me to info on that newer Backup that you originally tried. Was told, when you Update thru Discovery, a message is displayed…oh well…I keep going back to your explanation of what went wrong when you had the more newer version that had a fault. We have not seen anyone opting to use it and Complain.
  • whether you leave the PC on or off…I fail to see how that Sleep works…I know on my PC, if I set the Sleep, it will definitely Sleep, Even if an application is running…had this happen on long movie downloads and even with the huge win7/win10 update…I’m not willing to check this out, especially with a running application.
  • the safe eject…was an issues that I read about in this forum. Next time you do shut your PC down, try the safe eject (in the boxes next to the clock…also notice an eject in Discovery gear setting for device). See if you get a message about WD running apps…if you check in Task Manager, you will see background app running, so technically, when you pull your USB, there is a handshake with the drive. I know you don’t want to do anything to mess up your backups. I found an entry in Device manager that got rid of the msg.