WD 2tb My book HDD

Got another 2TB My book HDD for x-mas. so now I have two and cant seem to have them both plugged into my laptop at the same time , for it only finds one under " my computer". was wanting to transfer files from one to the other but cant . I also have a 750 gig external WD HDD that works just fine with either 2tb at the same time so it doesnt seem to be a laptop issue. the only thing that i figure is that laptop getting confused because they are the same excact 2tb hdd. I tiyed going to the propeerties and changing drive name but that doesnt seem to help . for example if i change it to “drive one” and the other to “drive two” they still show as My book / drive one.

any help would be great ,


It’s a Windows thing a signatured collision. This post explains what to do http://community.wdc.com/t5/My-Passport-for-PC/Copy-files-from-one-drive-to-another/m-p/277504/highlight/false#M7587


1 Like

thanks , I printed that link out and will give it a try . I will post a follow up after I try it

worked perfect ! problem is solved and i learned something new :wink:

thanks again

Thanks for posting back. Glad it worked.