Volume failure after upgrading My Cloud Mirror 2 to OS5

Hello there,

I have just upgrade my My Cloud Mirror 2 to OS5 5.05.111. The process completed successfully without any errors messages. I was able to rest my user (creating new password) and access the dashboard. However, later an “Volume Failure. The data volume 1 on the drive is not accessible. Code:4” critical error message appears. The HDD LEDs turns red. Capacity turns to 0.00 MB free and I could not access the drive on local network to get the data at all.

I check the storage tab and it says “No Configured Volumes. Setup a RAID Mode to configure new RAID Volume(s) on this device.”,“Disk Health: Healthy”

I used the drive normally before the upgrade in “Spanning Configuration”.

Please help me to sort this problem out or tell me how to! get my data out. Many thanks!

Screen Shot 2020-11-23 at 02.07.59|690x406

@winnd4spd What size HDD and Volume did you have configured with your Mirror Gen2?
Mirror Gen2 shipped from the factory with a max of (2) 8 TB HDD in RAID1 so a max of 16 TB volume total.

Did you have a volume larger than 16 TB?

1 Like

Hello @SBrown,

Thanks for your reply.

I have 2X10TB and was running spanning of total 20TB on it previously.

Are there anyway I can fix it or get my data out in this situation?

@winnd4spd Unfortunately, My Cloud OS 5 doesn’t support a volume larger than 16 TB on the My Cloud Mirror Gen2 so it cannot mount the volume. One solution would be to upgrade the enclosure to an EX2 Ultra which does support larger volumes in OS 5, or if you have a backup, reconfigure the disk with RAID1 and 10 TB Volume.

1 Like

@SBrown I see. Thanks for the info.

The idea is that I need to get my data out of it before I can reconfigure the disks. I wonder if any of these options would work:

OP1: Get a new EX2 Ultra then swap the disks into it and use the disks straight forward, perhaps?

OP2: Swap the disks with other My Cloud Mirror Gen 2 running OS3 to temporary get my data out of it (because we can not downgrade from OS5 to OS3, right?).

If option 1 and 2 are possible, do it need to configure anything on the enclosure before doing so?

OP3: Manualy get my data out using dock with computer (Last resort option as I might need a guideline how to do so).

Looking forward for your advices.

. .another option would be to for WD to change the HDD limit to something above 16TB.

Considering that the unit ran fine with 20TB with OS/3. . .I suspect the hardware is capable?

A few thoughts:

  • From the WD Reply; I take it that you can just drop the volumes from the Mirror to an EX2 (roaming?) and life is good?

  • QUESTION: What is the software capacity limit of the EX2 Ultra?

  • QUESTION: What happens if you pull out one disk? Is the other disk readable; or does it recognize that 1/2 the volume is missing? If that is the case. . . .seriously reconsidering running these as spanned volumes in the future; since a failed HDD will result in ALL data lost. The odds of one drive failing in a two drive system is DOUBLE the odds of a single drive failing. . .

  • I would look into the other options you are considering as well

  • . . . .hint- - -if you look in the transmission threads; I think someone found a way to roll back to OS/3. . . .but that was likely for a different NAS (a PR4100? Can’t remember - - -and there may be some important differences in the way the “recovery partition” is set up.)

1 Like

Thanks for joining @NAS_user.

I have the same thought that the My Cloud Mirror Gen2 are working well with 20TB previously so it should be able to work with the new OS5 which I feel is faster (from how quick I get into the Dashboard so far).

@SBrown said that the EX2 Ultra works with 20TB. However, I wonder if a hot swap can work straightway?

Finding a way to rollback to OS3 could be a solution for me. Thanks for the idea.

Did you figure out a solution to reading the data off you 2 x 10TB drives?

Unfortunately, I’m still trying to find the way to read the data out but still no luck.

I escalated the case to WD support centre and WD recommend me to use Linux to read the data out. However, WD did not give me any instruction how to do that, instead on the last reposed, WD recommended me to use 3rd party data recovery services.

Oh good lord.

So the question on the MyCloud Mirror: Is the OS residing on the HDD, or on a rom chip? If on a ROM chip. . you probably could just drop the drives into your OS/3 enclosure and you are good to go.

But I personally would head down the Linux route. This would involve;

  • A USB enclosure to house the drive.
  • A linux driver so you can read the Ext4 formatted disk from the MyCloud mirror.

I have not actually done this. . .but I have read about other people (on the single bay MyCloud subforum) having done it.

Give this link a try: 3 Ways to Access Your Linux Partitions From Windows (howtogeek.com)

I was offered to send in my original hardware to get a replacement with OS3 installed.

Since I switched to a Synology I focused my efforts on getting my new NAS up to speed.

But reading all the problems people are having with OS5 and the indexing issue, perhaps getting a MyCloudMirror rolled back to OS3 would be the best way to proceed.

This would enable people to simply extract their drives before sending it back to WD, and plug them back in to the replacement enclosure (with OS3).

Doesn’t require Linux or any additional hardware.

I think the OS is residing in the ROM chip.

You can test this out by removing the drives, then logging into wdmycloudmirror.local. It should still recognize your login credentials, networking, but your volumes, shares, etc will all be missing.

@NAS_user @justplainlawr

WD did not offer me for an exchange the enclosure, but told me to try 3 party data recovery services and Linux. The problem is that I only can find some articles about recovery data with the My Cloud Single, not for the Mirror. Not sure if Linux would detect the RAID 0 with 2 drives connected to 2 external docks and the safety of data using this method.

I also believe that that OS is on the ROM as like @justplainlawr said, the configuration still remained, only volumes cannot be accessed.

The best and safest solution I could think about is to downgrade the OS5 back to OS3. However, not sure how to do it :roll_eyes:

I was able to roll back to OS3 using following method

  1. upgrage to DSM ( https://fox-exe.ru/WDMyCloud/WDMyCloud-Mirror-Gen2/ )

  2. move on with the installation of DSM

  3. Enable “SSH Access” in web interface
    Login via SSH from your first login (Or any of ligin with Admin privileges)
    Type “sudo su” and enter your password again. You are “root” now. Type:
    dd if=/dev/zero of=/dev/mtdblock1

  4. After reboot you can access to “WD Recovery” web. Install original WD firmware OS3


Thanks @vendo232,

That’s absolutely a break though. However, I’m not sure whether WD has blocked it on the new OS5 as I faced an error while trying to upload the bin file via Web GUI as bellow:
Screen Shot 2021-01-10 at 21.42.33
Hope you can help me to pass though this step

Hi guys,

I found the way to revert the my My Cloud Mirror 2 back to OS3 2.41.116. Here is what I did:

  1. Take out the HDDs and replace them with 2 others blank (just for the safety of the data inside. You need to have HDDs inside to be able to use the My Cloud Mirror 2) / Formatting them to to be able to use (RAID 0 or 1 are fine).
  2. Login the Web GUI using your normal admin account / Settings / Network / Activate the SSH / It will ask for a password, put whatever you want that easy for you to login later (the default user is “sshd”)
  3. Reboot the drive (so the SSH can be fully activated)
  4. Open Terminal / Login the My Cloud Mirror 2 via SSH following these codes:
    ssh sshd@your My Cloud Mirror 2 IP address
    Are you sure you want to continue connecting (yes/no)?
    Warning: Permanently added ‘IP address’ (RSA) to the list of known hosts.
    sshd@IP address’s password:
    Put your SSH password on
    BusyBox v1.30.1 (2020-09-04 02:41:28 UTC) built-in shell (ash)
    Enter ‘help’ for a list of built-in commands.
    root@WDMyCloudMirror ~ #
    dd if=/dev/zero of=/dev/mtdblock1
    dd: writing ‘/dev/mtdblock1’: No space left on device
    10241+0 records in
    10240+0 records out
    5242880 bytes (5.0MB) copied, 1.905316 seconds, 2.6MB/s
    root@WDMyCloudMirror ~ # packet_write_wait: Connection to IP address: Broken pipe
  5. The My Cloud Mirror 2 will be rebooted / The recovery screen will pop out on your web browser (you might need to refresh the tab with the same IP address. If you router does not give you a different one, you need to pop the new IP into your web browser )
  6. Download the My Cloud Mirror 2 OS3 2.41.116 firmware from https://downloads.wdc.com/nas/My_Cloud_BWVZ_2.41.116.bin
  7. Apply the firmware bin file into the recovery screen / After the firmware is installed / the My Cloud Mirror 2 will be rebooted and pop out login screen (you might need to refresh the tab with the same IP address. If you router does not give you a different one, you need to pop the new IP into your web browser)
  8. I faced the problem that I could not use my password to login so I did the full rest by press and hold the reset button on the back of the My Cloud Mirror 2 until it rebooted.
  9. Voila! You are now back to OS3 2.41.116 / Hibernate the My Cloud Mirror 2 / Swap back your HDDs / Turn it on again / Login the Web Gui / Accept the HDDs roaming / You are now back to fully functional My Cloud Mirror 2 OS3 2.41.116 will all of your data on it.


Thanks @dswv42,

That’s a really details instruction of how to revert back to OS3 from the OS5

This worked for me as well on my EX2 Ultra. Thank you for the fix.