Very slow transfer speed (only to private space) - My Cloud Home

Actually the last version is 7.13.1-163
This version is not listed on but yesterday mine received it.

1 Like

Thanks. Hopefully mine will update. It’s been left backing up at 3 - 10mbit for days now.

“could fix this problem after activation uPnP on my router and restarting MyCloud Home. Now I have ~100 MB/s transfer speed on Z: drive.”

Thank you and this is useful information. Can you confirm if you have static IP address with your ISP and that your port forwarding works through the router and that you have high internet upload speed (>100 MB/s?)


Good observation by Sergey on the router UPnP and speed of transfer of the My Home Private User Space (drive “Z:”). It is also possible that speed difference is due to a recent firmware update to 7.13.1-163. Although I didn’t get 100 MB/s, I did get 29.2 MB/s, quite an improvement from 18.5 MB/s prior to turning on router UPnP and rebooting My Cloud Home (MCH). It is possible that the peak transfer sometimes reached 50+ MB/s and one could possibly get near 100 MB/s with faster internet speed. This test was done with an ISP internet that is quite slow, at about 30 Mbps down and 12 Mbps upload. Software used for file backup was Freefilesync portable version 6.2. Beware of malware in later versions that are not portable. Firmware on MCH is 7.13.1-163

updated picture. The faster speed may be entirely due to firmware 7.13.1-163 on MCH.

Mine finally updated to 7.13.1-163. Beware, yours might update and say you have this version, but you won’t get faster speeds until you manually reboot the MCH. I know this because mine updated overnight while I was doing a backup. It never rebooted automatically during the update (because the backup wasn’t interrupted) and was still slow the next day. After a manual reboot I’m getting peaks of over 400mbit/s instead of 10mbit/s according to Windows TaskManager.

7.13.1-163 did improve the transfer speed.
didn’t correct other issues.

1 Like

I think the bottleneck now is the terrible WD Discovery software. For a system service, kdd.exe uses 2GB RAM. Unacceptable when they could use the operating system’s SMB support.

An alternative is to forget any security, just use the public folder, and uninstall the WD software.

I guess I don’t see it as a huge problem because the WD My Cloud Home (MCH) is marketed as a home unit. Perhaps if a user is routinely or daily backing up 100s of GB of data over the LAN, it will slow down the PC, but copying a few hundred MB to 1 GB as a home user might do daily, such as shown below, did not cause too much of a strain on system resources. There is always the option of directly copying from a USB HDD drive to the MCH if one is storing or restoring TB of data because that is the fastest way (100+ MB/s).

Transferring hundreds of GBs to a few TBs through the network to backup the MCH itself, takes literally days. Home user. Process consumes almost 2GB RAM 24/7 for days! The MCH home doesn’t have even the basic features the precious MC had. Not even a backup entire drive to USB option.

With the most recent firmware and software, as my benchmark shown 5 posts up, backing up through the LAN to the Private User Space took about 2.75 minutes for 4.77 GB of 300 files, the same files backing up to Public User Space took about 1.0 minute. If those numbers hold for 100 GB, it should take only 21 minutes to back up to the Public User Space and 57.5 minutes for the Private User Space.

Im getting more and more frustrated. I have been trying to sync a folder for 3 days now, and sync speed varies between 2mbps and 100kbps… most of the time the kbps. At this speed, by the time i have everything synced the drive will be out of warranty. I then found i can copy files at 20mbps by just dragging them over to the drive… However they dont sync. What is the problem with the “sync to homecloud”. I have also noticed on the home cloud i can “make available offline”, what is this feature? I was under the understanding when on the drive it was available offline? And i can find not instuctions to help? If it synced the files at the same speed as i copied i would e a very happy person, but currently I am enraged with the device.


Same. Some big files transfer quickly, but lots of small files it takes forever. I’m using Synctoy and it’s been taking days to sync folders.

Can anyone suggest how this can be sped up. Would setting it up on a static ip help? Ive got roughly a tb of information I want to sync, but this will never work. I can just copy it over but i bought the drive as a drive that would sync my files, as id expect a NAS to work. I do understand really a nas is a drive attached to network, but I would have expected the software to do its job. Google drive and dropbox are so quick, why cant this be…its local

The only way to speed things up, besides WD fixing it, and besides buying someone else’s product, is to abandon all security, uninstall WD Discovery and just use the Public folder locally via SMB.

So even if i wasn’t to use WDs software it would still sync slowly. That was my next test to see if that would make a difference.

Thanks for saving me time. Time i can spend erasing what data has been transferred and putting it back in its box to return and get something that works.

I looked at getting synctoy too. Discontinued mid january. How is your MCH setup? Port forwarding? I read in a post on WD Knowledgebase saying that was the best setup. 3 days countdown till i return it

FreeFileSync uses the Windows Volume Shadow Copy service to read locked files and synchronize them, Synctoy can’t do that. FreeFileySync is consistently 10 to 20% faster than Synctoy. If any users are attempting to sync hundreds of GB to TB of data at a time with background processes of indexing, they should be looking at a high end NAS which could cost 5 times as much as the My Cloud Home storage products.

1 Like

thanks tekram.

Was looking at this also

I gave up on syncing it all and cut it down to 30gb, even after a week its still not done.

Didn’t think id have to spend hundred to have a sync’d backup, of what WD say it should do. Why publish this software if its not supposed to be used for this. I thought this was a step up from a standard external drive, which i could have had backed up 2 weeks ago. Could just use dropbox or drive

I have been so close to returning my mycloud home, but i have found I am getting sync speeds of 120mbps now which I am happy with. It is syncing the way i want it. The only thing im finding now is occasionally when i come to update a folder or sync it, everything turns to the blue sync light… But nothing. To actually have it sync properly I have to unplug my ethernet cable from drive for a minute of two, then plug it in the transfers fires up. I know everybody is saying just take it back, but this is almost what i was expecting from it, but why do i have to disconnect then reconnect for it to trigger a proper sync???


I just got 8TB MCH to replace a 4TB MC as WD stopped remote access support. I like being able to access my pics on my phone remotely. I figured the MCH would be a logical improvement

Even after more than a year since this forum thread stopped, I’m having the same issue with Win 10 PC and I see no fix has come about.

The sync function takes forever (I have about 3 TB of photos) and I think has locked up. No more disc activity on source drive, and still blue “not yet sync’d” icons on folders. No way to check/fault find progress either.

Drag/drop is no more than 18MB/s (100+ to public share) over 1Gbps wired connection and Synctoy, which I used with 4TB MC, just hangs after a few hours of ‘looking for changes’.

This MCH is poor, and the WD software a farce. WD discovery app even suggests software downloads (security, backup, utilities) under an image of MCH but NONE are compatible with it.

Acronis only worked when pointed directly to the public share. And is recommended by WD.

I have UPNP enabled on my router, and web app on desktop says ‘relay’ as connection type. My iphone on same LAN via wifi says ‘local’ using mobile app.

I just want to back where I was with the 4TB MC, fast reliable transfers using synctoy or similar, with remote access

1 Like