Very high Load_Cycle_Count (over 5 000 in less than 180h)

From the same web site, but not the forum…

How to Stop Excessive Load Cycles on the Western Digital 2TB Caviar Green (WD20EARS) with WDIDLE3

1 Like

For your interest.  (References to WD staff removed.)

I posed a question to WDC technical support and made a reference to:

The S.M.A.R.T Attribute 193 Load/Unload counter keeps increasing on a SATA 2 hard drive

Answer ID 5357   |    Last Updated 03/16/2011

The reply I got:

“As explained in the knowledge base guides surrounding this ‘issue’ the problem with high LLC count only occurs in third party enclosures. Our enclosures are designed to take advantage of the increased power saving capabilities available from the GP range of drives and as such there is no need to modify the internal workings of the unit. In fact, there is no way to change the idle mode for our external drives, let alone the network attached ones, as this is not going to be an issue.”

“As the guide you linked me to explains, our drives are now tested to over a million cycles to prove that the technology present in the drives is reliable in the right enclosure, in fact the Intellipower features should result a longer drive life as there is less wear in the drive overall.”

Comments welcome.  :smiley:

1 Like

BS reply :slight_smile: I simply dont believe that…

8sec cant be right value for any hdd in Linux system.

There is something else for you - with MyBook World Edition (whitelight) - these default 8secs results in very annoying click-click sound repeatedly from hdd - thats when heads trying to park but cant due some Linux process waking them up again. I did changed default value for MyBook World Edition also, and as expected “click-click” thing stopped immideately.

With MyBook Live you almost cant hear any “click-click” becouse hdd inside is more newer model and probably also due fact NAS unit does have more “cache ram” for doing little things without waking up the drive (for example i can use IRC from MyBookLive when hdd is in stand-by mode perfectly), and you can make them even more quiet as explined here -


Im not saying that reaching superb high value is not possible. It seems it is possible, becouse somebody from other forum sent me details about his WD MyBook (BlueRing) stats. Here they are:

9 Power_On_Hours 0x0032 072 072 000 Old_age Always - 20560
193 Load_Cycle_Count 0x0032 001 001 000 Old_age Always - 1151823

 So… over 1 million cycles.

1 Like

jazzymood wrote:



Im not saying that reaching superb high value is not possible. It seems it is possible, becouse somebody from other forum sent me details about his WD MyBook (BlueRing) stats. Here they are:


9 Power_On_Hours 0x0032 072 072 000 Old_age Always - 20560
193 Load_Cycle_Count 0x0032 001 001 000 Old_age Always - 1151823

 So… over 1 million cycles.


WD have already said that it is possible. 


“drive has been validated to 1 million load/unload cycles without issue”

1 Like

Ok. Running an experiment.  I’ve seen in a technical document on WD’s site that some drives have had the intellipark ceiling raised from the default 8 seconds to 300 seconds.  I’m going to try the same and if the LLC does not increment like a junkie deprived of his/or drugs then I’m leaving it at 300 seconds.  I did have it set to 390 seconds.

8 seconds seems like s stupid ceiling and with the drive on my NAS spun down (after 10 minutes) most of the time the power saving offered by intellipark will be close to invisible let alone negligible.

1 Like

Symptom: Attribute 193

WD drives are designed to reduce power consumption, in part by positioning the heads into a park position (unloading the heads) and turning off unnecessary electronics, resulting in substantial power savings. WD defines this mode as Idle 3. Some utilities, OS’s, and applications, such as some implementations of Linux, for example, are not optimized for low power  storage devices and can cause our drives to wake up at a higher rate 

so the drive will park the head every 8 seconds and the OS pull it back to active state, causing the heads to dance around continuously?   So Debian is not optimized for green solutin ?! hmmm .    Unloading the heads while there is no hard drive activity *must* be a good thing.   Implementation doesnt seem to be quite SMART though:stuck_out_tongue:

1 Like

ARM Linux which is used in MyBook World (WhiteLight) is also “not optimised” then.

Actually I can’t imagine any Linux OS which is :slight_smile:

1 Like

I have not been here in a while. But I have been reading all the posts with great interest.

Thanks to all those who have found a solution. Thanks for trying several parameters and their effect on the disk temperature.

While parking the heads every 8 minutes or so allows to delay reaching 300 000 LCC in about 5 years, it is quite a large value. Also, with 2 MAC computers triggering a backup every 1 hour each (not synchronized), it helps, because the disk is spinning half of the time anyway…

Also, if you allow me, somewhere in this discussion I did read :

“Remember, to shut down the MBL, pull the power and re-insert”

Well, this is a very bad idea. And a good way to (possibly) loose some or all of your data.

You should either send a “reboot” or “shutdown -h +0” or “halt” command, depending on the effect you want to achieve. This is a safe, clean, way to do it.

Maybe there is even something in the web interface that can just do this. I don’t know, I have deactivated it to free some resources.

Oops. I put a “,” in instead of “then”.  (if that was my comment 'cos I’m commenting before finding my post.)

Yes, perform a controlled shut down BEFORE pulling the power cord.

1 Like

I think (will have to examine te scripts) that shutting down the MBL through the WebUI may also perform additional shutdown tasks that “reboot” or “shutdown -h +0” or “halt” won’t do.

As to the Load_Cycle_Count?  I can live with 13 within a 24 hour period as opposed to a few hundred.  I may try reducing the idle3 parameter to something like 2 minutes from 5 to see what happens but if the drive is set to spin-down after 10 minutes then what is the point of the heads rapidly parking and unparking?  Ok, so the electronics can draw less power but consider the mechanical stress.  So WDC design the drives to cope and there are drives that have Load_Cycle_Count well in excess of a million, but if the drive dies then the data dies with it. Usually data that can never be replaced (emphasizing to back-up the important and uber-important stuff!) so better find a good balance of power saving and reduced mechanical stress?  At least WD have ridded the Linux OS to write the logs to a ramdrive which gets flushed to the disc on shutdown (A reason to shut-down the NAS using the WebUI).

If one’s going to run their own apps that don’t use a ram cache of some sort then of course the drive’s Load_Cycle_Count will go up like a bunch of squirrel on a high dose of steroids!  (This is where idle3ctl is of use)

Just morning thoughts on the issue before my mind gets clouded with the scheduled noise of society.  :smiley:

1 Like

3 minutes set for idle3 seems (preliminary) to be ok.  Just tried and and kept a watch and the heads parked after 8 minutes. Will be some internal processes writing or readinjg from the disc resetting the drive’s counter.

1 Like

Ok folks. After a copious number of hours of testing, well more of setting and observing…

An Idle3 setting of 30 seconds seems to be acceptible. The Load_Cycle_Count does increase but it does not go up at a rate that would be comparable to a nuclear reaction that’s out of control.

NAS:~# idle3ctl -g /dev/sda
Idle3 timer set to 129 (0x81)
NAS:~# idle3ctl -g103 /dev/sda
Idle3 timer set to 30.0s (0x81)

 A setting of one minute allows head loading/unloading but it happens a lot less frequently.

NAS:~# idle3ctl -g /dev/sda
Idle3 timer set to 130 (0x82)
NAS:~# idle3ctl -g103 /dev/sda
Idle3 timer set to 60.0s (0x82)

 I’m gonna rest in peices now with the setting at a minute. No need to play with this anymore. :stuck_out_tongue:

Thanks for this excellent description how to add the idle3 timer to MBL.
However, I was stuck at this point:> * * *


  1. make

    If it displays that make not found, you need to install it using apt-get install make

    Probably in this case gcc is missing too. You can also install that with apt-get install gcc

I got this error:

MyBookLive01:~/idle3-tools-0.9.1# apt-get install make
Reading package lists... Done
Building dependency tree... Done
E: Couldn't find package make

 And this solved my problem:

apt-get update

 After updating the package list, I was able to download “make” with apt-get install make.