Unwritable drive

Hello, I bought a My Passport Essential (USB 3.0) last week, 'n when I conncet it to my NetBook (Windows 7 Starter 32-pits), the NetBook recognize the drive 'n it sends a massege saying that the drive is ready to use, bbut when I open “Computer” I can’t find it…!
What should I do…? 

Go to disk management and see if the drive shows there

1 Like

I’m sorry I’m late, but it doesn’t apear in disk managment…~
is there something I should download or something before I connect the disk to my netbook…?

I have the same problem.  I have just bought an external drive My Passport 2TB from Amazon.  My Macbook can detect it but it would not allow me to write anything to the drive.  Basically I can’t use it because the permission is 'read only".  Please advise me on how I can make it writable.  Thanks.

1 Like

If you find a solution, please let me know, I need to use my HardDesk…:confounded:

Mac OS can only mount Microsoft NTFS volumes in readonly mode. In order to write to an NTFS partition, you need something like the following:


There was also a utility called “NTFS-3G for Mac OS X”:

Here’s another solution:

Enable native NTFS read/write support (in Snow Leopard):


but I don’t use Mac…=S

It’s Windows 7   32bit

http://wdc.custhelp.com/app/answers/detail/a_id/3868 This have worked for me it will format the drive and make it appear in computer :wink:
Did you plug your hard disk in your tv and formatted it to your tv? Because if you did that this is the solution to your problem :smiley:

1 Like

well, I didn’t plug it to anything but my laptop…=\
but I’ll check it out and let you know if it worked…=)

Thank you…

This is what I get when I reach step 4…:cry:


969 Views with no one sullotion? :cry:

This worked for me as well!!! :smileyvery-happy:

I found a sollution, I just made “recovery” for the WD installer, I did it before, but it didn’t work till now. Thank you every one.

What do you mean that you ‘made “recovery” for the WD installer’?  How did you do that, please?