Unable to eject 4Tb my passport for mac

Hi,

I bought the 4Tb my passport for mac to store all my photographic images on. I copied all the folders I needed to it and set up the WD utilities.

The first problem I noticed was that after coming back to the macbook after a period of time the software catalog that I use which is Adobe Lightroom cc was no longer reading the drive, I tried opening it in finder which showed it to seemingly be fine. So I shut down all apps that may be using it and tried to eject the drive. However the drive would not eject and the error message that appeared was informing me that one or more programmes were still using it. Could not see what though.

I bit the bullet and forced the eject, but the same thing keeps happening and I can’t eject the drive. The WD utilities will not run scans or repairs on the drive either. I have reached my limit of knowledge on what to do next so any help would be greatly appreciated.

The Drive is a My Passport for Mac 4Tb
Product: 25E4
Firmware Revision:4.004

And my mac is the macbook pro mid 2017 running El Capitan 10.11.6

Cheers,

Lee

2 Likes

Hi there, try to uninstall and reinstall WD Utilities. After you reinstall, retry scanning/repairing the drive. As for the drive not ejecting, try it on a different computer, if possible, to see if you experience the same issue.

Hi,

Thanks for your advice. I tried to uninstall the wd utilities, but was unable to do so. It then dawned on me that although I had switched it off, time machine was backing up to a folder on the drive. So I removed that from the drive completely. Then I tried to open the wd utilities in applications, but their icons were greyed out. But the wd utilities install icon then appeared on the desk top. I installed them and carried out a full scan. The result was a fail, but I can’t seem to find any further information as to why.

However, lightroom now seems to work with the folders on the drive, and I am able to eject the drive with no further error messages. Hopefully this will continue. It would be useful to find out why the drive failed the diagnostic though.

Thank you very much for you help, very kind of you.

Cheers, Lee.

Hi,
Mmmm! I seem to have spoken too soon. Lightroom put up an error message saying it couldn’t read files. I opened the drive and it appeared to be empty. I shut down any programmes that might be using it and attempted to eject it, but it seems that I am back to square one and it says that one or more programmes are still using it ant it won’t eject. Time to chase up the ticket I put in yesterday.