Unable to access shares as keeps asking for Network Password

I just set up my ne My Cloud Mirror today and everything went smooth to start with.

I got all the hardware and software installed and it worked fine.

I updated the firmware and it also updated the My Cloud mirror.

I took a deep breath and copy and pasted a small directory from my hard drive into a share folder I had created.

It worked.

When I tried to copy and paste another small directory into the same shared file a box came up asking me for my Network username and password.

I tried every combination of usernames and passwords that it could possibly be but to no avail.

This same message came up when I tried to open any of the shares that I had created so I couldn’t access any of them.

The empty public shares could be accessed without a problem.

It appears that I can open that 1st shared file that I mentioned from above with my iPhone without a problem.

Please help as I can’t think what to do next.

Thank you.

Sometimes I get a different message stating ’ I do not have authority to perform this action’.

I am really struggling with this as I thought things were going so well then this.

Any help will be gratefully received.


I have double checked all the settings in users and shares and all appears correct.

In desparation I even rebooted the My Cloud Mirror but still no joy.

My daughters keep saying they are sorry as they bought it for me at Xmas but through gritted teeth I am telling them it is not a problem.

I have tried taking passwords outs and returning my own user details back to admin.

I tried copy and pasting again and got asked for my network username and password. I put in admin and with no password and it seemed to take it but then threw up another mesage: 

\\All3Girls is not accessible.

I am getting worried that I am trying so many things that I wouldn’t know how to get back to the start.

I keep saying to myself, ‘a little knowledge is dangerous’.


 I stayed up late last night trying to sort out the problem and think I may have sorted it.

I kept looking at posts in this community and found the following


I went into control panel and users then removed my password and everything started working A1.

Pete is now a happy bunny (at the moment…lol)

Hi Papadadio, welcome to the WD Community. Thanks for sharing what worked for you.