Twonky DLNA

I have used the twonky DLNA for a long time now and it has always worked well streaming to my smart tv and also my WD TV live. On rare occassions it glitches a bit but I find a restart of the NAS sorts it out nicely.

Anyway recently the Twonky DLNA has been dissappearing quite a bit or taking a long time to show up when the TVs populate the DLNA servers. It’s also the same using apps like Twonly Beam on my iPhone, the twonkly DLNA is often missing or takes a long time to show itself. No proble, I thought a restart would help and it was ok for a while but soon started doing it again. I rebuilt & rescanned but still the same. I am having no issues accessing the mybooklive:9000 interface via web browser. It’s just getting very frustrating especially for my wife who is not technical and just wants to be able to switch on our WDTV and start using the Twonkly DLNA. Any ideas?

I do also have an iomega hmnhd NAS and whilst I am not that impressed with it, it does also have a twonky server on it which is absolutely rock solid. I never see it dropping / dissappearing at all.

I could try the WD DLNA patch but would rather try and get the twonky media server working reliably. When it is visible there are no problems, everything works and I don’t got dropped mid stream (at least not so far as I have noticed). The problem is it’s visibility is hit and miss when going into media servers.

Many thanks,


You tried updated WD Twonky to Twonky 6 via SSH? (Voids warranty)