Trouble uploading photos from iphone

Hi I am trying to upload photos and apart from when I just uploaded 50 they are not all appearing in my my cloud folder. I’ve tried select all and also just selecting a number of them, what is going wrong?
Is it also right that I cannot see the status of the upload as well?
I’m assuming that in my cloud settings the cache chosen is the most that can be uploaded at anyone time and is the memory the phone uses to upload?
Any help appreciated.

There are lots of recent posts here about uploading photo issues, did you look around for any?

You did not mention what kind of phone you are using. For now I will assume an iPhone, so here is important info I posted a few weeks ago regarding uploading from an iPhone/iPad. If you have an Android phone, then disregard.

IMPORTANT: for very large uploads (such as a complete and full iOS Camera Roll,), the iPhone/iPad Auto-Lock control needs to be set at a high value (meaning, set to Never,) BEFORE the upload begins, or else Auto-Lock will likely time out, step in, and shut down the iPhone/iPad, and your uploading will stop before it completes. (WD Support says Auto-Lock is a battery-saving design feature of iOS devices.)

Also, for large uploads, have a fully charged iOS device, and keep My Cloud app in the foreground during uploading.

Be sure when all is completely finished to put your Auto-Lock control back to where you had it set (at 5 minutes or under).

Subsequent auto-uploads may not require resetting Auto-Lock if only a few items are uploaded each time.

I have been told by WD Support that Android devices do not have this issue.



1 Like

Hi Mike sorry yes it’s an iPhone. I did the auto lock but I think it doesn’t have enough memory’s I do select all so will try doing a smaller number of files. I assume it needs to have enough memory and the cache set high enough for the files to transfer over?
Thanks

Jo,

The cache, memory or storage capacity does not have anything to do with uploads.
My iPhone is only a 16GB phone, not a problem, other than I can’t store much on it, but then again, I don’t store much of any media on iPhone or iPad – I stream media to phone/Pad instead.

The cache size differs for every device, based upon the phone/pad storage capacity. Since my Phone is a 16GB phone, my max cache available 16GB, but I do not want to use the max, so I have it set lower to 8GB. My Pad is a 64GB model, so again, I do not have it set to max, I have it set to 20GB.

What is the cache used for? Examples: it is for storing a streamed movie as it is buffered in device. It is where anything you download with My Cloud app to store in the app’s Downloads folder. Say you want some photos from on your My Cloud stored in your phone (example is a photo taken with you digital camera) Or, you want to store some movies on iDevice for watching on an airplane trip using My Cloud app.

The cache will fill to the cache size you had set. Items cached can be deleted individually. If you want to delete all of them, you would tap “Clear cache” and every item stored in cache is deleted. Use with caution if you have multiple items in cache, and delete them individually. Lastly, don’t let cache fill up, get forgotten and waste valuable storage space in iDevice.

Now, back to you photo uploading issue. Some tips:
Remember to set Auto Lock to Never for duration of uploads.
Have your phone near your router; in same room is fine.
Use 5G wireless signal if possible.

Before you begin,
– Rename the first folder of uploads you made to My Cloud. If files are not in a folder, then put them into one. Next upload, the MC app witl think there are no files uploaded, and upload them all.
– Another “gotcha” is that the My Cloud app only does auto uploads if the app is completely turned off and then restarted, as that is when auto-backup will begin. Use wi-fi to upload. If you do not have auto-backup set up, do so in Settings of iPhone for app.

For this particular upload you really ought to upload everything on the iPhone Camera Roll to the My Cloud. Afterward, you can go into My Cloud to delete any files you really do not want to keep at all. You also have to delete same ones from iPhone or else they would be uploaded again next time you auto-backup.

I actually used auto-backup just once, then moved the files on My Cloud into specific folders. Now, I can’t use auto-backup going forward or else stuff still on the phone will be uploaded again, so I now exclusively upload new files manually and individually.

Any more questions, let me know.

1 Like

my Iphone has Album with 600 Pics… When I use the WD My Cloud App to upload to WD My Cloud (after add photos Step) For some of the Albums the Count that WD My Cloud shows does not match to the Album Count on Iphone.
Iphone is setup to upload to Apple Icloud pics…
Could this be that the images that are on Apple ICloud, WD app cant see those in other words it only sees files on the Device (Iphone)

Trying to move Icloud Library to WD Cloud as ICloud does not work well with Windows …
If anyone has above issues, would help if they can share what they did to transfer ICloud Library to WD My Cloud NAS server…
Thanks

Surely you can move icloud pictures back to your iThing, and then use a decent file manager app to move photos from iThing to MyCloud. FileBrowser seems to work well.

I have a WD MyCloud and am trying to upload photos from my iPhone 6S, 32GB (iOS 12.1). I have read and followed all suggestions I’ve found on this topic including https://support.wdc.com/knowledgebase/answer.aspx?ID=18969&lang=en and Backing up iPhone/iPad photos with My Cloud app? READ THIS.

App settings are set up correctly for auto back up and new photos appear to be uploading when I close and reopen the My Cloud app. My iPhone is connected to my 5 Ghz Wifi connection but I don’t think the upload is the issue. The My Cloud App activity status shows the auto backup as “Completed” but the app only seems to be recognizing 82 of the photos in my camera roll instead of the 5,123 showing in all photos in iPhoto. Any suggestions?
thanks

Start over by creating new folder to upload into. Be sure auto-lock of phone is set to never. be sure to close MC app completely before attempting upload. The app only checks for upload when it is first turned on from completely off state.

To me this has happened to when using Android phone aswell. Earlier the issue was happening with iphone. It seems like you have to keep the apps open at front while uploading or else the WDMYCLOUD goes offline.

Now, This is regardless to Android or iOS devices. It is really frustrating that we have to restart the machine again and again to get the MYCloud services back.

Still trying to find a permanent solution and not a workaround.