Tried R-Linux with my 3TB My Cloud but cannot read files

Hi WD Community,

My 3TB My Cloud stopped functioning, I could not access it, and so I took the drive out and tried recovering it using R-Linux. Unfortunately, at the moment, I cannot find my files. I tried the instructions here (R-Linux help), but the J: drive (2.72TB) only shows a bunch of the following files with nothing in them


  • $BlockBitmap
  • $INodeBitmap
  • $InodeTable
  • $SuperBlock

If you can please share how I might be able find my files, I would really appreciate it.


Hi, unfortunately I am not knowledgeable in linux.

As you need the information out of the drive you should contact a professional data recovery company.

Are you attempting to use R-Linux on Windows to view/recover files from the My Cloud?

Have you tried using a Linux OS to see if you can even access the partitions and view their contents? One can use a Linux Live CD ( boot disc like the popular Ubuntu ISO to launch a PC into Linux outside of the Windows OS and view/access a My Cloud hard drive attached to that PC.

Hi Bennor,

Thank you for responding.

Yes, I am attemptin gto use R-Linux on Windows to view/recover files from My Cloud.

I have tried Ubuntu Live CD. I can see the drive under drive, but I am unable to see the contents using the file manager. How can view my files?

It appears from the Ubuntu screen capture (second one) the various partitions of the My Cloud hard drive are not mounted. Try mounting the partitions. Typically the data partition (shown as partition 1 & 2 in the first screen capture) will show up, and may mount, as a RAID partition.