Tried lots of things, no solution


#1

A few days ago, I was using my passport HD and I dropped my lighter (unlit) on the USB cable, which caused my HD to disconnect. Since that time, and never before, I am now prompted to enter a password, one which from disuse I cannot seem to remember. Also, I dont remember setting a password at all. Windows thinks its a driver problem, but I cant remedie that until I unlock the drive. WD thought it was a power problem, and now I’m using the Y-USB cable to no avail. Is there a default password like on some HD models that I just don’t know about or am I simply too foolish and stupid to no have set or have memory of my own password? Note on that: I’ve tried every password I may have set. Nothing seems to work.

I’d prefer to not reformat my HD if possible, but recognize that option may be my last. And now I know better to set and remember a password. Cheers


#2

If there were any files still cached when the cable was disconnected, corruption may have occured.  If you know the password and it’s not unlocking the drive, it may have been corrupted as well.  You may be stuck with reformatting the drive.  If you get the incorrect password five times, it will ask you to reformat.  You can do it then.