The discovery utility failed to find my device on the network

The Discovery Utility failed to find our My Book World Edition II on my business network. I wanted the My Book to have a static IP like some of my other servers and network hardware, and needed to know how to discover and configure the device.

Tech Support suggested that I reset the device, but that did not solve my problem.

After much trial, my IT Manager suggested that I change my local Windows XP computer (which I had the discovery utility installed on) from it’s normal Static to Automatic DHCP IP Addressing, and that I also change the PC’s DNS settings from Static to Automatic. After making those 2 changes, the Discovery Utility successfully found the My Book on my network.

Once the My Book was discovered, I was able to configure it into Static instead of DHCP Client mode. After I returned my local PC to its origional static IP and DNS settings, and wait a few minutes for the dust to settle, the Discovery Utility was still able to work properly.

There was nothing that I found in the User Manual or on the Knowledge Base or Community which addressed this issue. I cannot beleive that I am the person in the world who has ever had this issue.

No, I’m sure that we are not the only two people to have problems with WD Discovery finding our World drives on a network. However, I have not found many postings anywhere on the Internet that address this problem.

I can access my White Light drive from all five computers on my network (all running XP), and I have assigned drive letters as necessary, but WD Discovery cannot fine the drive and so I cannot use any of the software that comes on the CD-ROM.

Your fix looks a lot like a random event, since all of my computer get their IP addresses from the DCHP server on my router. I expect that my problem has something to do with Windows firewall or my anti-virus software.

I will try WD customer support today to see if they have this problem already worked out.

Has anyone else already got around this problem without having to change from static to dynamic IP assignment?

I have the same issue. select WD Discovery from the CD, and Windows Firewall and Spybot gave a warning.  Have not got working still, despite making exceptions.  It just comes up with “WD Discovery has encountered a problem and needs to close” repeatedly.  Have also tried Dynamic and Static IP.  I use Time Capsule (XP) as my NAS. It works but I cannot access the WAN- ie. YouTube, Flickr.  Hope WD post solution in Support portal soon.

Network Connections on WD TV says Network is fine, but when I “Check Connections” it cannot resolve the DNS, it has no spaces or special characters either.

Have the same problem as jeffsmith and i thing that this solution can work for me too, I will try and let you know if it helps or if WD support can give me any other solution if i didnt reply any more my reference ID is 100106-004444 so you can find out…

I also havent connected yet . Discovery tells me that  no network drives were found . Have tried everything but no joy . Disabled firewall but nothing happened

“Discovery” finds my MBWE on XP, it just does nothing when I click “Map Network Drive,” and it can’t be found on the network outside the software, either. Oddly, Twonky works, but any file uploaded from the XP computer is deleted the second anyone tries to access it.

It would be nice if WDC would answer its e-mails.

You can try a network scanner to see if the drive is on the same subnet as your computer. One that I like to use is SoftPerfect’s Network Scanner ( http://www.softperfect.com/products/networkscanner/). It’s free. It’s small. It doesn’t install anything. You just download the EXE and run it.  The download link is on the right, under Product Info.

Once you download it, do these steps:

  1. Run it

  2. Go to the menu item Options -> IP Address -> Detect Local IP Range or click the Auto Detect IP Range toolbar button (to the left of the Help icon, it’s a box that says “IP”)

  3. You’ll see a pop up that says “Auto Detect”

  4. Choose your IP address. Do not choose the 0.0.0.0 or 127.0.0.1 options.

  5. Click OK

  6. Click the “Start Scanning” button at the top

  7. Wait for it to finish

You should see your device show up on the list. You can access it by IP address once you see it. It will probably show up with a name like “static-host.home” or something. There should be a plus sign next to it. Clicking on it will show the shares. Right-clicking a share gives you some options, including mapping a drive.

If you right-click on the IP address, you can pick Open Computer - > As Web (HTTP) to get to the config pages.

This program isn’t as simple as the Discovery utility, but it sometimes finds the device when Discovery can’t (it uses a different method of scanning). If the network scanner doesn’t see it, then it’s not showing up on your network, and you’ll need to do more troubleshooting.

2 Likes

Thanks for this. We’re closer now – the Network Scanner is finding the device, but it cannot see the folder shares; there is no plus sign. The computer should be able to see the Download and Public shares, at least. So nothing can be mapped.

Why would XP not be able to see the shares on the MBWE?

All… i’m new to this thread but I am on my 3rd MWB.  The 1st one wouldn’t show up on my network.  the 2nd one had the same problem.  I’m on my third and it is still having issues.  From going through so many drives, it makes me think it’s not the drive anymore.  Does anyone have any suggestions… I’ve tried the following “solutions”

  • Connect the drive directly to my PC through the ethernet cable… got the “limited or no connectivity”

  • Disabled the firewall

  • When I ping the drive, it says nothing is found

  • Tried a hard reset on the drive but that did nothing…

Any ideas would be greatly appreciated… please help!

yeah similar thing here. Got the drive mapped to all house computers then started losing it. File transfers stopped as drive no longer available.  Think maybe the router is changing the IP address randomly or possibly when another device asks for that IP. Anyway, changed to a reserved/static address at the router and static on configuration page. If you cant access after type in IP and it should get to login page. Very slow on Internet Explorer tho. Drive should then be viewable in My Computer.  Biggest problem I’ve had is that the latest TwonkyMedia server is not compatible with my Pinnacle Soundbridge music streamer. Still waiting for response from WD.

Chankew, I think thats down to the setup of your network card  or router not the drive.

i have the same problem.  i have no clue how to fix it.  just waiting for support to get back to me.

Just remember that if your MBW is not with a fixed IP adress, you should pass thru a router  or Hub with DHCP server to give an adress to your MBW and to see it.

My two cents worth after a lot of frustration!

(A) Windows XP - didn’t detect my device no matter what I tried (changing DHCP, firewall settings etc.)

(B) Windows Vista - detected the device instantly

© Apple Leopard - detected the device instantly and in true Apple fashion is also the easiest to use

WD staff - please try and fix the utility for Windows XP - I am using Windows XP Service Pack 3

Thanks, netscan is an excellent program.  Works a treat on XP machines which don’t seem to respond to the WD discovery tool even when UPNP has been enabled. 

NAS-T, you are the MAN! What  great little bit of software. Solved my issues in 5 minutes. Goodbye WD Discovery, you are toasted toast.

For what it’s worth we have found uninstalling - not just disabling - the firewall seems to cure the problem of not finding the external drive.  This has worked on XP, Vista and now a Windows 7 installation on a new Toshiba laptop.  We use Eset internet security on all our machines.

Cheers

Thank you NAS-T.  I am going from XP to Windows to Windows 7 and your recommended downloaded worked well.  2 minutes. Thank you. 

You is one hero :slight_smile:

That worked perfectly. I needed to give access to my work laptop, on which installing software is blocked (i.e. couldn’t install WD discovery).

Many thanks!

Hi Yall!

My nice white paper weight does not work. My router (linksys 610) seens it for few sec when powers up, then the top & bottom led blinking few times, (assume that is some kind of error or what since the user manual book says nothing but how to plug the unit to the wall in 321 languages) then network goes out of the window, and a big nothing (like WDC customer care).

Changed, lan port on routher, lan cable, automated then dedicated IP for Mac address on DHCP, swiched on and off router firewall/ PC firewall.

But nor my PC (win7), my laptop (win7) or WD live does not sees it.

Im out of options, totally…

Thanks for WD support to not answering my emails…