Suspendisse Eget Bibendum

I have the EX4100 made the mistake of upgrading to OS5,
Question … couldn’t I just try to manually install the OS3 Firmware latest Release 2.41.116 ?
Won’t that revert my OS5 to OS3 ?!

Thank you in advance,

well now I have to think real hard what i want to do …
downgrade to OS3 you’re way or wait for WD to add features to the OS5 Android App that are all ready in the WD Photos App (works great on OS3 for backing up Photos and Videos from android cellphones)

Thanks for the assist :slight_smile:

Go for downgrade, let’s see if we have third person with bricked hardware.

Ya since I don’t want to brick my EX4100 it looks like I’m going to postpone it …
On the other hand I sent an E-Mail to WD support for an official downgrade path , may be if they get more E-Mails like that they might actually do it :thinking:
So lets rally up and start sending those E-Mails :slight_smile:

1 Like

Thanks :pray:

" If a cyber security breach occurs despite having taken all measures, then there will be no legal breach. It is worth noting, however, that the regulator sets a high bar for demonstrating that all appropriate measures were in fact in place."

As the old firmware has ( NOW ) know problem - how can WD even support a return to the old firmware.

I plan to wait and see if the next few firmware updates help before moving from EX2 to faster PR4100 where the indexing as least is not a bit problem.

Awesome post!!! Another sucessful revert.
My Cloud EX2 Ultra success back to OS3…

You can upload a video of how to do it. Thanks


The most recent OS3 version is 2.41.116

Anyone know a location for an older version of OS/3?

I happen to have an OS/3 machine running an appropriate older version. . .any way to get the necessary files off of that machine? (both machines are EX2 ultras. . . .but the one running OS/3 has larger HDDs)

well it appears i am also a member of the bricked club.

after running the commands exactly ( re read once i had typed 3 times ) On reboot it cant obtain an ip address in any way and the screen says firmware update failed before going blank. it shuts down when i press the power button but in no way tries to connect via ip.

i dont want to chuck it but am gutted that this has happened. I’m not blaming anyone but clearly this does not work for everyone and the original post should highlight some of the outcomes before it describes how to do the process.

I mistakenly only read the comments after i had tried the process and now have a brick.

Greetings, your procedure perfectly worked on my My Cloud EX2 Ultra, I created a account just to say thank you very much !

hi, have you had any joy fixing this?? i screwed mine on saturday trying this guide, sadly i did not read the comments 1st

I had no joy and decided to buy small server instead.
my hardware is still ■■■■■■ and waiting for miracle…

hi. after i erase config files, my EX2100, i off my EX2100 power and on it again, its keep blinking in RED LED non stop!

I cannot access to my dashboard anymore. (even I enter the “http://wdmycloudex2100/” into the web browser.

My EX2100 is same as yours!! any solution?

I have a new EX2 Ultra (received 8/17/2021), that I tried to revert and I believe I’ve bricked my device.

Because the device is new with no data I decided not to remove the hard drives.

I ran the command as given, following all other instructions but the device will not obtain an IP, nor is it seen on the network.

Question: Is there OS data on the hard drives that pulling the drives before executing the commands will have preserved?


I am finally getting a few minutes at home this week - - - - and may get a chance to finally roll back my OS/5 test box to OS/3.

Are the instructions in the first post the most recent thinking?
I have SSH’d in the past; but I am by no means a LINUX expert. . . . so any last minute tips would be appreciated.

I was going to make this a private message. . . but your box is blocking messages. A private response would be fine.

Main stumbling block is finding an “older” OS/3 than the last one released. . . .but that is not why I am writing.

We need someone to post the version of OS3 that will successfully downgrade. The latest OS3 version will brick the device

Thanks for the update. I will give it another try.