Suspendisse Eget Bibendum



So the router may be supplied by the ISP. . . .but surely it has a brand name and model number on it?

This smells like a network issue to me as well. . . . I am suspicious when you say it is an ISP supplied router. . . .I wouldn’t be surprised if there is something “strange” in there that is causing an issue.

Do you have another router lying around? I definitely would hook the PC and the NAS up to another router at this point and see if something different happens. You don’t need an internet connection for this other router. When you set up the other router. . . .there is likely an automatic configuration for automatic DHCP. . .which is what you want.

At this point. . . there may be something fundamentally wrong with the hardware. As a last resort, you can probably get the data off the drives using a USB enclosure and some software that can read a linux EX4 formatted HDD (hmmm. . . that would work for JBOD and Raid 1; but if it’s a stripped raid. . then maybe not)

@meraxx it really depends on how well you can use the router. Most easy is to take the device round to a friends house that has a more user friendly router than yours sounds to be. You need to look for your devices mac address in the lan attached deices.
You can also attach the pc directly to the device but you would need a null ethernet cable (aka crossover cable) and then use arp directly from your pc to the mac address (google this for details), it’s pretty easy but you need that cable.

Connect pc to device using crossover cable
Reboot PC
reboot wd device
let it warm up and give it a couple of minutes
from command prompt type “arp -a” and look for the mac address
(ipconfig isnt really helpful)
good luck
PS Is the ethernet port on the wd device lit up and flashing away? If so then it’s working and it’s just a question of how to get to it - Sorry so simple and I only just thought of it!

I tend to cut myself a lot with that razor

ethernet cable note.

the need for crossover cables has been eliminated with more modern equipment. Gigabit Ethernet was created with a widely used option called Auto-MDIX (automatic medium-dependent interface crossover). This technology detects whether you need a crossover cable or a straight-through cable, and it automatically configures the network interface card accordingly.

– ie it adjusts not only speed but which lines are TX and RX

I do keep both types around as old equipment may need it or a Ethernet Crossover Coupler

AND watch out if using a router connected to a cable modem - you can have two devices giving out IP address


I have followed procedure on my EX4100 (it was set to DHCP).

After restart on LCD it says update failed, which is expected, and LED’s are blinking RED.
When playing with UP/DOWN buttons I can see IP says

I cannot find device on my ARP table on the router at all.



After few more restarts and cables switch from port 1 to 2 to 1 - IP ADDRESS SAYS DISCONNECTED now.

However still cannot see device in ARP table.


Crossover cable has arrived from Amazon.
I have set up static IP on my laptop ethernet adapter, configured SERVA to serve as DHCP server and connected cable to EX4100. No joy, nothing is being given out, nothing in log file, nothing via arp command etc… Tried also with normal network cable, same thing… Out of ideas for now, but looks like BOX is done for good.

Hope someone reads it before trying this not tested procedure on EX4100…

Had trouble to access to my WD My Cloud EX2 Ultra after downgraded the firmware
This link helped to login:

Thanks, but doesn’t work for me.

at least try connecting directly to the modem if your modem - router are different devices.

…with another router…
Again, NO sign of NAS.
Still convinced of the network issue?

Dumb question: From the graphic, the router gives an IP address for the PC of

The ARP command infers that the PC is on And I presume the router is on

Are the 169.xx.xx.xx addresses coming from the ISP router, or the TP-Link router?

I only ask, because I wonder if there is something weird happening because you are not operating on one of the reserved “private IP address” ranges (192.168.xx.xx; 172.16-32.xx.xx; 10.xx.xx.xx).

I am not confident this is going to work, but try putting the router on a 192.168.xx.xx, and using an ip pool in the 192.168.xx.xx range; and running ARP -a again.

I have tried, netgear, dlink and another ddwrt routers… nothing, same ■■■■.
Tried normal and crossover cables connected to my desktop and laptop, nothing, same ■■■■.

Looks like my ex4100 is done for good, unless there is a way to “load” the os from USB or modify NAS HDD with files etc… but this is beyond me. So far unit is ■■■■■■.

Thanks and beware ex4100 owners.

Funny for you, but I don’t see a single user of EX4100 on which your process worked?

On the other hand for myself and meraxx our units are roasted.

I can live with it, no worries, just trying to warn other EX4100. Your post is dangerous.

BTW definition about type of person you are:


I find interesting that you silently managed to delete all your posts in this thread, in the meanwhile…
Wise boy… :wink::face_with_hand_over_mouth:
Just because you’re not a coward, right?

Cant apple the firmware downloaded, the spinning circle thing just goes on for ever, there is no % just the spinning circle on loop.

Any ideas?

You are right… used the wrong method…
Oh ■■■■…
Guess just trashed it

Thats is way too advanced for me, but thank you very much

I was wondering…
From what I’ve read to unbrick it i will lose all data.
I have 12TB on Raid1, so 6TB with same data on both HDD.
Could I try to unbrick it with just 1 HDD inside ? Or could I use some other HDD?
Might be better If i just buy an empty drive and put inside my HDD’s.

Thank you

If the data is intact, you can probably pull the drive and read it from a PC or MAC.

The method would include the following steps;
a) Pull drive from the enclosure :wink:
b) Put drive in a USB based drive enclosure (or mount as an internal drive)
c) Obtain a program that can run in a windows/Mac environment that can read a Linux based EXT4 drive partition.
d) Run the program and read the EXT4 formatted WD drive; and get the data off the drive.

(this is not much unlike how I have dealt with “crashed” PC drives. . .pull the drive, and put it into another PC so it can read the drive)

I have a 12tb drive running on raid 1.
I tried to connect one of the drives to the pc but it says raw even using a program to read Linux can’t seem to open the drive.
Can recommend any program ?