Support For My Cloud Changing

We’ve developed a new OS to keep up with evolving security standards. Compatible devices must Upgrade to My Cloud OS 5 by January 15, 2022 . Incompatible devices will lose support on April 15, 2022.

Upgrade to an eligible device.

Das sehe ich genauso! Es ist eine Frechheit, das es ein Ablaufdatum für Eure Produkte gibt.
Kümmert Euch um eine Lösung!!!

I’d seen the complaints about issues with OS5, and was not planning to update unless absolutely forced. I guess this is it. Updated OS 2 days ago.
We’ll see how it goes.

Agree with you. Unacceptable.

Joe Taxpayer,
I’m in the same boat. I’ll also have to upgrade. So, I’m wondering what your experience has been so far, since it’s been about a month since you upgraded.

I use it to save and access files from my phone and ipad. No issues so far.
I haven’t loaded Plex yet, as I’ve gotten a larger NAS set up, a Synology with 8 drives. I have a 2 drive MyCloud EX2 Ultra. Still useful and easy to access remotely.

Thanks Joe. I also upgreaded. I’ve never really figured out how to use and NAS other than to store some movies and recipes on it, so I seem to be pretty unaffected by the upgrade.
I appreciate you sharing your experience.

Hi, tried to install Firmware 2.41.121 as writen to upgrade to OS 5 zo my cloud mirror Gen 2. now i´ve firmware 2.12.144. I downloaded the 2.41.121, but i can´t update the firmware. i got an error by updating.

Fehler beim Hochladen der Firmware! Error on uploading the firmware.


I started my My Cloud Mirror after a long time and tried to get a connection to the Data on this drive. My new Labtop with WIN 11 without any my Clod software can not get any connection to the drive. I can see it in the Network and can connect trough the Firefox to the Drive. Updted the firmware to 2.12.144, but how can I get to the date. Since the Sofware is not availiable any more? Any Idea?

Question to WD - why the OS3 devices do not have any access to the dashboard anymore - I am aware that the support is over (there is no real support from years, but never mind), but not able to access the dashboard even through my local network makes this device totally unusable!
I received a mail with 20% discount to buy new WD device - are you serious??
After this situation - not a single WD product will be purchased again from my side.
I expect WD support to explain why the dashboard cannot be accessed locally!