Suddenly my 1TB Lacie External Drive is not recognised any more from the WD live media

All of a sudden and while watching new season of Californication, when finished watching episode 2 and prompted to menu and selected episode 3 the media player gave me message that cannot play it cause contents changed…

From that time and on tried almost everything (switch on and off both media player and hard disk, unplug and plug usb to media player, erasing the wd live folder from hard disk, etc…) the small light from the player never stops blinking therefore cannot see the contents from the hard disk.

Of course my PC with Windows 7 Ultimate can read and play all contents without any problem.

I have WD Media Player Live Wi-Fi 3rd gen and i usually know what i am doing wrong so to fix it somehow. This time it just collapsed and dont know what to do!

Any idea anybody?

Thank you very much for your time.


PS: the only thing that have not tried yet, and may be effective as i am reading from the community, is to power of media player and unplug it from power supply or reset it…

If you HD is USB 3.0, look at this Rear USB Port

Unfortunately it is not USB 3 but USB 2 and i am saying unfortunately cause finally the solution was 2 hard power off. Unplugging from power supply and it worked…

I am thinking that this should not be a solution any more in 2012!!!