Software Update - WD SmartWare Version 1.5.4.5 for Windows (3/20/12)

You may post your experiences in this thread.

3 Likes

Hi,

this version does not show the “leakage” of files from the GUIs that 1.5.1.6 did. With me it also uses much less RAM than 1.5.1.6. did. I hope that that is the end of everybodys troubles.

John

Thanks for trying it and reporting to all. I found with earlier versions that the drain on resources (apparently I am not allowed to say “resources-s u c k”) started to build up after a period of use. So could you let us know whether CPU and memory usage remains good after a few weeks.

Thanks

This update has been an absolute disaster !!

I was running v1.5.1.6 - WD Smartware advised me to update.  Downloaded update and tried to apply it - failed.

Rebooted and tried to update again - failed.

Rebooted and tried to open WDSmartware assuming MSI had reverted back to v1.5.1.6 - nothing !

Tried to reinstall v1.5.1.6 using previous updater - failed saying I was already running v1.5.1.6.

Tried a repair - failed saying couldn’t find critical MSI files in C:\Program Files…

Tried to uninstall - failed.

I am now locked out of my WD drive with its vital data as WD Smartware won’t run to allow me to enter my decryption password.

Thanks very much for nothing !!!

O/S - Windows 7 Home Premium SP1 X64 with all MS patches.

1 Like

I downloaded --WDSmartWare_Software_Upgrader_for_Windows_1.5.4.11B.zip-- I unzipped it and ran the installer. After about 4 minutes I got "Installation was not successful (Error Code: 1603) Please try again or contact WD. I tried this several times with the same result.

I then installed the WDSmartWare_Software_Upgrader_for_Windows_1.5.1.6 and it installed just fine.

So at this point the 1.5.4.11B version won’t work for me. By the way I thought the update version was 1.5.4.5?

If any body has help for me please let me know.

Installed this afternoon. Very clunky installation, had to restart twice, but got installed. At one point pop-up said it was 1.5.4.8 but now says 1.5.4.5. STILL DOES NOT WORK RIGHT.

Came home just now and RAM was full from WDFME.exe locking up machine.

I have 12.27 GB RAM, when I got home I was using 12.16 of it. Over 10 GB’s of that was from WDFME.exe.

Sorry WD… you people STILL can’t make software that works. I upgraded…

(1) So far, I’m sitting here 2+ hours, and the software still consumes my computer, “Categorizing files”. Come on! Norton’s full system/disk scan doesn’t take that long

(2) I “turned off” backup, hoping that would free up my system long enough to be able to select the files/folders I want backed up. Even with Backup turned off WDFME.exe and the other tasks continue to consume 100% of my CPU.

After updating yesterday I found that my old MyBook drive is not being recognized.  It shows up as a local drive without any content.  Not sure yet this has anything to do with the Smartware 1.5.4.5 update but I will be after I try it on another PC.

Like another post which I now can’t find, when I brought up Smartware for my Passport drive after the update I had trouble with the gray tabs for Backup, Retrieve and, within Settings, the Drive Settings.  The reply to that post said click on the remote drive icon.  That solved it all right.  But why was this change in basic operation even necessary? 

I thought it might be due to mulitple drives but I have only one connected.  And just like the user in the post that disappeared, I thought there was something wrong with how my update was installed.  I spent several hours trying to reinstall and rebooting, as well as disconnecting and reconnecting the Passport drive.

Performed to update and like other can no longer aproach my data on the backup.

The tabs back up and recover remain gray and i can only adjust the pc settings and not the drive settings.

thanks for this update

As rodavis44 says, try clicking on the remote drive icon, ie on the Home Tab give a single left click on the icon for ‘My Passport Essential’, or what ever your WD drive is called, and that should bring up the backup and retrieve tabs.  You have to do this every time you open Smartware from Quick View.  Definitely not an improvement to the previous version.

I was hoping that the new update to SmartWare would provide some relief from the CPU resource hogging.

Alas, it is still a disaster.

The software takes an eternity to update the catalogues and the metadata.

I gave it over 3 hours to settle down after performing a category backup, but no luck, it just contined to use up to 80% of CPU.

I have had to turn off the service to regain normal operation of my PC

(Windows 7 64 bit 4 GB ram)

Product:               My Passport Essential

Model:                  WDBACY5000AWT

Software:             WD Smartware Version 1.5.1.6

Over the weekend 24-25 Mar 12, I downloaded Windows release 1.5.4.5 from the WD website and followed the instructions for its installation.

Restarted my PC and ran the WD Smartware.

On the Help tab, the Product Name: WD Smartware and Version 1.5.1.6 was displayed.

If the download and installation of this latest release was completed OK, then should not the version displayed on the Help tab read 1.5.4.5?

Does this mean that this latest release has not been correctly installed?

I installed wersion 1.5.4.5 on a Windwows 7 64bit PC  4GB of ram.  
Restarted my PC and let SmartWare catch up overnight (Categorizing and Backups).

At first it looked like it is all beter (for a day).

Woke my PC up today (Same problem as before - Categorizing forevever - even though NO files have changed).

Same ram hog - peg cpu at 100% making the PC unusable.

New version of the software - same problems - what if anyting was fixed???

Installed the new version, which went smoothly, but it hasn’t corrected my issues with this software.  As soon as I  open IE and browse to a site with streaming video,  WDFME grabs my CPU, using at  least 50% of it (see below). Memory is not an issue for me but CPU usage is killing me. This occurs whether I have the drive connected or not. Any other suggestions before I permanently uninstall this software?

WDFME Usage.png

Vista Home Premium SP 2 - 64 Bit - 4GB RAM

1 Like

Really unhappy about update. The drive works, but after the reboot, accessing WDSmartware, the backup tab is ghosted out which pretty much makes the drive NOT fit for purpose.

ipw133 wrote:

Really unhappy about update. The drive works, but after the reboot, accessing WDSmartware, the backup tab is ghosted out which pretty much makes the drive NOT fit for purpose.

On the Home tab, click on your remote drive icon. That will activate the Backup and Retrieve tabs.

1 Like

I can’t understand why this thread is not getting any attention from the people at WD. They must be monitoring, right?

I have been waiting patiently a long time for this software upgrade because in principle Smartware is just what I want: it is simple, effective and free. Unfortunately it is also driving me crazy because it slows everything else down unacceptably.

I think that if WD can’t get it right they should withdraw it because releasing poor software is bad for the company’s reputation. The best of all worlds would be to do a deal with a good piece of backup software and bundle that with their drives. Such a deal would probably not cost more than the money they spend on developing Smartware.

One of the main reasons I purchased the WD My Passport was for the integrated automatic backup solution.  Boy, was I snookered.

I upgraded last night to the latest version of SmartWare 1.5.4.5.  It took a while to install, but happened without complications.  The software then took over 12 hours to categorize and backup 3.5 Gbytes of data.  Not exactly the performance I was looking for.  I then looked up information on this forum for version 1.5.1.6 and determined that the problem is systemic and not likely to be fixed anytime soon.

The solution I have found that works perfect for me is Synchronicity available from sourceforge at  sourceforge.net/projects/synchronicity.  It allows me to backup entire directories, then subsequent backups will only copy the files that changed.  The software is free and very straightforward to use.  I love the My Passport drive, and this allows me to use it effectively.

I love my WD drive but, really am completely dissatisfied with the Smartware software. I’ve been using the software for a couple of years now and it has been a major resource hog from the beginning.  The code is clearly not well written and WD appears completely insensitive this issue/problem/bug since they have had multiple opportunities to tune the code to make it much more CPU friendly.  It’s inexcusable for such a highly regarded company that makes great hardware to completely ignore the continuous complaints from its users regarding its poor software application.

The web is full of negative comments about the Smartware application but, sadly, WD is not listening.

I’ve decided to abandon the application and find another one that is much more CPU friendly.

This update has continuously failed for me. I have been trying to backup my hard drive for the last few days but whenever I open the software, it tells me there’s a software update. I follow all the steps to install the update and reboot my computer to finish the update. Upon rebooting, the software tells me it’s still the same version as it was to begin with. In other words, I spent all that time trying to update and it never installed. I’ve contacted customer support but they’re basically useless. I can honestly say that once I run out of space on my 2 terabyte drive, I will NEVER buy a Western Digital again. I prefer to buy products that work and work when they say they will.