Software Update - WD SmartWare Version 1.5.4.5 for Windows (3/20/12)

you’re not alone. I’m having the same exact issue. It tells me it installed correctly and everything. After I reboot my computer (Windows 7 64 bit 4 gigs ram) and open the software, it still shows the same software version I had to begin with.

Installed 1.5.4.5 for Windows. Restart my system. Before my system loads my desktop, a black screen appears along with the Command window. The Command window remains completely blank. After around 15-20 seconds, my desktop loads and all of my Startup components show up.

I then open SmartWare, which recognizes 0 files to be available for backup (although SmartWare recognizes C: and the WD external drive). My SmartWare version number is also the same as it was out-of-box: 1.4.x.x.

I have done this several times and each time leads back to the same two issues: 1) the installation of 1.5.4.5 never seems to occur and 2) no files are recognized for backup. Both these issues render the software 100% useless. Any help?

I have the same issue, I’ve been speaking to tech support for 3 days now and they still don’t understand they have a problem with their update on their end. They still firmly believe the issue is on my end with my hard drive despite everyone else complaining on here about it. I actually uninstalled the old software as well as the update, rebooted the hard drive and re-installed whatever the latest firmware was. I haven’t turned the hard drive back on to see if it actually worked yet or not.

I have never in my life seen a company as inept and incompetent as the software people in WD.

As predicted, it did not work.

They have no clue what’s going on within their company. They honestly do not read the support forums they provide to get just that. They keep trying to basically blame me for their error and refuse to accept that they have a MAJOR issue with their software and it needs to be addressed immediately. I’m about to threaten them to throw this in the garbage and buy a seagate or something else from one of their closest competitors. This is absolutely ridiculous.

I suppose I should clarify a bit. When I first opened the SmartWare program as it comes out-of-box, it recognized my various file types for backup and made suggestions of what I should back up. Then the “update” window popped up and I went through the described updating process (nothing out of the ordinary). It was after this first update–supposedly to 1.5.4.5–that things never worked as they should. I had only had the hard drive for 2 hours before there was a problem with this software. I love WD hard drives; I have no idea why this program is such a dud.

I’ve had this hard drive for about a year and has had a few software and firmware updates. I’ve never once had an issue with it until now and now it’s causing nothing but problems. I can’t back anything up because the software is technically outdated. I will be on the phone again with tech support tomorrow.

UPDATE:

It is now working for me. Here is what I did:

I went to Control Panel --> Uninstall A Program --> then I uninstalled the two (no idea why there were two) WD SmartWare programs shown. I restarted my computer. Then I went straight to the update website, bypassing the WD SmartWare that is loaded on the hard drive. I downloaded & installed the update, then restarted again.

Now everything works perfectly and I have version 1.5.4.5 installed correctly and the backup appears to be available to run. Fingers crossed and good luck.

I’ve tried that several times and it still won’t work.

t82_fair wrote:

When I first opened the SmartWare program as it comes out-of-box, it recognized my various file types for backup and made suggestions of what I should back up.

 

 

About two years ago, that was the subject of a LOT of complaints, too. It was because of that, that WD came out with the “select your own files” feature.

 

“Out of the box”, their “Category” method of backup only backs up files in certain areas on your hard disk, if they have certain extensions. This was VERY misleading, because it would NOT back up everything that you might change on your hard drive. Their user manuals, and website at the time even said that their software “Works quietly in the background to protect your data using minimal PC resources. Whenever you add or change a file it’s instantly backed up.”

 

Well, that turned out to be false and misleading. Thankfully, WD agreed, and gave us the “Choose your own files” method of backups. Now, if they can make their software actually work, we’d have something.

 

Here’s original threads from those days:

 

http://community.wdc.com/t5/ideas/v1/ideapage/blog-id/software_ideas/article-id/26/page/1#comments

 

http://community.wdc.com/t5/WD-Smartware/Smartware-enhancement-request/m-p/154176

 

http://community.wdc.com/t5/Software-Accessory-Ideas/SmartWare-Enhancement-Less-Restrictive-Backups-Must-Have-for/idi-p/15760

 

1 Like

I’ve escalated this issue.

Thanks for escalating. Ok, I realize this is a “user forum”, but there appear to be some WD people here.  The “official” answer for support, is most likely to contact WD, and not rely on this forum.

But… as you can see, there are new people in this forum, having come here from doing a Google search on WD Smartware. Having all these complaints available to anyone who searches, can’t be a good thing. As a software developer, if I allowed my software product to be the subject of so much negative  public debate for such a long time (without fixing the problems in a timely manner), my company would crucify me. Folks will surely base future hardware purchases on the reputation and reviews they read online. Yes, so far, the hardware works great. The software doesn’t. Buyers won’t separate the two when making decisions.

I also can’t imagine it being cost effective for WD to answer numerous calls from people one-by-one, going thru a bunch of steps on the phone, where the same answers could be posted here. Seems to me, that would save a lot of time on WDs end.

Bottom line: I think WD needs to pay more close attention to the forum, and start to answer people here, or at least keep people informed on what’s happening. This shouldn’t have to go on for months, before someone “escalates” the problem. I get the impression WD doesn’t even think there is a problem.

I have never used any of the other commerical backup products that have been mentioned here, at least not yet. I can only base my opinions on what I see with this software, vs the only other thing on my computer that might be inclined to use as much resources… which is my anti-virus software.

When my anti-virus softrware does its “full scan”, that means it’s finding and actually reading the contents of every single file on my hard disk, looking for patterns, and viruses. If it can do this without significantly hogging resources on my computer, there is no reason your software can’t do the same, because you’re doing very similar things (looking for all files, then copying the ones you decide need to be backed up).  And Norton can finish its “full scan” of my entire hard drive in less than an hour.

We’ve all said this for months… even when only a “few” folders and files are selected for backup, your softrware appears to hog the system forever, as if it’s constantly looking for ANY file in the entire system (whether its marked for backup or not). System files, like “profile” files or “cache” files IE and Firefox use, should never even be looked at. And the responses we’ve heard from WD about “SQL Lite not allowing us to delete files”, and “this software is working as designed” is nonsense. This “try uninstalling and re-installing the software” is also not acceptable, because as someone else pointed out, it’s also a WD software problem.

I don’t disagree with you.  Us, moderators, are the ones that pretty much escalate all the issues from the community.  And we don’t always post that we’ve escalated something. But that’s because we’re not always sure it’s a valid issue.  Furthermore, sometimes it takes a while before we see that there is an issue.  But when we do see that there is a consistent issue, it always gets escalated. 

If you are not sure whether something has been escalated, or should be escalated, you can always ask one of us.  However, the decision was made years ago to make this a user to user forum.  It is not a support forum, and it’s doubtful it will ever become one. 

1 Like

Why then was my “ticket” closed when my issues was unresolved and refered to this forum is its not support as if that was the resolution to my issue: that SmartWare is a virus and broke my last computer and on this new one will eat up 11 gigs ram in hours and won’t give it back…**bleep** is it doing with all that processing going on??

A sweep it under the rug policy.

After installing update, I can’t even launch the WD Smartware now. I’m not that tech savvy so I’m not sure what happened. The error message is “Windows cannot find c:\Program Files\Western Digital\WD smartware\Front Parlor\WDSmartware.exe”.  Make sure you typed the name correctly, then try again.

This is just the sort of thing that is so time wasting when non technical people like me have to figure out what went wrong. I thought software updates were supposed to be foolproof …urgh …I don’t even know how to reverse the update … or it is reversible at all ?

Pls help 

Robert C’s two recent posts are excellent and to the point.

In the WDFME.exe RAM Hog topic BBBBBrandon (WD Staff) made the following posts:

Page 5 on 30 Nov 2011 edited on 26 Dec 2011:

“We are releasing two new versions that will solve different problems.

The 1.5.4 code line will add support for new product and also have maintenance items within including a better installer to resolve most install/uninstall problems seen.

The 1.5.5 code line will have significant back end changes related to the categorization and copying of files that will significantly reduce the amount of resources used including memory and hard disk i/o.

The time table on both of these releases is not certain yet.”

Page 6 on 12 Jan 2012

“We are currently targeting a major overhaul for the 1.6.x version, there will not be a 1.5.5.x as referenced in my previous posts.  This release should follow the release of 1.5.4.x that features a new installer.”

Is this still true and was it wrong to expect any reduction of the major Smartware problems with 1.5.4.5?  If so, why was this not made clear when it was released?

And

Can WD please say when 1.6x will be released?

As a newbie on this forum I must say for the record that version 1.5.4.5 is no better than its predessor which I upgraded from and WD should be ashamed to continue to subject their customers with this software that is simply put “garbage”:angry:

My CPU is running at 100% and the computer is virtually frozen. Version 1.5.4.5 is also a RAM hog and the only way to make my computer to function properly is to end the WDFME.exe process in the task manager. The minute I kill this process my CPU usuage drops to about 5% and I am using very little RAM.

WD, SHAME ON YOU!!!

1 Like

ouch! I just installed this update to:

Windows 7 Home Premium 64 with latest patches/updates

Now WD SmartWare sees the drive but no Backup/Restore tabs are available. Settings tab is available but nothing on it. So I guess I just hosted my backup system by doing this install! Yikes WD. I am on a new computer (about 2 months ago) with no other problems/issues going on. And it looks like there is no help in site from WD on this board, dang!

I presume you have the Backup and Retrieve tabs but they are greyed out (an unexplained feature of the latest software).  The Home tab should have an icon for your computer and, to the right of it, an icon for your WD external Drive.  Click on the icon for the WD Drive and, after a few seconds, the Backup and Retrieve tabs should become active and cease to be greyed out.

You might wish to look at the WDFME.exe RAM Hog and WD Smartware building etilqs files topics before you undertake a backup.