Slow file transfer speed with Asus RT-AC68U router

When I connect My Cloud 3T to the lan port of Asus RT-AC68U router, the file transfer speed via Windows drag and drop is always 1MB/s. The only solution is to connect My Cloud to the lan port of the switch and connect the switch to the router.

When My Cloud is connected to other routers, the speed can be 60-80MB/s.

Would anybody or WD advise whether it is a compatibility issue and how to solve it?


The fact that the My Cloud works properly (faster speeds) when connected using a switch or other routers indicates the problem most likely is the Asus router. First step is to ensure your using the latest firmware for that router.

A Google search turns up other threads elsewhere indicating some are having speed issues with that router. One suggestion (see this link) indicated that one improved their speeds by changing the QoS Type from “Traditional” to “Adaptive” on the QoS Tab within the RT-AC68U’s administration section.

This Asus support forum thread indicates some may have corrupted NVRAM and they used the following procedure to solve their issue. From that thread:

Maybe you got corrupt nvram,try this

1- Do Factory reset in Gui , Admin inteeface
2-When factory reset is done, turn off your pc
3-Power off router
4-Hold WPS button and power on your router and hold on WPS button until led behind or in front begins to blink( 10-15 sec approx) and release WPS button
5-Wait for power cycle( 2-3 mins)
6-Power on your PC and reconfig router from the beginning, “” dont import old settings"

Good luck

Here is a link , for good tips

1 Like

I have an Asus RT-AC68P and my speeds are around what you see with the other routers.
Are you running AiDisk or AiCloud or any of the other features (Torrent, VPN)?
Do you have a Static IP to the My Cloud from the Asus Router?
Are you running firmware or AsusMerlin?

No, I did not use AI disk or AI cloud or other features. The firmware is 1842 version. I tested another 68u and the result is the same. When I connected my Cloud to the another brand’s router, it is normal. When I connected other NAS to my router, normal too. So it is weird.

I have seen some threads on other forums that deal with the Asus RT family of routers that sometimes the “QOS” will not play well. Do you have that option set on your Asus RT-AC68U?

Have you done a speed test (Internet), does your router’s speed get what you expect?

How about normal uploading/downloading to another computer on your LAN … Is that OK?

Are you running Windows 10?

I am just throwing out some ideas … I have never had a problem, well actually once and I did a factory default restore on my Asus RT-AC68P and started over, and that seemed to solve my issue. But have never had an issue with either of my My Clouds as it relates to the router’s performance. I use to have a Linksys WRT54G2, although only 10/100, but never had an issue with that either.

Some thoughts:
I have an Asus RT-N66U, and My Cloud NAS and have never had this sort of problem. I use AiCloud, have a portable HD drive attached to router, never have needed to use QOS, since home network and internet is lightening fast with lots of bandwidth here. I have never needed a static IP for any reason – the router assigns a unique and “permanent” IP address to all devices based upon algorithm it computes from MAC address.

I will throw out the suggestion that it is RF interference causing the issue.
As an ex-ET in USAF who long ago worked on RF radar, I am always on the alert for this problem with my gear. Example, when I was setting up my WD wireless passport, I was having a devil of a time getting it to use a certain wireless channel. Hey, it’s RF junk surrounding my computer stuff I realized, so I moved away from all gadgets to dining table and got it set up right away.

In the past few days someone posted same issue with his drive connected to his Surface pad. Tony and I ,and both came up with RF interference, and Tony also came up with an Intel white paper explaining this as a big problem in many instances. See link and paper’s link. Lesson here: don’t crowd all your gear close together!

I use Windows 10 64 bit windows explorer, drag and drop a single file.

I tried QOS adaptive but problem still exists.

I did factory default and held WPS and power on at the same time and restarted the setting but problem still exists.

The weird part is another RT-AC68u from my friend to connect my WD my Cloud in another place has the same problem.

Also if I connected WD my Cloud to my previous Vigor 2920 router, everything is normal.

Also if I connected WD my Cloud to switch first and then connect the switch to RT-AC68u, everything is normal.

Asus customer service said the lan port has no problem as he tried to connect my router to Synology and the speed is normal.


I have had my Asus connected to a GB switch and directly into the RT-AC68P and it made no difference in speed or connectivity to either My Cloud. Since you are having an issue with the My Cloud connected directly with the router and not through a switch then I would expect there might be an UPNP issue … not sure :worried:

But as mike27oct pointed out he is not having issues with his RT-N66U. Not sure where to go from here but maybe contacted Asus Support would be my next option, especially if you have registered your router after purchase.


As @Bennor wrote, check your router and maybe update its firmware, there is a new one available since some weeks ago. I am using the same router for my demo networks and it always works fine with no speed issues. The RT-AC68U has an internal Gigahertz CPU and a lot of RAM, so it should be well equipped to cover whatever load. You may take a look at QoS Quality-of-Service settings, here are some quite annoying traps hidden. For the first step, follow Bennor’s reset advice.

What happens if you turn QoS off?

Throwing out some other suggestions. Try different network cables if you haven’t already. Try each one of the networking ports on the back of the router. Check to see if the router supports setting the speed of the network port, sometimes it is set to Auto, try forcing it to the highest speed. Try enabling Jumbo Frames on the router and if there are additional Jumbo Frames settings experiment with them to see if they affect/increase the speed.

1 Like

What is the state of the LEDs on the Ethernet connector on the MyCloud? It could be another problem of failing to negotiate the correct link speed; you may only be getting a 10Mbps link…

Though if others aren’t having trouble, it sounds like a problem with your particular setup. Try another (cat5e/cat6) cable, and a different port on your router.

YES, try another Ethernet port on router. I hade a port on a network switch go out before, so replaced switch to fix. A non-tech neighbor was having issues with his cheap router not working. I took it home, and found the input port non-functional, so tried input on one of the other four and was working. It, too, had a bad port.

Nevertheless, these problems were not causing slow speed, they had NO speed, cause they were dead ports.