SlingPlayer - no longer works!

Hello.  I was using the WDTV Live’s Slingplayer just fine for several days.  Yesterday I left the player on and unattended for about an hour.  Now I can no longer get the player to stream from my Slingbox.

I get the error code 10003 from a timeout.  it does this:

1.  logs into my sling account

2.  connects to my slingbox

3.  attempts to start streaming - this step is the one which is usually followed by “optimizing stream…” but I get the timeout message.

Notes:  Yes, my slingbox is ON and working.  I can view it just fine on both my PC and phone as I could prior to this issue.

I believe the issue to be in the WDTV Live unit as a result.

Now I have done a factory reset on the WDTV Live unit and started completely over (after wiping cache data to see if that would help).  Nothing is helping.

Perhaps someone has a clue on how to correct this?  I am away from home and hence my slingbox, but again, I am able to connect to it and stream TV just fine using two other means (PC and phone) so it doesn’t appear the slingbox is the issue anyway.

Thanks for any assistance!

Check if the link below helps.

http://answers.slingbox.com/message/72260#72260

Thanks for your response.

That article refers to Boxee Box error, but it also requires one be local to the SlingBox and as I mentioned, I am not (and won’t be for a while).

Again, the SlingBox on the remote end is working perfectly with regards to the sling players for my pc and mobile device.  The pc and mobile device are running inside my LAN in my remote location so I figure it can’t be about ports on the router, etc.  And lastly… the WDTV Live device DID play / control the slingbox just fine for a couple of days; then it stopped.

I am having the exact same problem.  I can properly connect and stream from my Mac, iphone and ipad, but get the same error with my WD TV Live.  I just purchased this unit and it worked fine for the first day.  Day 2 started with this problem.

I also cannot physically get to my Slingbox.  It’s on the other side of the world.

Has anyone found a solution out there?

Sorry to hear you’re having the same problem, but must admit it could also be beneficial as since it’s not just me, perhaps WD will give the issue the attention it deserves.

FYI - don’t waste your time with a factory reset or logging out of the sling account on the WDTV Live unit.  Clearing the cache/data option also does nothing to help with this.

I actually successfully used the unit to access my slingbox 500 several days and for several hours over the holidays in December.  I then moved the boxed with me as I travelled in Jan and used it to access the slingbox for again several days and several hours with no problem using the WDTV.  It was only on a day that I paused the program I was watching and then left it that way for an hour or so that the problem began.  The device timed-out / gave up waiting on me.  But then you’d think a simple reconnect would put you right back where you left off.  Unfortunately this wasn’t the case.

WD please address this for us soon as I am in need of another device to make a TV “smart”.  If I get no resolve on this, I will have to look at Sony and Roku.

Well no response from WD and hence no resolution.  So, I solved the issue myself… just bought a Sony Internet Player with Google TV!

It has a working Slingplayer, but also does Netflix AND Amazon Instant videos (something WD doesn’t do).  It also has a ton and I mean a ton of other apps and TV options.

Thanks anyway WD!  Ignore product issues = bye-bye customers.

Definately got the same problem.  Also, mine worked for the first week and then all of the sudden the WD TV Sling Player started constantly timeing out after the starting streaming screen was on. To make sure it’s not a wireless network problem, I pugged the ethernet cable directly into the back of my modem and then ran a long HDMI cable to the TV. but the same error code 10003 presented itself.  I sent it back and got a new WD TV Live, but the new one also does the same error code 10003.  There is obviously a flaw in the WD TV Live Sling Player programing.  My MAC and my laptop connect to my slingbox just fine through the web browser slingplayers.

1/12/13

Model: WD TV Live Streaming (non-hub)

Model ID: WDBHG70000NBK

F/w: 1.12.14

Slingbox 350 - Port 5201 (using manual port forwarding and static DHCP lease, NOT uPnP)

I’m a techie merly passing through. I’m posting a workaround I found that may help others, but won’t be back to troubleshoot.

To the folks at WD: I’m very unimpressed with the 3-second input lag, missing WDTV -> SlingBox remote control mapping, and lack of timely updates. Even though I found a solution, I will likely return this anyway for a true mini-ITX HTPC and recommend the same to others.

PROBLEM:

Something on the WD TV Live appears to use cached settings on SlingBox’s backend services. At http://support.slingbox.com/ you can see “Last Update Received” and various other internal network settings.

SOLUTION:

Force an update of the SlingBox credentials. Easiest way I found was to break the port-forward, then attempt to connect to the SlingBox from the web. This forces the SlingBox to reconfigure itself and use Sling as an intermediate relay. This allows WD TV Live to work, at which time you can set it back.

[Broken] (WD TV Live) --> (Home/SlingBox)

to

[Working] (WD TV Live) --> Sling <-- (Home/SlingBox)

then

[Working] (WD TV Live) --> (Home/SlingBox)

STEPS:

1.) Log into your router and remove any port-forwards to the SlingBox (typically port 5201). [Or if using uPnP, disable it temporarily]. Reboot your router.

2.) [OPTIONAL] Confirm the port-forward is broken by going to https://www.grc.com/x/ne.dll?bh0bkyd2 (Gibson Research ShieldsUP) from your HOME Lan, typing 5201 in the box and clicking “User Specified Custom Port Probe” (bottom left). If it says “OPEN”, the port-forward is still working.

3.) (From a remote, non-lan location*) Access the SlingBox from www.slingbox.com . You will notice it fails to connect, then connects at a reduced speed. If you use “netstat -no” in the command line you should notice it no longer connects to your Home IP:5201, but one of Sling’s IPs:.

*[Connecting from the same Lan MAY NOT force an update!!]

4.) Attempt to connect from the WD TV Live SlingPlayer app. IT NOW WORKS! If you press the Red Button to display stats, you will notice the IP at the top has changed accordingly.

[Once you get the WD TV Live working again, re-enable the port forward]

5.) Log back into your router and re-enable the port 5201 port-forward. Reboot the router.

6.) Confirm the port-forward is enabled by using GRC.

7.) Attempt to re-connect with WD TV Live. When you press the Red Button, it should show your Home IP:5201 again.

CAVEATS:

This requires having simultaneous  access to remote IPs. I was able to do all this while VPN’ed into my router, others may not be so lucky. I also tried to do a Firmware Reset to Defaults and lost some built-in apps, but it did not fix the problem. I am unsure if that affected my solution.

Please only use this as a rough guide. If you are feeling particularly chariable, post if any modified version of this works for you.

ADDENDUM:

To the other poor schmucks that lost SkitterTV, Hauppauge, and other apps by attepting a Factory Reset, it is possible to get them back. You need to downgrade your firmware to then re-upgrade. [Follow the appropriate model numbers by hovering your mouse over the “Select the Firmware to Download” names.]

Follow these URL updates in order and follow the instructions there:

1.) http://wdc.custhelp.com/app/answers/detail/a_id/5860/related/1/

If you have a WD TV Live Streaming, you want wdtvlivegen3_rollback_1.11.14 . YOU NEED THE VERSION ON THIS PAGE. (It allows a downgrade by faking the version as 2.11.14, which is a total hack, but gets the job done. It also hints WD likely never intends to keep releasing firmwares/product support past 2.0. >:( )

2.) http://www.wdc.com/wdproducts/updates/?family=wdfwdtv_live_G3

This has the most up-to-date firmware for the 3rd generation WD TV Live Streaming (currently 1.12.14). Might as well download this at the same time as #1. Updates for the other models are here:

http://www.wd.com/en/library/library.aspx?t=3


3.) http://community.wdc.com/t5/News-Announcements/bd-p/Announcements

If this post becomes outdated, the forum I linked is in SHOULD have the most recent Beta firmwares. Make sure you get the RIGHT type - TV Live Plus is not TV Live Hub is not TV Live Streaming. Make sure you get the EXACT right one.

As a ‘techie’ do you have any technical reason why your rollback and update method above works or is it just that it does!

As to the ‘It also hints WD likely never intends to keep releasing firmwares/product support past 2.0.  :angry: )’. If you notice on your rollback page WD are generally releasing firmware as 1.01.xx and 1.02.xx. On this basis there are currently another 88 firmware updates until they have to use 2.00.00 and that does not include minor iterations. Even if they released one every month (which I can assure you they don’t) that would give this player another 7 years worth of updates. I would think that if they don’t get it right after 7 years then they never will.

I have exactly the same problem!  Model WDBHG70000NBK-VESN with firmware 1.12.14.  It worked for a few weeks and now cannot get access to slingbox…times out.  No problem acccessing slingbox from PC or phone.  PLEASE WD fix this!

Got the same problem.  It’s the second WD TV that I have cause I exchanged the first one since it was not working properly but I still have the same problem.  Can WD address the problem and give us some help please !!! 

This issue has been reported to the development team, I will post back once I get any news.

I believe I found the solution.  I had the exact same issue…slingplayer for WD worked and then stopped working…with error message 10003 popping up.  The problem is actually not with WD or Slingplayer, but rather with how the slingbox is set-up on your router.  Specifically, auto set-up of Slingbox is DHCP-enabled and if you have a lot of devices connected, Slingbox has trouble streaming through the DHCP server.  The way to solve this is to make Slingbox operate on a Static-IP, as follows:

1.  Log in to your router (typically by typing 10.0.0.1 in your address bar).  If you’ve never logged into your server before, try username “admin” and password “password” to log in.  If that doesn’t work, you will have to consult your router literature or internet service provider for the log-in information.

2.  If you go to the “connected devices” screen, you should see the Slingbox and your WD hardware; each one will likely say it is DHCP-enabled (not Static-IP).  Each device should have an “edit” button.  For Slingbox, click on that button, switch the IP address to something no other device in your home will likely use (like 10.0.0.100 or 10.0.0.200) and change the type to Static IP.  When you click okay, your router will take some time to reset itself.  After it resets itself, it may take a few more moments for the connected devices to update (at which time your Slingbox should have a new IP address with a Static IP-enabled). 

3.  Once you see those changes, try using your WD players again.  My hub and my live TV plus worked just fine after putting slingbox on a static IP.

I hope this works for all of you!

Are these instructions for the router attached to the slingbox or the one connected to the WDs?

Thank you,

Tony

My sb350 is in CT and my WDs is in GA. They are not in the same house.

I did this with the router connected to the slingbox and put slingbox on static ip. I have not tried using a remote wdtv with this solution.

Thank you again. One last shot (even though tech support says that my slingbox and router is set-up correctly; i cal;led them yesterday and today…they are nice folks but don’t now how to fix it…not even tier 2 support). Otherwise, both WDs are going back to Fry’s and I am but a very long HDMI cable.

Thank you!

This box is garbage, I fixed it with reseting the slingbox and of course it started doing it again, I am so upset because I am not near the sling box to reset fix your product Wester Digital!

Hi,

I’ve had the same problem and found out, that the slingbox (mine is standing far away) needs the IP-Adress, which has occured first. If you have another dynamic IP or another fixed IP which is different to the first in your own network, the slingbox won’t connect. I switched back and all was die again.
Give it a try!

I also purchased WD TV live, strictly to have a dedicated way to watch slingbox on my TV.  It was working great, really great for about two weeks. Then all of a sudden it would connect, but wouldn’t start streaming and the connect would time out.  (Appears to be the same problem noted multiple times in this thread.)

Sllingplayer continues to work great on my PC, iPad and iPhone. It is clearly a problwm with the WD device.  I solved the problem, this once, by having some toggle the power on my slingbox.  This solution is obviously not good for the long-term. (Although I did think about getting an AC timer switch to cycle the power on my slingbox daily. But this should NOT be required.)

I hope that the next update to slingplayer for WD TV–or firmware–will fix this. Otherwise I would NOT recommmend purchasing WD TV Live for the purpose of viewing slingbox.