Skipping files she copying from USB drive

Brand new MyCloud duo is taking 5 days to copy 1.1TB from a (WD) USB drive connected via MicroB to USB cable. Plugged in directly, and connected to gigabit Ethernet.

Also this copy (although not yet complete) is skipping all files that feature No capital letters AND no numbers. (Ie lowercase only). Mixed cases, and lowercase + numbers is ok.

Further more it appears to randomly cease copying files and moves on to the next. Ie it skips content and I can’t currently to see the pattern that triggers this.

Makes trusting a backup very very difficult!!

Any insight / advice?

I’m hoping it will return to the Mossing files before completing??

Nobody knows how you are restoring files from USB. Is this with a third party app on what OS?

USB 3.0 copy using webapp (browser) is about 5 GB/min or 3.7 hours for 1.1 TB. It will take longer for fragmented small files and slow USB 2.0 HDDs.

You can do your own speed test with a USB 3.0 flash driver or SSD drive.

Thanks NoPlex, it’s great to hear there is somebody out there!!

As I said, I have connected as WD disk via USB directly to the My Home Duo. There are 2 issues

  1. Speed. I don’t understand why it’s so slow, as all the elements are billed as Much faster.

  2. The WD software interface is skipping out files whilst copying over from USB, and does not recognise / view some files. In other words it’s leaky.

I think it’s related to different formatting (Mac/pc/case sensitive etc)

I have now stopped the direct transfer from USB disk to WD disk, and I have re-connected the USB disk to my Mac. I have started to try to fill the gaps, transfer missing files directly through Mac Is from USB to WD Home.

I am able to see the newly added files through the finder, but they do not show up through the online WD app.

So the files the WD software didn’t copy in the 1st place aren’t visible even when ‘drag n dropped’ directly onto WD MyCloud.

However, basically, this is not a reliable solution. I’m 300 pounds down.

I think putting an Ethernet to USB hub would have allowed me use my Loaded USB disks via home LAN network , and set up a reliable back up system with something like CCC.

I am currently sensing the 300pound WD disk is soon to be landfill.

You didn’t mention macOS until now, but that is what I figured. There are always problems with macOS file and folder permission and this is not the first time skipping files has been mentioned associated with macOS and probably HFS+ formatted files and also massively slow down in transfer.

If you try a different operating system and a USB HDD from such a system, there will likely be very few problems.

Hopefully you can get your money back or trade it in for something else. However, your expectations of a solution from other NAS manufacturers may be misplaced if you are thinking along that line. This is because macOS USB backups are not meant to be read by another OS (whether with a NAS or Windows or Linux). You will see these errors in Synology for example

File Corruption using Synology File Station (with MacOS USB drive)

*Designr @designr
Apr 12, 2020 Edited

Problem #1:
• Synology File Station returned an error when attempting to copy ANY MacOS application (.APP Bundle).
Problem #2:
• Synology File Station appears to copy fonts (Postscript Type 1, Screen Fonts, and TTF) returning no errors.
Problem #3:
• Even after successfully migrating fonts and MacOS applications to the Synology using the MacOS Finder, File Station reports inaccurate file sizes.
Problem #4:
• There is no guarantee nor have I any confidence that these files will remain intact after routine file maintenence tasks.


Are these known issues?
Is there anything that would give me more confidence in the Synology NAS?

Mounting a share on a Mac and using the MacOS Finder is the only way to copy fonts and apps to the Synology. Once restored to a Mac both then appear to function normally. **
However this workaround is untenably slow for large amounts of data.

I bought the MyHome as a home hub. This is so that I don’t need to use a home Mac computer with ‘file sharing’ which seems to require that the machine be woken up (even on long ‘energy saving’ modes).

However, as described (badly! Sorry) in my posts above the WD MyHome OS appears to not recognise many folders. As I have said already those that have only lowercase letters in their names, but it is not only that group. It also seems to skip large chunks of subfolders within larger folders - so a 100GB folder copies over as a 20GB folder.

When I force copy files manually with OSX, those items are visible through OSX but still not visible through the WD mobile app.

This is evidently profoundly unsatisfactory. I am seeking to preserve vital data against potential future disk outages.

From NoPlex’s comments that WD is not capable ni dealing with MacOS data - there is clearly a compatibility problem - it was however sold to me as MacOS compatible.

Is there any work around here?? Can I replace the software in the WD unit with something more compatible? Can I ‘persuade’ it to simply function as x2 4TB external drives each visible on my home network in a really straightforward way??? (I have the duo)

If not - I think my only option is to buy an Ethernet Switch with USB ports and run a bunch of USB disks, each as an individual disks and have backup software (Carbon Copy Cloner has worked for me in the past) replicating data across the individual disks - will this work?

It sounds like I have no choice but to return the WD disk as is not as compatible with MacOS as billed.

Have I got this right?

Nobody makes a network storage that is 100% compatible with macOS, not even Apple because they don’t even try. Do you see an affordable network storage hardware solution from Apple? Do you see Synology making a 100% compatible macOS network storage? (see above).

The reason is very simple. It is macOS that is defective.

Hi NoPlex, I’m sure you will be right about the nature of MacOs.

However - I am seeking to replace the following:

X2 separate computers (both macs) each running a USB external storage disk, each backed up to a second USB storage disk. (They are mirrored with CCC) and it all works.

Recently I have had issues with the network not being stable, and the file sharing being unreliable.

Additionally I have a 3rd machine I want to store data for. So I thought of buying a larger External Disk, connecting it via Ethernet to my home router so all machines can access it.

I saw the MyHome Duo that promised ‘mirroring’ and Ethernet connectivity.

Now - to further clarify, x3 of the x4 USB disks mentioned above are WD Elements external drives, and other than the network issues I have Zero problems.

The WD MyCloud Home does not act as a simple storage device, does not just copy what works fine over.

Now all this is way above my pay grade, however I now think that had I just bought an Ethernet to USB switch, with x4 USB ports I could have connected all x4 of my existing USB disks, accessed them all from all over my house from any machine around my home network, and retained clones amongst them to protect against future disk failings, - this would all be solved.

Instead, as it stands, I have bought a machine that won’t copy my files, that I can’t be sure is retaining a copy of my data, which is the opposite of what was in the product descriptions.

I have described what I see as a simple route that I think will work, so I find little reassurance in the idea that all NASs or that OSX have problems.

Again to repeat - I have x4 WD storage disks and I can’t retain a simple home network.