Simple fix for "USB device not recognized"!

Hi everyone! I registered an account just to share this great and so simple fix I found if you’re getting the error message “USB device has malfunctioned so Windows does not recognize it”. I have a MyBook Essential 1TB 2.0 (without the Smartware) and my computer is a Windows XP SP2 and that is the problem I had.

Well all you have to do is just unplug your computer from the wall! Yes, that’s it! I couldn’t believe it either. But the reason why it works is because when you just turn off your computer the regular way (without unplugging it) the motherboard is still being powered. But when you unplug the computer and then plug it back in again, the motherboard will reload the drivers and walah! USB ports work again! Just make sure you shut off the computer the regular way first and then unplug it and wait a few minutes before plugging it back in again.

Before I had found this solution I had plugged in my camera into the same USB port and it worked just fine, so it was only MyBook that was not being recognized. I found this fix on some other website.

I realize this may not help in all instances but I really hope it helps someone who is desperately trying to get their external hard drive working again.


Thank you for this information,

You’re most welcome!

Excellent.  Quick fix.  Yes, total power off!   Saved me a lot of time.  Thanks!

I’m glad it helped.

Thanks so much! You saved my life! Cheers

You’re welcome. I’m happy it helped.

Could use some help. Tried powering down and unplugging but still no joy. Not getting an error message, but when I click on “My computer” it just doesn’t show my external hard drive, only the interna C:\ and E:\ drives…Any help much appreciated.

Is the external hard drive powering on at all?

hmmm… I think you might have a different problem, because when I had my problem, when I plugged in my hard drive it would flash blue for just a couple of seconds and then it would shut off and then I would get that error message.

if you’re not even getting the error message then it might be something else going wrong.

unfortunately, I’m not really much of a computer expert but I’m sure there are others here who could help you better.

I have had a very similar problem.  Finally found that my power cord that came with My Book Essential isn’t working any more.  Am trying to find out how to purchase a cord that will fit, but can not find any!


I tried to connect a Avermedia  Aver TV HD Volar hybrid 830 USB ,to a Dell XPS L702X  laptop,(i7 4 core motherboard,8Gb memory,and 555 graphics card,with 3Gb memory),but it is not recognizable,while,when I ried to do it to a desktop,with the same Win7/64bit Home Pemium system as the laptop,it was recognized at once,playing TV digital channels.

Can you help me please to overcome this problem?