Shared Music won't Load in iTunes

Hello,

     iTunes won’t load shared music from a My Book Live 3TB with the most recent firmware (Version 02.02.02-020 : Core F/W).  My MacBook Pro is new, running well, and equipped with the latest version of all relevant software.  There is about 150BG of music in the “Shared Music” folder on the My Book Live’s “Public” folder.  All of it is accessable through a file browser, but not iTunes.  The folder sharing is set to “All” in the drive’s UI (Shares -> Public -> Media Sharing: All), and I have refreshed the iTunes server through the UI as well  (Settings -> Media -> iTunes -> Enable & Rescan).  The song list used to load fine in iTunes (10.5) but I’ve done two things since they worked last: (1) loaded more than 50GB of additional music (it worked when I had 100GB), and (2) installed an update for Lion.

    Now, when I click “MyBookLive” in iTunes under “Shared,” it gets hung up as if loading but it never finshes loading.  The process has run for over an hour and just shows the following in iTunes:

iTunes hung loading MyBookLive

     This issue isn’t restricted to my computer.  The same exact thing happens on computers running the previous two versions of OSX (Tiger and Snow Leopard), as well as on two other Windows machines (one using Windows 7 another using Windows Vista).  All five of the computers have the latest version of iTunes installed and all five used to pull up all the music within about 10 seconds before the process started getting hung up.  Something odd I’ve noticed is that the “Shared Music” folder on the drive registers as only 12kb, but the folders in it add up to nearly 150GB.  Any suggestions?

-Mattalones

I haven’t tried it yet, but I’m seeing reports in other locations that the iTunes 10.5 upgrade might be the cause of this.

It’s happened before…  Apple changes something in iTunes and all the other folks have to scramble to patch it.

But, again, I’m not sure if it’s related…

The same happening here. Hope they can fix it soon.

I have the same problem!

+1 here.

Greetings
listener1

Same problem here - the shared music lib ist visible and accessible via tools like ourTunes (see http://ourtunes.sourceforge.net/),,) so I guess it’s really a DAAP protocol problem related to changes introduced with iTunes 10.5 … waiting for a fix.

Same problem with my WD Mybook Live 2TB. On pc and Macbook version of Itunes. 

Music in public share folder is accesible through all file browser, but not in Itunes. I get the same ‘loading’ message in Itunes.

WD please update firmware.

first time i’ve tried putting music in the Public share and nothing appears in itunes. this has been happening since itunes 10.4, now on 10.5 with the same issue. all my settings are correct in itunes and sharing all media is set on the drive as well as the itunes server enabled. this really **bleep**…

Same issue here on Win 7 64. I was a beta tester for iOS 5 so I had iTines for Windosws 10.5 before the public release and have been having this same problem with it.

Looks like Apple changed something;  something previously optional in the DAAPD handshake is now required, and mt-daapd doesn’t support it.

Lots of vendors are broken now.

https://discussions.apple.com/thread/3372281?start=0&tstart=0

Has anyone any news on how long a fix might take? I purchased my WD network drive 3 days ago and am contemplating taking it back as the idea was to have a cost effective itunes server in the home. 

A WD moderator should comment soemwhere in these posts with some sort of progress update on this issue. I cannot recommend this product to anyone wanting to use it with itunes right now.

Other wise ideal for sharing files and media from one central place.

This issue should be resolved in the next firmware update for the My Book Live. Timing on it - well I don’t want to say an exact time as these things always change, but “should be” less than a month away.

They just upgrade the firmware to Firmware Version 02.03.01-024 and it did not fix the problem :frowning:

I noticed the same. I am going to wait another week to see if a firmware update turns up and fixes anything and then the drive is going back. I think a qnap device might be my alternative.

WordpressGuy wrote:

I noticed the same. I am going to wait another week to see if a firmware update turns up and fixes anything and then the drive is going back. I think a qnap device might be my alternative.

QNAP has the same problem.   

In fact, any device that relies on GPL mt-daap has this problem.

noticed a bunch of firewall events between my pc and the NAS, it was a UDP protocol that was being blocked repeatedly to/from various ports between the PC and the NAS. when i added a rule to allow svchost to pass thru, the mybooklive appeared under shared in itunes, but the status remained at loading mybooklive. stayed that way for some time, then i gave up. i tried replicating this by toggling the sharing feature in itunes a few times but it hasn’t happened again.firewall is not even showing any activity to/from the NAS and the PC. running latest firmware, and the mapped drive works fine.

Here is a discussion @Apple Support Community (look for Deledrius posts on page 3): it seems that there’s even a patch available for forked-daapd (which is the software deployed in our MBLs). Unfortunately I’m unable to recompile forked-daapd using the source WDC has published due to too many dependancies on other packages (running out of spaces while resolving those deps), otherwise I could provide a deb to fix this problem.

Still waiting for a firmware update that fixes this issue…

By next firmware update - I DID NOT mean this security update. As you can see by the release notes - there is only one fix in that udpate. The new version of the forked-daaap will be in the update I said would be out in less than a month.

is it then safe to take my pewny 35GB of music and put it on my NAS in anticipation of this update ? does this sharing issue have anything to do with svchost ? any special rules i’d need to add to my pc’s firewalls in order to ensure seamless communication ? been looking forward to dropping all my music onto the NAS so that I can free up some space from my internal drive.

It looks like that the problem is in place for quite a while if it was already there with iTunes 10.4, for video streaming even earlier. Please hurry up with the fix.