Share Access Issues

For some reason, even with the access set to ‘No Access’, all users can access the USB drive attached to My Cloud.

Before I did a Quick Restore, all shares were accessible regardless of the share access setting.

Now there seems to be problems with the USB drive share, so far.

This is unacceptable. Western Digital need to address this issue urgently.

I’ve had so many problems with my cloud since I bought it. I’ve spent many hours of my time dealing with this.

Please can you fix the issue.

What is set to "No Access’? Are you accessing the USB drive locally or remotely?

Couple of things to try. In the Dashboard, navigate to Settings > General > Cloud Access > USB Content Availability = Off. Set the Public Access setting for the USB Share to off. Again in the Dashboard, navigate to Shares > select USB Share > Share Profile > Public Access = Off. Then in the User Access section on the Shares page one can set the User access to that share; No Access, Read Access, or Full Access.

USB Content Availability is off.
Public Access to the share is off.
Each user has set ‘No Access’ for that share.

I can access it locally, and via FTP still.

I’m going to submit a support request. I use the drive attached via USB for Safepoints.

This is a serious issue.

When you say “I can access it locally, and via FTP still” … are you the “Admin” or a “User”?

I can do it from both. If I add new users, they can access it too.

Yesterday all shares could be accessed by anyone. Regardless of what the settings were. At least after a Quick Restore, it fixed that, but now anyone can access the USB drive still.

I’m ready to hurl it in the bin.

I’ve done another restore. Still got the same issue.

All users have full access to the drive connected via the USB.

This is where the Safepoint is, so this does me no good. If WD can’t fix this, then I may as well ditch it.

I’m without a cloud until WD finds a solution.

I’ve submitted a support request.

It looks to me that there may be a misunderstanding of what is the primary function is for those external USB drives.

As far as I can tell (from using an attached USB drive) it will be unavailable to local net users if the [USB Content] = ON regardless of WDMyCloud security settings and will appear as just another network attached drive.

Like me, if you are using that drive for Safepoints and you do NOT want any user access to the drive then set [USB Content] = OFF and use the drive for just Safepoints.

I believe that the primary function for the USB external drive is backup and not additional NAS space. Just my SWAG. :grinning:


But it creates the drive as a share, and I should be able to set Full Access, Read Access or No Access. At the moment, even if I set it to No Access, all users have access to it via FTP. Also, I have it mapped on my PC, and regardless of the access setting, I can still access it.

This problem just started with the last firmware update.

I didn’t realize that this changed with that last FW release.


It’s a bug. I hope someone else can try this and see if they have the same problem. Try turning share access off for a user and see you or whoever can still access it.

No, it seems to work correctly if you follow the logical steps to secure the USB share.

Here is the Shares after the FW update and after establishing a new Safepoint.

Next, turn OFF Media Serving and Public Access.

Once that is done, your USB drive should be inaccessible as a Windows share.

Now you can go back to the Dashboard and make the USB shares available to whom ever you choose (of course, to me!).


How is it possible I can access the Share via FTP for all users when the share is set as NO ACCESS for all users?

Is that normal?

I guess FTP is a different case. Why do you need FTP?


So, I just went through the WD documentation for the MyCloud and the extra documentation for the FTP access and when set up according to these documents FTP access IS secure! Users have no access to the USB drive unless they have user access to the share and have FTP rights and (most importantly) have a password.

I ran these tests using a depreciated Windows user (meaning, not an Administrator) and with no special access. This user can only access the Cloud PUBLIC shares and, of course, the FTP shares I allowed that user rights to.

So, what is different in your setup?


Holy smokes!

If I log into Windows as a standard user, and attempt to access WDMyCloud dashboard, or the WD Quick View, or FTP into the device and download or just attempt access using Windows File Explorer, I am refused.

But if I use the WD MyCloud application then I can access all of the shares on the WDMyCloud! This is unbelievable!


Is this with the latest Firmware?

How are you trying to access the My Cloud? By IP address or hostname? I’m logged in as a standard user, on my windows 10 laptop. I can access the dashboard. I have access thru the file explorer. I have the My Cloud set up in the router ti always get the same IP address.