Runtime error (visual basic C++) during installation on XP SP3

During installation off My Book Live Duo everything starts up normal. The software recognizes the drive en suggests a drive letter. After pressing continue the system stops with a runtime error “abnormal program termination”.

It doesn’t matter witch drive letter I choose.

I use a cable between the computer and the router where the My Book Live Duo is connected.

UPnP Framework is enabled.

How can I solve this problem? Please can someone help me?

Albert Jan

Instead of using SmartWare, I suggest you just manually connect to the drive.

Open “My Computer.”

Click MAP NETWORK DRIVE in the menu.

Pick a drive letter from the drop down

in the FOLDER path, put

\(ip address of your mybook live)\Share Name

Such as 


and click FINISH.

The mapping is working fine. However, how do I get access to the functions of Quick View since I have not been able to install them following the normal routine. I would like to set up RAID but I assume I need Quick View to configure the setup?

I have never used QuickView.  :)

ALL setup functions are available via the Web User Interface.

Maybe a stupid question, but how do I get to the web user interface?

Put the ip address of your MBL into the browser.

Thx! Worked well!

Edebets. I have PM’d you a couple times. I am trying trying to figure out why you got a runtime error. Please respond to the PMs I have sent you :slight_smile:

Dear Tony,

Thanks for the explanation. I managed to get into the web services of My Book  Live duo . But I can’t find the right way mapping that dis into my computer. In XP there is no possibility to select Map network drive under “My computer” so I stuck at that point.

The IP-adress of My Book Live duo is when is connected it to my router

Can You explain me how I can do this?

Albert Jan

Dear WDTony,

I’ve got the same exact problem:

"Microsoft Visual C++ Runtime Library

Runtime Error!

Program: K:\Setup.exe

This application has requested the Runtime to terminate it in an unusual way. 

Please contact the applications’s support team for more information."

Running the setup.exe is fine, I do get to display “My Book Live Duo Discovery” and “My Book Live Duo Found”, can display the “Details”, but as soon as I click on the “Continue” button the error comes up and the application cannot be closed, nor stopped via the Windows Task Manager. It does not respond to clicking onto it at all anymore.

I’m running Windows Vista Business SP2.

Any help would be dearly appreciated!

It looks like we have had some units go through manufacturing with no files in the software folder on the Duo. This is pretty easy to get around by following the steps below. I am assuming you purchased the Duo from a retailer in Europe?

Updating the Software Folder for Duo
To update the Software content, please do the following


  1. Go to the WD link below to download the zip file:

  1. Click on the Download now button
  2. Save the zip file to your desktop and extract the files
  3. You will then see the Software folder. **IGNORE all the other folders**
  4. Open the Software folder
  5. Copy all of the files in Software folder to the public/Software folder in the Duo.  
    Note: Delete any existing files in the public/Software folder first

Let me know if that helps.


1 Like

I had the same problem with the setup.exe. Glad it is not my pc configuration, but a shame that WD has let pass such errors on the market. I was and still am a fan of the wd products but i hope it Will not happen again, because i dont want to lose my confidence in wd. I managed to find the drivers and install the wd software and managed to assign the drive letter using Windows network configuration. Do i still execute the steps wdtony suggest? I think my software folder is empty too.

If you have already installed Quickview, Smartware, and mapped your drive to your computer, then there is no need to do this.


Thanks for the help. After updating my firmware and follow the instructions as you described the problem is solved.

The installation software on the CD is working normal. After the software discovered the Duo the installation of the smartware follows without any problems.

Thanks for all the help!

Albert Jan

It is not a “Europe” issue.  Original drive purchased from Amazon(within a week of public release) had this issue.  Replacement purchased from Best Buy did not have this issue.

  As you can probably see, the original drive from amazon had other issues, so it is more than just files missing.  Hopefuly the ones on Best Buy’s selves are of better quality than the first batch being sold by Amazon.

Hi all,

I did what WDTONY suggested and ran the installation CD again, problem solved. The driver has been recognised and everything is installed. However, when updating the firmware through the Dashboard I encountered another problem, which I wlll post in a next topic.

Hello Theos2,

In my case it was the missing software and probably also the more recent version of the firmware.

Did the drive from Amazon had missing files? Then I think that the same “Europe” issue (batch) is sold bij Amazon while Best Buy have a earlier or later version of the same product.

Yes, the amazon device was missing the files in the software folder.  The best buy(currently in use) has the files in the folder and I did not receive the runtime error on install.

  If you don’t plan on using the smartware, is the software required?   Also, is there a relationship between this missing files issue and the DLNA corruption(for lack of a better definition?)  i am not sure this has been proven.


  quick question.

  I was browsing through the Software folder, and went into the DUO drivers folder and noticed that there are actually 2 files that windows 7 recognizes as acceptable drivers for this device.  One is labeled PnpXA2pc and the other is a wdb…  I am quoting these names from memory, so I don’t have the exact names right.  Any idea why there are 2?  Which one should be used in what situation?

You shouldn’t have to worry about that. One might be for the pnpx/Rally drivers for Windows 7. Not sure what the other is you are talking about.