Restsdk-server high cpu

It has been close to a year since I approached western digital regarding my issue. I’ve been noticing that MyCloud’s CPU is running at approximately >90% capacity. I think is causing the unit to shut down, at least I think that is what is happening. I receive an email saying that there is a power supply failure. There are no major sounds, the cloud is quite quiet. I am working on getting a fan in hopes that maybe it will help the CPU cool down from the “restsdk-server” Can some one help me figure this out?


What WD Device do you own? Is it the single bay, 1st generation WDMYCLOUD?

It is exactly what’s portrait in the picture above. It is a 4 terabytes single bay. WDMycloud. Some times I feel these companies unleash software on their own product past their warranties to push us to buy newer products.

When you open the Dashboard what does Diagnosis show? See example image below.

If you feel you need a new power adapter look at this list for requirements/replacement.
Power Adapters for Western Digital Products (

If your dashboard looks like the image below, then you have a 2nd generation WDMYCLOUD

If you haven’t done so already, use the forum search feature (magnifying glass icon top right). There are a number of past discussions about restsdk-server and other services that run on the single bay/single drive My Cloud that some have ended up disabling using SSH.

For example this post:

Many of us first gen users have disabled Restsdk and several other services in an attempt to deal with various My Cloud issues, in particular the “sleep” issue that is well discussed in many other posts in this OS3 subforum. Generally for OS3 v4.x firmware users they can use the /etc/rc2.d/S98user-start file to stop certain services when the My Cloud boots up.

A basic example of the S98user-start file I’ve run on a single bay OS3 v4.x firmware My Cloud. Unknown if the 2nd gen single bay v2.x firmware uses the same commands or user-start file.

# Attempts to fix sleep issue with Samba
/etc/init.d/samba stop
mount -t tmpfs -o mode=0700,noatime,size=2m tmpfs /etc/samba/msg.sock/
/etc/init.d/samba start

# Stop certain unwanted wakeups
mount -o remount,noatime,nodiratime /dev/root /

# Stopped My Cloud services
/etc/rc2.d/S20restsdk-serverd stop
/etc/rc2.d/S85wdmcserverd stop
/etc/rc2.d/S86wdphotodbmergerd stop
/etc/rc2.d/S92wdnotifierd stop

It appears by your screen captures you may be using a second gen single bay My Cloud. If so you can update the second gen to the OS5 firmware if you haven’t already done so. Downside is that OS5 comes with it’s own issues, particularly with indexing files.

Your screen capture also indicates you have a firmware update available. You may want to update the firmware to the latest version to patch/fix any security or firmware issues/vulnerabilities.

If you have already updated to the OS5 v5.x firmware then see the dedicates OS5 subforum where there may be additional discussion similar to your issue (which is likely Cloud Access related). Note that the single bay My Cloud hardware has difficulty running both OS3 and OS5 firmware due to its limited processor and RAM.

OS5 My Cloud

dswv42 is correct.

The screen shots clearly show this is a 2nd Gen mycloud; running a version of OS/5.
The problem is definitely the indexing process. More than one unit has been bricked by this process; or by users powering down the device during the indexing process.

The cure is simple: Disable all cloud services (should be a single button). The indexing is ONLY relevant to WD app cloud access; and if you disable cloud services. . the device won’t index.

The cause is simple: The OS/5 indexing process is horribly inefficient; and has been since day one. WD while acknowledging this can take time; they have NEVER acknowledged that this is a problem. (This lack of acknowledgment is the true root cause problem; because there is no plan to fix it)

Bennor is correct in his points;

  • This is an O/S 3 subforum - - → so technically the message is in the wrong place (ALTHOUGH - - - > This forum only has about 4 active users . . .and we have all responded)

  • You should update the OS/5 firmware as a security measure. . . although I have serious questions about the security of OS/5 software even when fully patched. I highly doubt a new version of OS//5 will fix the indexing problem. (Because according to WD. . . it’s not a problem)

I would further suggest for privacy reasons, you might consider blocking internet access to this device from your router. Disabling cloud services does not prevent the device from “phoning home” for everything from time-sycronizations; firmware version checks. . . to who knows.

If internet access to the device is needed . . . . we should talk. There are a number of ways to go about this that do not require indexing and WD Apps.