Repository with software worked on v4 firmware

Update:

Full Build-essential (Binutils already patched. So you can make chroot and compile some software on WDMC)

Samba 3.6.6 (Maybe brocken dependences. I add all later)

# Packages in repo: 1267 :smiley:

 @Fox_exe

excellent repo, thanks a lot! 

I was wondering, how could i make the pip to work in python. Can you guys help? 

WDMyCloud:~# apt-get install python-pip
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-pip : Depends: python-pkg-resources but it is not installable
              Depends: python-setuptools (>= 0.6c1) but it is not installable
              Recommends: python-dev-all (>= 2.6) but it is not installable
              Recommends: build-essential but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
WDMyCloud:~#

It required other packages but it doesn’t exist in the repo. I think resolving dependency isn’t easy.

  • Python-pip - Done
  • Transmission-daemon - Done
  • PyLoad - Done
  • ffmpeg - Done.

Packages in repo: 1326

wow!! thanks for you efforts!!

Hi Fox

I have compiled some packages with the 64k

Can add them to the Repository

They are available on 

http://diaa.no-ip.com:8080/Misc/

The packages are

Dovecot – ( IMAP and POP 3 server )

postfix   — (SMTP server )

Incron

SASL2

Owncloud 7

debtree 1.0.10

For test:  Kernel v3.2.68 + custom modules (For v4 fw)

  • Maybe its fix USB 3.0 problems and freezes (“WDMC disconnected from network” problems).
  • Kernel compiled in Chroot at v4 firmware (Yeah, all packages for build/make packages available in my repo!)

Later i make a .deb package for installing through Apt. (+ deb package for original for roll-back chages if something do wrong)

Thanks for fixing the python-pip. It helped me a lot. 

I have also an issue installing build-essential. 

Am I approaching in correctly? 

WDMyCloud:~# apt-get install build-essential
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 build-essential : Depends: libc6-dev but it is not going to be installed or
                            libc-dev
                   Depends: g++ (>= 4:4.4.3) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Strange… I check it again on clean system. Build-essential installed ok. No problems…

Try run apt-get install -s libc6-dev and other dependencies packages until you get “Unable to find this package” or something similar.

can i have a help about pyload server ? :frowning:

my pyload server is giving an error.

1369 07.04.2015 22:34:08 INFO pyLoad is up and running
1370 07.04.2015 22:34:40 WARNING Not able to connect server for updates
1371 07.04.2015 22:34:40 INFO No Updates for pyLoad

Dear Fox_Exe,

Could you provide Subliminal package  for automatic subtitle download from Opensubtitles 

:stuck_out_tongue:

cheers,

Regarding my issue installing build-essential above: 

I started to track down missing packages: 

WDMyCloud:~# apt-get install -s build-essential
build-essential : Depends: libc6-dev but it is not going to be installed or
                            libc-dev
                   Depends: g++ (>= 4:4.4.3) but it is not going to be installed

WDMyCloud:~# apt-get install -s g++
 g++ : Depends: g++-4.6 (>= 4.4.7-1~) but it is not going to be installed

WDMyCloud:~# apt-get install -s g++-4.6
g++-4.6 : Depends: libstdc++6-4.6-dev (= 4.6.3-14) but it is not going to be installed

WDMyCloud:~# apt-get install -s libstdc++-4.6-dev
E: Unable to locate package libstdc++-4.6-dev
E: Couldn't find any package by regex 'libstdc++-4.6-dev'

It seems the “Black Pete” is the ‘libstdc+±4.6-dev’. 

Do you think this was the root of the problem? 

When tracking the libc-dev and libc6-dev packages dependencies with install -s i found no other missing packages. 

libstdc++6-4.6-dev is available in my repo, as i say.

Apt-get update ?

apt-get update done 

There here was a typo in my previous post between  ‘libstdc+±4.6-dev’ and  ‘libstdc++6-4.6-dev’. That package is obviosly in the repo as you say. My bad. 

My current assumption of the root of the problem is version mismatch of libc6 and others 

WDMyCloud:~# apt-get -s install libc6-dev
The following packages have unmet dependencies:
 libc6-dev : Depends: libc6 (= 2.13-38+deb7u8) but 2.17-93 is to be installed
             Depends: libc-dev-bin (= 2.13-38+deb7u8) but 2.17-93 is to be installed
E: Unable to correct problems, you have held broken packages.

WDMyCloud:~# dpkg -l|grep libc6
ii libc6:armhf 2.17-93 armhf Embedded GNU C Library: Shared libraries

I wouldn’t be afraid to experiment (install -f or upgrade or maybe sid repo?) but currently I have only remote access to MyCloud. It should have the latest firmware installed (4.01.03.421) 

What would you suggest? 

Do you guys have any thoughts about the package version mismatch? What should I do?

Thanks

Better way - use chroot.

Hi folks,

Can you please suggest me an easy configurable VPN server on My Cloud?
Appratiate if you have a quide to setup VPN on my cloud, I search on board and couldn’t find an easy applicaple solution.
Thanks…

What firmware version are you using for successful build essential?

How about adding fail2ban and mkvtoolnix?

Cheers