Red light when attached to Netgear hub

Hi all,

I’m stumped.  I bought a new My Book Live (MBL) 1TB recently and it won’t work when attached to a Netgear DS108 8-port unmanaged hub.  It boots through the blue and yellow lights, but then the light turns red instead of green.  The network adapter lights on the back blink during the boot process but go off when it reaches the red light.  And it’s not active on the network - I can’t see it from either of the two Dell Optiplex PC’s attached to the hub.  It even boots to the red light with nothing else attached to the hub.  I’ve tried attaching it to different ports of the hub and used different cables, but still no joy.

The MBL does boot to a green light when attached to one of the PC’s - and I can access the MBL.  It also boots to a green light when plugged into just the single port of the Sagemcom 4300 DSL modem.  And it works fine on other networks and PC’s not associated with this problem hub.

Everything else attached to the hub works fine.  And there is no capability for updating the firmware of the hub.  I haven’t yet tried updating the firmware of the MBL.

So, any ideas what it is about the hub that’s not compatible with the MBL?  Can the MBL configuration be changed to work with the hub?



can you make speed/duplex adjustments on the hub?

Tried another cable?


I did try a different cable that I know is fine.  And unfortunately, the hub doesn’t allow speed/duplex changes.



Ok, I’m a network engineer, and I want to check some terminology here.   :slight_smile:

Are you actually using a HUB?   As in, it’s not a SWITCH?

If it’s a HUB (which is generally used synonymously with “multiport Repeater”) , it’s quite possibly 10 megabits per second, and most likely (even if it’s 100 meg) HALF DUPLEX.

I am, quite frankly, not sure if the MBL supports half-duplex networking.

Can you post the exact model number of this “Hub?”

switch/hub - whatever…

Sounds more like 'where is my DHCP-Server…

From what is readable: Modem, Hub, PC - well… Red Light is one indicator for: No IP/network.

can you clearify this?

How are your IP’s addressed in your network?


Hi all,

Per Netgear’s description, it’s a Netgear DS108 8-port 10/100 Mbps Dual Speed Hub.

The IP addresses are assigned via DHCP by the Windstream/Sagemcom DSL modem.

Thanks for sticking with me.


@Rockstar DA:

  >> switch/hub - whatever…

  >> Sounds more like 'where is my DHCP-Server…

I would agree, except that the poster said:

 The network adapter lights on the back blink during the boot process but go off when it reaches the red light. 

If the Ethernet LEDs go *OFF* when the front panel LED goes RED, that’s not a symptom of DHCP failure.   That’s a symptom of NETWORK failure.

@bsbsbs:  Wow.  That’s an old bit of kit … almost 13 year-old-technology.   It’s so old that the autonegotiation may not be working correctly with the more modern equipment.   

It actually IS just a repeater, and thus only operates at HALF DUPLEX.

I don’t know if the MBL will allow half-duplex.

Time for an upgrade.   If you like NetGear products, I recommend the NetGear GS-108Tv2.

The My Book Live does not support Half Duplex. You will need to upgrade your switch (or hub). You can find pretty cheap switches online for under $50.

1 Like

Hi all,

Thanks for all of your help.  I replaced the DS108 switch with a Netgear N300 wireless router.  It’s not a switch, but it has DSL and wireless capabilities in case I need them.  And best of all, the MBL is now working properly.

Thanks again and have one on me.