Reading from a Removed Harddrive from WD MyCloud

I have a hard drive that was removed from an old WD MyCloud device. This was a NAS one generation before they actually started calling it MyCloud if that makes any difference.

Question is, what operating system will be able to read this drive? I’ve tried plugging it into a Windows 10 machine as well as OSX El Capitan and it shows up as unformatted.

Thanks

The first generation and second generation My Cloud hard drives use Linux (gen 1 uses Debain, gen 2 uses BusyBox on top of Linux).

Generally one can use a Linux Live CD, like the popular Ubuntu (http://www.ubuntu.com/download/desktop), to boot their PC and read from and write to a WD My Cloud hard drive attached to the computer.

Great! Thanks for the help. I’ll give that a try tonight.

I got a mount error when I tried this…

zero exit status 32: mount: wrong fs type

Ran fdisk -l and parted -l

sudo fdisk -l

Disk /dev/sdc: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: F718FA58-0B61-4964-A0A9-EA92BEB92ACE

Device Start End Sectors Size Type
/dev/sdc1 1032192 5031935 3999744 1.9G Linux RAID
/dev/sdc2 5031936 9031679 3999744 1.9G Linux RAID
/dev/sdc3 30720 1032191 1001472 489M Microsoft basic data
/dev/sdc4 9031680 3907028991 3897997312 1.8T Microsoft basic data

sudo parted -l

Model: ASMT 2105 (scsi)
Disk /dev/sdc: 2000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt
Disk Flags:

Number Start End Size File system Name Flags
3 15.7MB 528MB 513MB primary msftdata
1 528MB 2576MB 2048MB ext3 primary raid
2 2576MB 4624MB 2048MB ext3 primary raid
4 4624MB 2000GB 1996GB ext4 primary msftdata

Should be able to mount -t ext3 /dev/sdc4

RAC

Edit Why did it remove the mount point I put it in < mount point > Apparently you need a space after the < character.

Tried this and got:

mount: can’t find /dev/sdc4 in /etc/fstab

You need to specify a mount point, too.

Something like

mount -t ext3 /dev/sdc4 /some/folder/to/mount/to

Seen as HTML tag.

Always use the code formatting </> when posting code snippets; saves that sort of problem.