PR4100 occasionally won’t turn off

I’ve had my PR4100 since launch and the first year or so it’d turn off when I pressed the power button, but at some point this started being problematic. I think it was around the time they updated the firmware to remove ‘shutdown’ as an option form the web ui (which for the life of me I’ll never understand; it was so convenient being able to turn off without having to walk up to it).

I have the led set to turn off after a few moments. When I start experiencing this issue, the menu toggle buttons will still turn on the led, but pressing power does absolutely nothing (led doesn’t even turn on). I’ve tried unplugging the network cable (power button goes red, but still does nothing when pressed). I’ve even put it in standby using the web ui, and it seems to go in standby (power led flashes for a few moments then turns off; hdd lights are on and steady), but the power button then fails to wake it up, and trying to access it over the network fails to, too.

I logged a ticket and the support was pretty horrendous. I was told bs pr in the form of, ‘the pr4100 is designed to be left always on. You can schedule standby for times you don’t need it.’ They also suggested it might be doing some sort of maintenance, so I tried leaving it on for a week with it continuing to fail to respond before I finally gave up and did a cold shutdown.

Of course, I’d like to be able to turn it off when I’d like. (E,g., finding it wouldn’t turn off when i had to turn off power in the flat for electric work wasn’t fun.) and being told to schedule standby wasn’t really helpful. I gave up on support when I noticed there was a bit of correlation between how long it was on and when it’d stop responding to shutdow. (Generally, it turns off if I turn it off at the end of the day, but the more days it’s left on, the more likely it is to stop responding to pressing the power button.) So I just got in the habit of turning it off each night.

Anyway, it’s happened yet again (after just being on a few hours) and I thought to search google to see if I could find anyone else reporting this issue in the hope of finding a solution, but still no luck. So I thought I’d bite the bullet and post here to ask directly.

So… Does anyone else have this problem? Any workaround other than holding the power button for the 5 or so seconds it takes to do a cold shutdown?

@Zensunni We’ve provided a public BETA release of v2.31.195 for testing purposes.

My Cloud PR2100/PR4100 2.31.195 BETA Firmware for Reboot Issue

Thanks for the heads up, but that doesn’t seem related to my issue, but reboot issues many are reporting when installing firmware updates.

My issue is that the longer I leave the pr4100 on, the more likely it is to stop responding to the power button being pressed when attempting to turn it off. But this is a problem after just 12+ hours of uptime, not the two weeks implied in the firmware update.

Are you saying that firmware update is meant to fix the specific problem I’ve reported, too?

@Zensunni haven’t heard of a power button issue before.
Have you contacted technical support? Have your provided them your PR4100 system logs?
I would suggest to do that and they may replace the unit via warranty replacement.

Could you read my post fully to understand my issue before replying to it please?

@Zensunni OK I understand the issue you’re reporting now.
I’ll run a test some tests against the beta firmware and the immediate press of the power button.

@Zensunni I’m unable to reproduce your power button issue using the beta version of 2.31.195.Granted that I haven’t tested the existing product 2.31.195 or any previous firmware versions. I will do this now

  • 10/25/2019 8:55 AM - Press and release the power button = Unit is powered OFF
  • 10/25/2019 9:10 AM - Press and release the power button = Unit is powered ON
  • 10/28/2019 5:45 AM - Press and release the power button = Unit is powered OFF
  • 10/28/2019 5:55 AM - Press and release the power button = Unit is powered ON

@Zensunni I found no issues with production 2.31.195 firmware. I suggest to submit and RMA

  • 10/28/2019 6:37 AM - Install production firmware 2.31.195
  • 10/29/2019 5:50 AM - Press and release the power button = Unit is powered OFF
  • 10/29/2019 5:52 AM - Press and release the power button = Unit is powered ON


I may not have been clear enough in my original post. The problem isn’t constant, but sporadic. As long as I shut it down daily, the power button generally responds. But the longer it’s left on, the more likely it is to stop responding to the power button.

I turned on extended logging and have left it on a few days. This evening I went to turn it off, and it wouldn’t respond to the power button. I ensured no backups were running and turned off the plex server to ensure that wasn’t holding things up, but still it wouldn’t respond.

I then initiated a reboot via the web UI (because for some reason Western Digital decided to remove ‘shutdown’ as an option from the web UI) and the web UI responded that it was going to reboot. After a few moments, I pressed the up/down button the unit to light up the LED, which said ‘shutting down’ and the blue power button was slowly flashing. After a minute of waiting, I pressed the up/down button again to check the LED and now it won’t light up. The blue power button remains slowly flashing 20 minutes later. I thought perhaps it was in hibernation instead, but pressing the power button doesn’t wake it up and neither does trying to access the web UI or open shares.

I’m going to leave it in this state over night, but my experience is that the only thing I can do now is hold the power button for 5-10 seconds to force the shutdown (which implies it’s not a hardware problem with the button).

When I am able to get back into it (assuming it either starts responding again tomorrow or I pull the plug), how can I pull the extended logs to share this with you?

You mention Plexmediaserver. Do you have other 3rd party apps installed? They may interfere with the shutdown process.

Nope, Plex Media Server is the only 3rd party app installed.

Did you get to the bottom of this? I’ve experienced this today. Looking to rellocate the box and went to turn it off and it won’t. Wondered if that was because someone was loggged into it at the time but not the case.

I have been having this problem now for about a month. If the system is on for more than 5 days randomly the network card stops responding, and can not turn off using the power button.

Your post history suggests that you have an EX4100, which has different hardware with it’s own unique set of issues. The power button problem addressed in this thread is specific to the PR4100 and PR2100 hardware.

LOL, Strange to have someone look up my histories… But I run an IT company for 26 years I have a ton of WD products that are implemented at different client sites. So yes one of my clients has a PR4100 but you are correct this is an EX4100 my understanding is that they are all running the same firmware, (Firmware Version: 5.25.124) but I can move this to a new thread if you need me to.

Wow, I forgot all about this.

WD had sent me a replacement (I think they thought it was a hardware fault in the button), but the replacement not only had the same issue, but had an entirely new issue - the LCD wouldn’t turn off per the energy saver setting (it dimmed a bit, but wouldn’t turn off completely).

Apparently an actual design flaw made it into later models (not sure if it’s since been fixed). Here’s a thread on it. The design flaw is discussed near the end.

At least the LCD fault was constant and easy to prove (the power button issue sometimes took days to kick in).

After several months of back and forth with WD sending replacements that all had the LCD issue, WD eventually offered to refund me the full price of the NAS (I had originally purchased it direct from them).

I took the refund and switched to a competitor’s NAS and have been happily NASing ever since. I wouldn’t buy or use a WD NAS again.

Indeed, some PR4100s have multiple unrelated issues.

The power button issue is related to the power management controller (PMC) chip firmware timeout event counter (TEC), and the LCD display issue is a hardware design flaw that prevents pin 1 of the LM358 amplifier chip from reaching 12V so the p-mos tube can completely turn off.

You were very fortunate.

WD quietly swept the whole thing under the rug, and most users appear to have been told to go pound sand because their warranty had expired, so many of them also jumped ship and bought competitor’s NAS devices from Synology, etc.

WD never seemed to learn that users have long memories, where gaining their trust is hard, but once you lose it they’re gone forever.

Anyone can view post histories if a user’s profile is set to public. Just click on the username, then click it again to view their profile.

I’m just a regular user, same as you. However, it’s important to always say which device you have, because ambiguity only leads to confusion, where others may offer solutions that aren’t applicable to your particular device.

With regard to your EX4100 issues, the following thread may be helpful.

I have a PR4100 with the LCD display dimming issue, but it’s only used for backups and is powered off most of the time, so I just ignore it.