Possib le corrupted firmware


I, by mistake, tried to upgrade my firmware version and used wdlivehub release (3.12…) instead of the right latest release 1.06.46. I did it because for some reasons it did not display hebrew subtitles an I thought that my version was incorrect. Anyway, when I attached the USB Drive with the files to the device, it prompted it had found a new firmware and it commenced the upgrade. Now I understand that it did something very wrong and my question is how can I roll back. The problem now is that the device does not respond to the remote control and does not recognize the usb drive.

I hope this can be recovered otherwise …



Did you rename the files or something?

Otherwise I don’t know how it’d be possible for the WDTV Live/Live Plus to try to load files meant for another platform.  (It’s looking for files with a specific name.)

I use one memory stick to upgrade all of my devices, so I have versions of firmware for at least 5 different players stored on the flash (Live / Live Plus / Live Hub / Live SMP and WDTV Play)-- there’s never been any “confusion” on which files get installed.

Are you saying that your WDTV actually booted the new code and you have a menu, but just no remote control or USB connectivity?

Yes. I was wondering about it myself. and I do not understand why there my remote control does not control the device.

 I attached the USB stick and for some odd reasons it recognizes it (all of a sudden)  but propmting all the time about upgrading the firmware (does it , reboot again) and it does it in loop. I cannot control it and it does not respond to my remote control. I press the home button or the turn on/off button but in vain.

I now remembered that I renamed the files because I saw that nothing happened and rightly so because I was on the right version only I thought that becasue I could not read the subtitles correctly, I thought mistakingly that I needed to upgrade and to the wrong firmware :frowning:

What happened after you removed the USB stick?

Nothing. It is as it is waiting to continue the upgrade aain. But the remote control cannot control the device and pressing the power of home button does absolutely nothing. BTW, thanks for trying to help me. I am really hopeless

Please take pictures of your TV screen and post them so we can see what you see.


I followed your request. I inserted the USB diskonkey and the upgrade process began. at the end (see image) it was supposed to rebood the device and I waited for about 20 minutes until I decided to manually interfere. I pressed the powere and/or home but with no luck. So I disconnected the device from the power, re-connected it and now I saw again the upgrade process and again in loop . It seems my images are too large. Is there an email address I could send to so that you can see the images ?


Try an external “Image Host” eg. Imageshack, Photobucket etc…

Alternately,  (if you don’t want to register on an image host site)  try  … Tinypic, Postimage.org   etc

ok. I uploaded it to Rapid Share

try this


That isn’t a picture.   That’s some 7Z compressed file, and it’s saying it’ll take 20 minutes to download a 6M file??  

I resized and compressed his pics here (500kb version zip file (it’s got a bunch of pics) 


Here they are

Have you tried putting the CORRECT firmware in the flash stick?

hi guys

any understanding on what is the cause or how to repair it

Thanks Shimon

Are you reading the thread?  Look up at Post 6.

Hi Toni Joey and the rest of you Gurus

Any chance I could recover from this ordeal or should I look for a new streamer :frowning:

Sorry, I did not notice there is page 2 to the thread. Yes of course, the pictures you see is from the try when the right firmware is in the flash disk

I noticed that it does not create dot wd… on the flash disk. is this info something useful


Shimon wrote:

Hi Toni Joey and the rest of you Gurus


Any chance I could recover from this ordeal or should I look for a new streamer :frowning:

Look.  People are responding to your questions, but it looks like you are not reading them.   If you are, you’re not responding to their questions.

No more help can be offered if you don’t participate.

Look I apologized for not noticing the answers on page 2. I am new to the community and hence my mistake. I am not trying to disrespect any of you in particular when you are so kind to try and help me.

I looked at all the posts and I do not see any post I did not respond to.

Thanks Shimon