Plex Media Server won't run?

I don’t know if this will help anyone, but I spent a week reading blogs, reinstalling PLEX on my WD MyCloud EX2, and deleting preference files. Nothing was working and I was getting very frustrated. Bottom line up front, I wasn’t using the standard IP scheme for my home network. If you are using something different, you need to change back to to set up your plex server on your WD MyCloud EX2. I guess Plex only authorizes and similar out of the box IP schemes without authorization. Once you get into the server, you can then go to network, show advance settings, and then add your IP scheme to the List of IP addresses and networks that are allowed without auth.

Check these articles:

  • under the section: Can’t Access Server Settings
  • under the section: List of IP addresses and networks that are allowed without auth

That is what made the whole thing come together for me. After I listed my router IP and netmask in the plex settings (server, network, show advanced, list of IP addresses and networks that are allowed without auth) everything worked perfectly. The format is easy enough with your IP and netmask. After that you can update your router IP and return your network to the IP range you desire and entered in for authorization. I hope this helps.

No not really. It seems the config button wont work as it point to non https url on the new update.

I use a custom IP it works fine with that ip. All i need to do is point to https url just adding s to http .

Try it should work fine

I faced a similar issue and this worked for me. Hopefully it helps you all :slight_smile:

  1. Uninstall Plex Server from web UI
  2. Enable SSH on wd mycloud ex2 ultra web UI.
  3. SSH to WD via command ssh -o HostKeyAlgorithms=+ssh-dss sshd@your_ex2_ip_address
  4. Run cd /mnt/HD/HD_a2/Nas_Prog/
  5. Run rm -rf plex_conf/
  6. If applicable, Run rm -rf plexmediaserver/
  7. Reboot
  8. Download the latest build for your OS from the Plex website. It should be in .bin format. Media Server Downloads | Plex Media Server for Windows, Mac, Linux, FreeBSD and More
  9. Go back to wd mycloud web UI.
  10. Install Plex Manually using the latest .bin file which you downloaded
  11. Toggle the Run App
  12. Click Configure.

Copying some content from ohhohe’s post.

I had the same problem as you after the app was malfunctioning and i uninstalled it and re-installed it and couldn’t find any solutions on here. But i eventually did fix it by selecting install app manually and selecting the last plex server update bin file that i still had on my laptop. When i went back and tried launching the app it worked perfectly

I had the exact same problem as him and fixed it by using the install app manually option and selected the latest plex media server update bin file that was still on my laptop