Plex Media Server won't run?

Hi everyone, I have this weird issue regarding with Plex Media Server installation, now that I have My Cloud EX2 Ultra running on El Capitan up and running already, I’m thinking to give the Plex Media Server app a try, and have them run on my device. It used to run perfectly without any hustle. But just the other day, when I need to reset and reinstall the Plex Media Server application, it now won’t let me access the interface again?

Here’s the screen capture:

And once I clicked the Configure button, it redirected me to the following page:

It appeared something blocking the port 32400, I’ve checked my Firewall and other aspect that may prevent from blocking it, but couldn’t figure out what the solution is.

Any advise greatly appreciated.


There is the switch at the end of the first screenshot, “Run App”. Stop the App but switching it OFF, wait somewhere 10 seconds and switch it back ON and wait again somewhere 10 seconds. Then the Plex Web UI should open again.

Otherwise, checke your Chrome that the URL is not blocked as it used scipts and cookies.No clue hwat the red Stop icon right of the URL line is but it looks like that the Web UI is blocked. Excuse myself if I am wrong, I am not familiar with Chrome.

I tried this part, it’s not working here? Wonder why, it was just fine the other day though.

The red button it’s an ad-blocker actually, it was fine yesterday with the Chrome’s extension running still. I even switched to other browser like Safari and Firefox, but they’re still giving me the same issue? Any other solutions perhaps @Joerg_A?


Why did you need to reinstall the plex media server? Update issues? Performance problems?

Did you Change any other Settings esp. network related settings when reinstalling the plex?

I was reinstalling it due to the problem, at first it was just fine, then came along this port issues. So I figured I may need to reinstall them. As it appeared it didn’t solve the blocking part.

No I did not, well not that I remembered changing anything significant. So I decided to check the same port on my local machine, and Plex just working-out fine. So it’s not the browser issues, rather on the server-side probably.


Sounds like there are “old” settings left in the plex folder when reinstalling. I think this needs manual configuration via ssh shell. First delete plex than try to find the folders related to the plex installation via ssh and then rename the folder to “…_old”. Then try reinstalling. Thats what i would try

Okay, shall revert soon on this.


Hi Lutz

better way is to deinstall an App, then reboot the My Cloud. The Reboot would eliminate any forgotten pieces of an App.

I think that he did reboot and the settings won’t be deleted correctly.
But it’s worth a try to delete the app again and reboot the EX2.

1 Like

+1 :smiley:

Hi, this is a bit weird, now the plus button barely even show-up, after I delete and reboot my device?

And btw, no I haven’t SSH it yet.

Try it with safari and delete the browser cache.

If you are using cloud access then disable it for a second and re-enable it.

Wait a bit, the Install App (+ Button) will appear some seconds later, first the internet connection to the App Center will be checked.

@Lutz_Juwick @Joerg_A

Tried both, still no luck?

Is the EX2 set up with static ip?

Nope, on DHCP actually.

Ok than the IP in your screenshot is weird
Please set it up with a static ip with a dns server

True, but any ideas how did it get there? Since basically, I’m on DHCP, and obviously that’s not my ISP’s IP neither.

Thats an APIPA adress and says the dhcp server could not be contacted