Plex Media Server won't run?

Ahh ■■■■, I think, I keyed in the wrong information. Might as well just perform a factory setting. Revert soon @Lutz_Juwick.

@gerryleonugroho - Have you tried resetting your router anywhere along the way? Just a hunch…

I did @Great_Scottt, is just that, the router that came from my ISP is pretty lame. I need the extra coverage and the dual band features, so decided to put additional range-expander from an additional router. But the problem is when I plug my WD-MyCloud to it, it’s becoming not accessible.

That’s why I plugged the WD to my ISP’s router while trying to stream movies from it, through the dual-band 5GHz one, that’s when the whole IP conflict started to come in.


Gerry, resist suggestions to set up a static IP, I have over 30 gadgets on my home network and have never needed to setup a static IP for anything. All gadgets run fine under DHCP. Also the added router could be inserting conflicts of some sort. See my other post to you where I discuss this additionall router you have…

@gerryleonugroho - The first thing you need to do is isolate the problem - it could be the EX2, the computer, either router, even (although very unlikely) a problem with one of the cables. Try this:

  1. Disconnect EVERYTHING from your router and restart it.
  2. Disable Wifi on the router if you can, or disconnect all wifi devices. It might be faster to do a factory reset on the router (I was going to suggest that later if this didn’t work anyway…) and just not set up the wifi in the first place.
  3. Restart your computer - shouldn’t make a difference but lets just do it for good measure
  4. Restart the EX2.
  5. Connect JUST the single computer and the EX2 to the router using an Ethernet cable.
  6. See if you can access the page.

Gerry, another thought. If you need extended Wi-Fi range, just get an actual dual band range extender that does not need to be connected to a router. WD quit making the ones I have (although I can still find them new at closeout price of $25-30 in US.) Maybe you can, too, where you live. Otherwise, just look for ones made by router makers like Cisco, Linksys. Netgear, etc.

Hi @Great_Scottt @mike27oct @Lutz_Juwick

I think I managed to figure this out with the my main modem/router and the other wifi router expander. So no more IP conflicting again this time.

But the typical El Capitan - WD-Nas problem occurring again this time, El Capitan won’t pick-up the WD device again. The router has assigned the IP to the device as shown, but strangely El Capitan won’t pick it up. 81854 MyCloudEX2Ultra LAN1

I even did the same method which previously worked for me, but this I’m sort of running out of luck.

Tried accessing the interface, from a web browser, but still it won’t work.

Anyone with other ideas?


Setting up a static ip is the first point to ever find problems in your lan equipment. Resist all help in finding out the problem esp. when 169.254.x.x as IP is shown is a bad suggestion. Sorry but this is not really helpful.

Sorry, disagree, I have had plenty of problems with plenty of equipment and found every problem without resorting to static IP. I’m not just talking about my own problems but also others I have helped. I also have some tools that help me find LAN problems. If it works for you, then do it. Just don’t tell me I am not being helpful. Too many people lead off with “set a static IP” and that can just get folks into trouble, needlessly.

The guy’s problem seems to be coming from the Mac PC and I also think his tacking on an additional router isn’t helping things either, Both I and others suggested he remove,and I also suggested getting a range extender if he needs better 5G range and dump using the extra router.

If I was personally helping him in his home with this, I’d say take the extra darn router off, we don’t need it on main router; we first have to get the computer to acknowledge the My Cloud being added to the network. Strip this problem down to the basics to solve it.

Hi @Lutz_Juwick & @mike27oct

So eventually I decided to perform `My Cloud EX2 OS 3 Full Factory Restore’. I might perhaps messed-up couple of things previously, so it’d be best just to start everything all over again from scratch.

So fresh-up everything brand new again this time.

I figured, that’d solve the problem, it turned out the problem still persist, the plus button not showing-up still? This is weird.

So even after a fresh install, it didn’t solve my problem, though at first everything went well, the first time I brought this device home.

And now also saying that my device is also offline?

So anyone with other ideas?


Gerry, which factory restore did you do; was it System Only?

As mentioned earlier, I performed the ‘My Cloud EX2 OS 3 Full Factory Restore

A Full Restore will change all system settings back to the default ones, resets the My Cloud EX2 system, and fully deletes all information by overwriting or erasing all user data on the drives. All user data and shares are permanently deleted, making Data recovery programs unable to restore it.

But it didn’t work still?

Any other advise

Gerry, please relax about this (I know, easy for me to say!) If I had been able to tell you to forget about installing PLEX or any app before you even had the EX2 connected, I would have. As far as I know, doing a full factory “blow away everything” restore was unnecessary, since you had not added any data yet to EX2. I know I did recommend doing a System Only restore just to be sure the EX2 was at Point A and ready for action,

But, the action has to first come from the computer running your network, and that is the Mac. So, please quit restoring and messing with the EX2 until you find out why your darn Mac is being such a pain about accepting the EX2 from either WD or Apple.

I have thought of some other sources I can check for info. If I get any leads, I’ll let you know.

Yeach, is just that, it’s a bit weird, how previously I managed to get into the system and actually utilizing it, and how couple of hours later, it’s stop responding and barely even recognized that it’s there, hence the router displaying it perfectly that the device is within the network. Let me know if you know get any leads, thanks for the help @mike27oct


I had thought to check at for any reviews of your model EX2-Ultra. There are some, but no insights there as to installing on a Mac, etc. You might want to check there (at US site) and read the few reviews there for any info you can gain.

Okay @mike27oct we’ll head over to Amazon, shall get back to this thread once there’s any updates.


Okay @mike27oct, here’s what I did

  • Login to the web interface
  • Going to the app tab
  • Turned off the Plex Media Server
  • Did manual update, from the binary file found from Plex’s site
  • And it returned me with the following error.

Any ideas what went wrong? For sure, there’s nothing wrong with my current connection.



I have only updated PLEX once, because I decided not to use PLEX.

Anyway, some posted instructions in a thread here months ago, I followed them, and they worked. I even saved the instructions to a file, here they are:

Found the anser for Updating Plex. it works perfectly:

  1. Download the update for your WD NAS to your computer(a *.bin file).

  2. Open your My Cloud User Interface.

  3. Navigate to the Apps Page.

  4. Select “Add a new App” (the small box with a “+” on the lower left.)

  5. Select “Manually add a new App.”

  6. Navigate to where you downloaded the update file (*.bin).

  7. Select the *.bin update.

  8. Follow instructions from there.

Good Luck.

Hi Mike,

Still getting the same error again and again. Not really sure what went wrong though. The latest release is far more stable than the pre-installed one, it’s causing the disk making noises all over. I wonder what causing the problem and preventing it from updating the systems while others have made it perfectly okay.


No idea, let’s hope others can help.