Pellentesque Pretium

Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere cubilia curae; Morbi tristique mi ac eros maximus, pulvinar iaculis mauris interdum. Etiam eget erat feugiat augue hendrerit maximus eu ut felis.

14 Likes

Works like a charm , tested on both PR4100 and PR2100
Since I am a complete noob on all this, and for the other noobs:

Download some app called putty, for pc server ssh connection
enable ssh in WD
when you open putty, user name is: sshd (and not root or admin etc)
when you type the password , the cursor does not move, so type the password and click enter on keyboard
then write each phrase [dswv42]explained

PS: Before I did all this, Both PRX100 had rebuild raid switched to ON
so when introducing the HDD’s , the system rebuilt raid by itself

and I had the same error on both NAS when I entered:

mkdir /tmp/kernel
mount /dev/mmcblk0p2 /tmp/kernel
rm -f /tmp/kernel/uImage
rm -rf /usr/local/tmp_wdnas_config/*
/usr/sbin/rebootemphasized text

the error was:
failed to load external entity “/etc/NAS_CFG/ftp.xml”
cat: can’t open ‘/etc/exports’: No such file or directory

but it did not matter, because I rebooted the machines and all is well

you have to download the OS3 version before all this also, to then revert

thank you very much DSWV42

Happy to report I was able to revert back to OS3 thanks to @dswv42 clear instructions. Hard disks have been asleep while I’ve been asleep (as it should be). This thread should be made sticky by WD.

1 Like

Role back worked, I can access all my files etc but am unable to access the dashboard from the ip.

When I type in user name as admin and the password area as blank it does nothing but if you type in the wrong admin name the GUI says its incorrect.

I have tried the 4 second and 40 second reset to no avail.

Any thoughts how to gain access to the dashborad?

Kind Regards

It finally worked had to 4sec reboot a few times then managed to access! It’s all back to how it was with OS3… thank god

1 Like

Yes I think you are right… I did notice before I manage to get back in the dashboard it never came up with the raid roaming it just all worked and some of the settings once I was got back in were still as they were before!

Thank you though for this… I’m sure a lot of ppl will be using this :ok_hand:t2::+1:t2:

Hi everyone! I´m new to this forum and I hope you can help me: I´d like to know if there´s any chance that this method works with My Cloud Mirror Gen 2? I was close to try it but to be honest I´m too scared that I might damage anything.
Thanks for your help in advance :slight_smile:

Thank you for your answer :+1:

Thanks so very much for this! I just moved back to OS3. All the best during this season for you! Much thanks.

I’m constantly reminded of just how selfless many are with their time and skill.

3 Likes

Mods, can we mark this thread as sticky please? I’m sure lots of OS5 victims are looking for a way to upgrade their devices. Even from WD’s perspective it makes sense for folks to see this thread and know the option exists rather than go and add bash you up on 5 different threads for the disaster that’s OS5

1 Like

My Ex2 Ultra never came to life after trying to rollback to OS3.

Maybe there are options to fix it yourself? I connect to the local ip, safemode, I throw the firmware - I think the download wheel is spinning - the result is zero (((
21637597
I found information in this thread that if the firmware version is not indicated in safemode here, then it will not work to load the firmware via the interface. How to be?
21637207

nandwrite /dev/mtd3 /mnt/HD/HD_a2/Downloads/image.cfs

image.cfs was from MyCloud Gen2

Sorry, where do you need to mark the post?

can it be repaired?

I can’t connect via SSH now - it gives an error.
Tell me where to get a copy of the rescue firmware?
How do I install it on a My Cloud?

Being your safe mode screen does come up, the wheel appears to spin without completing, I would assume the firmware being uploaded might be corrupt. I upgraded one of my EX2 Ultra’s to OS 5’s latest release and downgraded it just now to OS 3. I did get the spinning pinwheel for about 10 seconds prior to it starting the 1-100% and appearing to reboot. Once it appeared to be back up, I reloaded the webpage to see safemode again. Entered the same firmware and started the process a second time. I only got the pinwheel with no progress to 100% this time. As such, I unplugged the device for a couple seconds, and reapplied power. This booted into OS3. Once booted, I couldn’t loving, so I performed a 40 second reset on the device. The device rebooted, come up to a basic login. As such, I performed a factory reset, and then reinserted the original drives.

A definition of insanity: Trying the same thing over and over again; expecting different results.

Of course. . . . in the world of computers the answer is often “If it doesn’t work the first time. . . try it 5-10 more times”. Amazing how often that works.


What error is SSH giving you?

Note that different firmware versions have different SSH login details.
SSHD, SSH, and Root have been used for user names.
“blank” and Welc0me (or is it welc0me?) have also been used as passwords.

Login user for OS/3 and OS/5 is currently SSHD; but I know older devices/firmwares used root as SSH login user.


Random ideas:

Maybe you should get one or three OTHER OS3 firmware revisions. . and see if one works?

I am thinking that the rescue firmware for the Gen2 might not work on an EX2?

What if instead of trying to load OS3 EX2 firmware; one tries to load EX2 rescue firmware? (I know . . . a truly crazy idea from someone who knows absolutely nothing - - -use at your own risk.) I would imagine that if it works. . the unit will boot to rescue firmware and prompt to load new firmware. . . … .

Am I doing this right? I don’t really know what I am doing.

I just copied and paste

# Delete Linux kernel

mkdir /tmp/wdnas_kernel
mount /dev/mmcblk0p2 /tmp/wdnas_kernel
rm -f /tmp/wdnas_kernel/uImage

OK, now when entering: mkdir /tmp/wdnas_kernel, i’m getting this:

mkdir: cannot create directory ‘/tmp/wdnas_kernal’: File exists

Thank you, that worked. Another weird problem though. I can connect to my files through WD MyCloudPR4100 on my smart tv, but when using the My Cloud OS 3 android app or https://files.mycloud.com/ all I have is a WD Sync folder that is empty.

EDIT: Got it working, a security setting had reset.