No web-access

i have tried a full restore, not the 40-sec reset

Now i have done a 40-sec reset. No change. Except now i can’t get the device to save my email adress in the “User Profile”: I type in my email but when it tries to save it i get an error:

This email account cannot be deleted. Make sure your device is
registered and your network connection is functioning properly, and then
try again. (250010)

I also tried to change the router DNS, as was suggested in a different thread (here) but no change.

Hi! Check the solution I posted in the following thread. Hope it helps also for you.

No web-access via

Thanks for the answer dan_sp :slight_smile: . As i explained in the post above yours i’ve already tried to change the DNS in my router to goole, but i must have done something wrong because now it appears to be working, i have remote access using the app on my phone. However, going to and clicking the sign-in button still only opens a blank page. This means that when i’m at work or anywhere else i can’t access MyCloud from a PC there (i tried from my local library, and only get a blank page).

It works!! Somehow the problem with the blank page has resolved itself and i now get the login-page.
I’ll try to reset my router to the default DNS to see if the problem returns, but now at least i know the workaround.

Thanks @dan_sp

I asume the issue comes because probably when some days ago was under mainteinance and WD maybe changed any ip address. Then as some ISP has cache dns, can take some days to update to the new ip address. That is why changing to google dns is working again. Is what it makes sense to me.

I just changed the DNS settings in my router back to default (provided by ISP) and i am still able to log in through Success!
Checked in Dashboard > Cloud Access and the connection status says “Connected”. Great success!

Apparently i did all this work for nothing as the problem was not on my end…

Anyway, I’d like to thank all you guys who responded on my thread for your efforts :slight_smile:

  • Damon

Well, I was a little bit too fast there.

Over night the problem with no web access has returned. Along with a few other problems: I created a second user, but this user could not get access to the drive - something i also did about a month ago without any problems. When trying to delete this user i got error-message that it couldn’t delete the user.

So this morning i did the following:

  1. A 40 sec reset of the MyCloud drive. Create new user again. No access. No web-access for admin either.
  2. Changed DNS in my router to Google ( and and waited for a while, nothing changed
  3. Did a 40-sec reset of the drive, again, and now things apparently work.

What’s interesting is that changing the DNS in the router back to default will allow web-access for some time but after a while (several hours) web access is blocked. Weird

So much hassle for something i didn’t do. It worked fine for a couple of years. Why not keep it that way WD?

I have the same problem here in Germany, blank page when I click on the login button:

the browser also tells me “Connection is not secure”

It works for me now. But i don’t know if it’s working because of the stuff i changed (DNS and 40 sec reset and clearing the cookies/cache in my browser) or it just solved itself while i was doing the changes. However, it’s fairly easy to try.

I’m having the same issues here. When I go to the sign in page for it’s all white. I have an EX4100 and PR4100 and neither are accessible through the cloud.

I’m in the U.S.

Hi, I’m in Denmark and also having problems connecting to my NAS remotely. I get a blank page when trying to connect through and error message on the app.

Hi all, same problem here in Hong Kong.

I tried to access via and click sign in, blank page(all page white color only).
I also tried to access via iPhone app, it always say offline.

my drive is working fine, my home internet also works fine, I have remoted back home and checked, everything works.

Seems this issue should be on WD side.

Same problem in The Netherlands

Same issue in Ireland. Was working last night when I first set it up -
not working today either in MyCloud android app or in 2 browsers on
Linux desktop

Web login page comes up as a blank page here in the USA as well. Worked OK last night. I hope WD support monitors these forums…

Sam issue here in Canada. Web access through Chrome browser worked fine last night when I set it up. Today (Aug.3) when I click “Sign In” at, I get a blank page. I made no changes during the intervening time.

Same in the UK, certainly WD’s problem this time!!

Wish they had a status page we could check like many other sites do. :frowning:


The same in Spain! …:disappointed:

…and the connection is lost again. WD are aware that there is a problem and are trying to solve it: