Failed to create device user. (400073)

Hello. Reporting an issue that has just been encountered as this is the first time in a long time I have attempted this. Two days of searching through the forums has not provided a step-by-step resolution directly addressing this issue (as far as I can tell).

Performed user creation and the result was…

Failed to create device user. (400073)
Note: User successfully added.

Went to Cloud Access page. Ensured connection status was ‘Connected’. Clicked ‘Sign Up’ for MyCoud account, filled in needed info, clicked ‘Save’. The result was…

“Failed to create device user. (400073)”

For Cloud devices on same page, clicked ‘Get Code’. The result was…

“Failed to create device user. (400073)”

Clicked on Support link from the ? dropdown menu, clicked ‘Support’. In the ‘Request Automated Customer Support’ section at the top of the dialogue box, checked the ‘Attach my device’s diagnostic report and request support’ and clicked ‘Request Support’. The result was a long wait time resulting in…

“500 - Internal server error.
There is a problem with the resource you are looking for, and it cannot be displayed.” - Encountered at http://websupport.wdc.com/rn/nassupport.asp

I have two users to add access for.

Thank you.

1 Like

@Shadowstreik - Thank you for reporting this issue. We are investigating.

You’re very welcome. I’m glad to assist. :slight_smile:

Hi @Shadowstreik - So we looked into this and were unable to reproduce the error… I did have the websupport link (http://websupport.wdc.com/rn/nassupport.asp) updated to always push you to the “Create a case” page even if it fails.

I’d like to actually have you reach out to support on this issue and see if they can’t help resolve it. I suspect it’s a network issue, but they could tell you for sure. Contact details are in the links below:

Phone:

Email:

Thank you for the assistance.

I put in a ticket and provided a system report. It’s been determined the unit is behaving improperly. Its remote access functionality has gone faulty and the unit requires replacement.

I got the same message. And the same error message appeared when i tried to generate a code for cloud access.
Recently, my device lost the “remote access connection” (i.e. i cant access it over the web, not fixed yet) and i assumed that these problems were somehow linked.
Maybe you could check if you have remote access connection? (Dashboard>Cloud Access>Cloud Access Status)

I had checked the status and it was in good shape (“Ready”). Yet, it was failing to create the code and even a WD account for web access. I don’t get that error, specifically, now, but a consistent timeout error. That appears to have lead to an overall external connection functionality to be no longer working.

My similar problem was “solved” by changing the DNS in my router to “Google” (8.8.8.8 and 8.8.4.4) and then performing a 40-sec reset of the MyCloud drive (see here).

Hope it helps
-D

Mine was partially solved. And then, it wasn’t. The DNS in the router made a point for me. My DNS is routed through openDNS on my router.

208.67.222.222
208.67.220.220
208.67.222.220

I logged into openDNS and set wd2go.com and mycloud.com to always be permitted. I then did a 40 second reset. Following that, I created a test user and it worked. I checked the unit connection status and it was connected. And then it went to ‘Failed’ status. Creating a second test user creates the user but failed to create a connection user (since the connection status was ‘failed’).

I kicked off a reboot. It made no difference.

I checked the stats on my openDNS dashboard and saw there were a very large amount of requests for discovery.wd2go.com. So, I added that domain to the Always Allow list. Then, througha VPN, I attempted to directly navigate to that domain, mainly just to see if it led to anywhere interesting. Heck, it could be where the unit connects to so it can be discovered, perhaps. I met a blank page, so I disconnected from the VPN and waited out the DNS permission change time (3 minutes). Try again without a VPN connection and Chrome reports the sits can’t be reached which leads me to beliefe that discovery.wd2go.com is what the unit goes out to for discovery purposes.

I checked the status and it is in ‘failed’ status. It, actually hasn’t left that.

I recall I have an actual personal openDNS account and my household IP is set up. I believe that I don’t actually need the DNS settings in the router because of that. To test that idea, I removed the DNS addresses from the router. Logged out of the unit’s UI, cleraed the browser cache for that, restarted the browser, logged back into the UI and check the connection status. It shows ‘failed’. That is a pretty consistent failure.

I cycled cloud access, itself, and it’s in ‘failed’ status.

I deleted my IP from openDNS, logged out of the UI, cleared the cache, logged back in after 3 minutes. Connection status is ‘failed’.

I know from that, at least, the issue isn’t with openDNS. I put my ip back on the account as I need the protections openDNS provides. I left the DNS side in the router alone.

Hello, basically, I have similar troubles.

After entering email address for a new user I got the error message: “Failed to create device user. (400073)”.
Dashboard>Cloud Access>Cloud Access Status = “Failed” (Unable to set up remote access), but I am connected to Internet.
It looks like security restriction or bad setup at the router.

Any ideas to check?
Thank you.

i had so much problems with this thing today that i’ve ended in “quick restore”
thanks got i’ve bakced up all my date from this thing :frowning:

why no budy is sending any email to let us know about any issues you guys have?

if i knew that there is a problem i wouldn’t do any thing, but i thouth ther is a problem with my cloud :frowning: finieshed quck restore and now i need to copy all the date back to the Cloud

After much thought, I decided that remote access to the MyCloud was, essentially, unnecessary. I have shut off remote access on the device.

I only have extended family, a couple friends and even less acquaintances that I would want to share any data with (that being family pics, videos, maybe a recipe or two, here and there.)

I have a spare Raspberry Pi and came across a tutorial on setting up my own cloud using the RPi and a spar external hard drive. That is set up, running and was a fun RPi project to do. The best part is there is no middleman for connections (ie- WD); every connection to the unit is direct and https.

The MyCloud operates perfectly fine for internal uses. After a factory reset, I have rebuilt data and will continue my household’s internal uses, as it was primarily intended.

Many thanks go our to everyone.

  • Shadowstreik

That sounds interesting. Could you share the link, please?

Hi! Sure, absolutely.

Raspberry Pi Cloud at pimylifeup.com.

  • I do not recommend nor endorse the link target, above. But, it’s a goody, non-the-less.
1 Like