No Audio files with new DNLA server

I have just installed the new update and switched to the WD server.

My problem is that all my DNLA clients (WD Live Media Streamer / Sony Blueray player / WIndows 8) tell me that I have no audio files!

My videos and photos are there  but despite there being around 180Gb of mp3 files they are not shown .

I thought I was being stupid, so created a new share and put a handful of Video, Audio and Pictures in it.
The Videos and photos are shown, but none of the audio files are there.

I have tried to refesh and then rebuild the media database, but it’s made no difference.

The files are all still there and can be played using shared folders etc.

Anyone able to enlighten me on how ot fix this? Otherwise it’s back to Twonky I guess.

Glad you posted this, I just created a post about asking what the differences were and wondering who switched over. This would obviously stop me from switching.

I was hoping that some video files (higher quality rips) that the Twonky (original version installed) will not show on my DNLA devices would now show if I switched to the WD DNLA.

Well I have now switched back to Twonky, and everything is back as it should be.

It does make me wonder if I can easily update the Townky server to a more recent version easliy now.

Anyway, may have another play this evening switching between the two in see if it does the same thing.

At least I know I can switch between the two fairly easily.

Read some other people stated after updating to Turn off The Media Server (wait until its complete), then turn back on and everything seem to work fine after that.

Just tried again.

Switched to the WD server created a new share, put a handful of MP3’s in there and rebuilt the database.

Rebooted the drive, and again no MP3’s showing under the WD’s media menu.
Again, all my videos and pictures are there, but no audio files, either in the original audio folder

I even tried copying some audio files to the default \MYBOOKLIVE\Public\Shared Music folder, but again they don’t show after rescanning or rebuilding the database.

So, back to Twonky for this time around.

I just saw this thread after replying to

Exactly the same problem, no matter what I do the WD Server does not stream mp3 files.

OK now I think I have succeeded in getting it to stream music and video. In the dashboard under Shares I turned media serving off for all shares individually. Then in Settings/Media I turned off the DNLA server. The basically turned them all on again and the files started to appear, music as well as video files.


Thank You! :smileyvery-happy:

That seems to have sorted it.

Will check when it’s finished rebuilding the database, but on the dashboard menu it’s definately showing loads of MP3’s

Will let you know later if it actually serves them to a player.


We cannot replicate this issue internally. We tested these exact scenarios, so it puzzling as to why people are seeing this issue. Those that have this isse. How much media did you have on your box? Did you wait long enough for the media player to index the media? Did you do any customizations to Twonky media server before you upgraded? Did you have any settings other than default for the media serving?



I have 2640 mkv, mp4, avi video files and 6500 mp3 and flac files. After updating from 02.11.09 – 053 to 02.41.05 – 034 I made sure everything was working OK. Twonky and shares functioning properly. I then applied the WD Server Patch. All videos turned up under “Media” in settings but no music files. Reboot, rescan rebuild nothing worked. The way I got it to work was as I stated above, I turned off media serving in all the shared folders under “Shares” and then turned them on again.

When I first set up my MBL I did customise the shares. I created a share for Video and for Music and with Twonky you could stipulate what media you wanted to share in each share, pictures, videos or audio. So I shared video in the video share, audio in the music share. (Basically to stop Twonky picking up the odd pictures I had in my music and video folders which annoyed me.) However I noticed the behaviour for the WD Server worked differently, for each share you either share all media, pictures, video and audio, or none. Maybe this causes the problem?

Both of these shares I left as public and the default public share I left in place but empty