Switch to the WD Media Server. Switch works but no files listed

So i updated the firmware to the new version and applied the patch to switch to the New WD media server. Upon reboot the new server showed but did not display any files. Told it to rescan still no files. Switched back to the Twonky server and files showed up. Did i miss a step? 

Hi,

I have just applied the firmware update, but i cant see how to turn on the WD Media Server?  Was going to try it on mine to see what happens…

Might help with all the problems i have been having with my PS3 which cant play hardly any files through Twonky.

You can go to the Dashboard of the device Settings -> Media Server ). The server should be defaulted to ON, so you should not have to do anything. It does take a bit of time to process your media, but you should start to see files show up after a period of time.

After half an hour still not showing up. Also tried rebuild database.

The UI (under Media server) should give you an indication as to how many files it has processed. Rbuilding the database starts over from scratch - do only do that when you absolutely need to.

Sorry can’t help OP, a bit oot, but

Is there anyway to set this DLNA server to scan

only certain folder? Not all folders.   Where is the configuration file for this WD server located?

Also, after firmware update, the Twonky database gets “updated” (recataloge(?)) or “changed”.

Might affect a switch over if the cataloge was still being “changed”.

Now, does anyone know of any doc that dipicts how the WD DLNA shows the DLNA data vs the Twonky displays?  My poor memory thinks that there was a slight difference…

Still no files showing. Waited 6 hours

Hi madhatter,

I’ve just installed the firmware and the dlna patch - Intitially it came up with no files and the version as 0.0.0 - After clicking ‘rebuild’ and waiting a few moments, it updated, including all my files.

I can only assume the patching on yours became corrupt and maybe you should try patching to Twonky, then back to DLNA, then rebuild - See if this corrects your problem?

Cheers

You definitely have a problem. I updated to WD dlna then right away it shows how many files music/pictures and videos. In seconds if not minutes. Definitely not hours. But my drive is relatively empty, so might be fast because of that. Now if anyone knows how to configure this WD DLNA server so that it only scan and index a certain folder only. ??? How to configure this DLNA server?

Hi,

I have updated the firmware on my device, but i have seen mentioned ‘patch’ for dlna - is this patch something seperate? 

If it is, how do i go about applying it?  I am hoping that this could recity the issue i have had with media streaming to my PS3.  Fingers crossed.

Thanks in advance :slight_smile:

I had the same problem. For me it is now solved. On the MyBookLive page I clicked on Shares. Then on Public and then I put media sharing OFF. This will take some time and after that I put  Media Sharing for Public ON again.

When I then went back to Settings -> Media -> Staus it was updating my media files!

I hope this works for you as well.

1 Like

The patch to switch over to the WD DNLA server is here;

http://wdc.custhelp.com/app/answers/detail/a_id/5735

After updating a My Book Live to firmware version 02.41.05-034 or later, the unit continues to run with TwonkyMedia server 5. If TwonkyMedia is the desired media server to be used, then nothing else needs to be done. In the case that WD’s DLNA Media Server is the one desired instead, then the patch will need to be downloaded and installed. Same process is to be followed downloading the TwonkyMedia Server’s patch and installing it should it be necessary to go back to it.

The firmware patches can be downloaded here:

dutchwduser you are a star.

Problem solved