New WD30EFRX Red Drive Idle3 Timer Set to 8 Seconds (High LCC in NAS)

I had the same high LCC count with my 4TB WD RED drives bought in november (WD40EFRX Firmware 80.00A80). Load Cycle count was growing > 600 per day so that the 600.000 will be reaced between 2 and 3 years.

Because I read that WDIDLE3.EXE has the drive to be connected with IDE and not ATAPI in BIOS, I choosed to give idle3-tools for Linux a try (another reason was that I already had a linux machine with a free SATA port).

The idle3 timer was set to 8 seconds and I could disable it without problems. No more LCC increase since then!

Here’s the link to the idle3-tools (has to be compiled from source, but it was as simple as typing “make” on my Debian-Linux installation):

http://idle3-tools.sourceforge.net/

Hope it helps!

Anyone tried the official WD tool yet? Any success?

Is it a real firmware update or just a idle3-tool type of tool (and if just a tool, what does it set the idle3 to?)

Still wondering which way to go: The official WD not-very-well-documented update or the 3rd party tool recommended by fellow users.

This is from the WD Support site for the update driver

  1. Download the WD5741utility update.

  2. Extract the file and place in a known location Windows:     

  3. Open a command line window.

  4. From the command line, navigate to the directory       containing the utilities.

  5. Execute wd5741 -? <-- this will type out some terse       usage instructions.

  6. Execute wd5741 -d? <-- this will type out a list of       drives.

  7. Execute wd5741 -d# <-- this will update drive with same # in previous list.

  8. Execute wd5741 -dall <-- this will attempt to       update all listed drives.

I removed a WD Red WD30EFRX-68EUZN0 from my Ready NAS 104 and put it my PC, attached to a SATA cable. The  POST and disk manager console both recognized the disk

I opened a command prompt with “Run as administrator”, ran wd5741 -? and wd5741 –d?

The -? parameter returned the proper commands, while  –d? returned  “No drives found. Try running with administrative rights.”

I also ran this from “Safe Mode with Command prompt” with the same results.  (screen capture url attached) https://www.dropbox.com/s/3mjaph14i6476ue/WD5741%20attempt.PNG

Without anything more to go on, I’m not willing to tell it to actually _do_ anything to “all applicable drives”.

A previous poster said something about WDIDLE3 needing an IDE connection?  I just checked the WD page for WDIDLE3 < http://support.wdc.com/product/download.asp?groupid=609&sid=113 > and it says it is for SATA connections, but since it was released almost 4 years ago, it makes me a bit nervous to use on a new drive. I know there is the “Idle3ctl” tool, but I don’t know anything about Linux and would rather not go there just to get “NAS ready” drives to really be “NAS ready”. **bleep**…

Over to the group….  (and hopefully a WD tech… please)

Got it. A brief step-by-step guide to what I did since I’m a bit in a hurry.

I downloaded newest Knoppix Linux and made a bootable USB stick with unebootin. After that, I copied idle3-tools and WD update for Linux (32bit) on the stick. The stick was mounted automatically as /mnt-system/ when Knoppix booted.

Opened a Terminal and compiled the idle3-tools, as instructed.

Well, Neither - the WD tool or idle3-tool first worked and it took me nearly an hour to figure out it was all about adminstrative rights, since neither of the tools weren’t too verbose. WD tool didn’t print any info and idle3-tools just printed “BAD ADDRESS”. So, I run them as root and they worked. I was also scared about idle3-tools being little dated as last update seemed to be on 2011…

Checked all the disks with idle3-tool, the timer was set to 80. (8 sec?)

I run the WD update first on one disk.

Checked it with idle3-tool -g /dev/sda. The result was 138. What’s this in human readable format?

The WD tool didn’t touch the firmware, so it’s probably just a “crippled” version of idle3-tool.

BTW. My disks are set AHCI (not IDE) in BIOS and in they’re formatted ZFS, which seems not to be supported by Knoppix - didn’t matter at all.

Hope this helps.

Thanks Much sxinn!

I guess while you were writing your kind reply I was taking the plunge with WDIDLE3 which is now included on the “Ultimate Boot CD”  http://www.ultimatebootcd.com/> under the  “/HDD/Device Info and Managementsection. I first saw it mentioned at http://www.jzab.de/content/wdidle-bootcd but it is now included in the current version of UBDC (which is a pretty cool collection of free tools)

I had read somewhere that some folks were having problems (later on down the road) with the new drives if they completely disabled the Head Parking routine and they recommended just extending the timer to the maximum for this utility, which is 300 sec (5 min).  I would like to set it for longer, but this will do for now. 

The utility worked flawlessly under the UBCD and reflected the change. I have just put them back in the NAS, so I’ll let you know how they perform.

One good tip was to disconnect all other drives in the PC during this process. I just pulled the SATA cables out of their motherboard jacks (3), leaving just the RED drive and the CD ROM. Sure felt safer KNOWING that nothing could get to my SS boot drive and data drives.

So now I’ll finally get to start playing with my NAS box. I look forward to when Netgear puts the 4TB REDs on the approved HDD list. They wont give you any tech support if you are not using  “approved” drives.

Thanks for all the help!

For what it’s worth…

I’ve installed 6 WD RED 4TB drives in my NAS 70 days ago.

The load count on all drive was already in excess of 68000.

Running the wd5741 utility, told me that none of my drives required the firmware update as it already had the latest firmware and there was nothing to do…

Upon running the WDIDLE3 utility, I say however that the timing feature was enabled, and set to 8 seconds !

So I’ve disabled completely all together for the time being…

So maybe the wd5741 utility does something for some, but certainly not for everyone

I have 6 2T reds in Freenas 9.2 using raidz2.

Device Model: WDC WD20EFRX-68EUZN0
Serial Number: WD-WCC4M086xxxx
193 Load_Cycle_Count 0x0032 179 179 000 Old_age Always – 64523

Device Model: WDC WD20EFRX-68AX9N0
Serial Number: WD-WCC30074xxxx
193 Load_Cycle_Count 0x0032 200 200 000 Old_age Always – 32

Device Model: WDC WD20EFRX-68AX9N0
Serial Number: WD-WCC30074xxxx
193 Load_Cycle_Count 0x0032 200 200 000 Old_age Always – 20

Device Model: WDC WD20EFRX-68AX9N0
Serial Number: WD-WCC30073xxxx
193 Load_Cycle_Count 0x0032 200 200 000 Old_age Always – 19

Device Model: WDC WD20EFRX-68AX9N0
Serial Number: WD-WCC30073xxxx
193 Load_Cycle_Count 0x0032 200 200 000 Old_age Always – 37

Device Model: WDC WD20EFRX-68EUZN0
Serial Number: WD-WCC4M078xxxx
193 Load_Cycle_Count 0x0032 180 180 000 Old_age Always – 62914

As you can see I’m only having an issue on the WCC4 models in the array, so do I run this update on all the drives or just the ones with the large LCC?

And what the hells going on here these drives are supossed to be NAS friendly, thats the reason I brought them in the first place.

I would run the utility on just the two drives you are having problems with and if you run WDIDLE3.exe, disable the timer.  If you run the ofther utility, monitor the LCC to ensure it stop climbing rapidly.

Does anyone know what the -68EUZN0 in the part number decodes to?

There seems to be a trend that only drives with this specific dash number are having this problem.  I have seen it now on both the 2TB and 3TB versions.

I was about to buy a RED drive but this just scares me off.

There are no reliability issues with the Reds, just a minor issue with the head parking timer.  I hear the newer drives are starting to come with a 300 second timer value.

Well wdidle3 fixed my 2 drives, just disabled the timer all together, so the LLC has settled right down thank christ.

So if one of these drives now fail and the LCC is through the roof I wonder if WD will replace them under warranty?

Since the WD data sheet for these drives lists the LCC spec. at 600,000 you should be fine now that you have changed the Idle3 timer.  I would not expect any warrenty issues since you appear to be down around 60-70K counts.

On the other hand the warranty is also 3 years. I have a machine here used as NAS, 6 red drives; 140k cycles after only 70 days.

If I did nothing on them, they would reach the 600k limit in less than a year… What do you do then?

My drives were going down that same path (1900 LCC in the 1st 24 hours).  That is why I used the WIDDLE3 tool to change the Idle3 timer from 8 seconds to 300 for my 2 drives.  In the last 2 months I have only seen the LCC go up maybe 10-20 counts (mainly due to power cycles and other things I was doing).  Seems very stable now.

I decided that after WD said the risk of using WIDDLE3 was low it was worth doing to keep from hitting the specified limit in the 1st year (at least for me the risk was worth it).

Good luck.

jyavenard wrote:
On the other hand the warranty is also 3 years. I have a machine here used as NAS, 6 red drives; 140k cycles after only 70 days.

If I did nothing on them, they would reach the 600k limit in less than a year… What do you do then?

You wait until your drives fail and turn them in under the warranty. You will not be able to turn them in just because they hit 600K count.  As you know the recommendation is to either set your limit to 300 seconds or disable but it’s up to you.

The point is wether the warranty would still apply, if you went over the designed cycle count. Knowing that you reached that point extremely quickly thanks to WD design choice.

I don’t believe for a second that WD would refuse to warranty the device, but you never know

They would not deny a claim for this type of issue and I’m certain they are aware of it. 

Hi have same model with 68EUZN0 but the idle3 was set to disable by default. Bought my red last November 2013.

Hello,

I have read this thread with great interest. I have a Synology NAS unit with five WD Red disks.  I have the serial numbers and capacities, which are three 3 TB and two 4 TB. I also have two WD red disks of 1TB each coming tomorrow for a second NAS unit that is built by me from very ancient PC remains, running now with one Toshiba disk that will be alone and not in the WD raid that I plan to set up there, that will be using Nas4Free software.

My questions are, and I apologize for my lack of knowledge of how to determine these items:

  1. How are you all determining the idle3 setting and where would I see this? Synology software is very comprehensive and I will examine the disk options to see if these are listed.

  2. Where are you all seeing your present Load cycles?

  3. Does this load cycle indicate the number of times that the disk is accessed by the sytem, in 24 hours?

I realize that these disks are Smart enabled and have what are supposed to be excellent NAS characteristics, but I am now concerned about this thread and the action of these disks.

Any knowledget that you can send my way is appreciated,

Debra

EDIT: I did find the information on SMART information for the WD Red disks in the Synology unit, under Menu, Storage, Disks, Smart, Information.  I do not see the Idle setting however, but I see many of the items shown in the screenshot in this thread. If someone could help me to understand these items, I would be grateful. I do see the smart information also for the Toshiba HDD in the Nas4free unit, but again, no idle time. I do need help understanding all these items in the list.

EDIT 2: I did figure out what I need. I studied these posts for over two hours last night and today. I got the report from my Synology under Storage Management-HDD Management-SMART Info, and saw the attributes and values. One of the posts here said to check the values of “Load_Cycle_Count” and “Power-Off_Retract_Count” and “Start_Stop_Count” which should all be close or equal. Three of my disks(the 3 TB) were fine in this regard. The other two, the 4 TB, were not. Disk 4  and 5 had a LCC of 10865, whilst SSC was 503. not good. So I knew that the idle timer was set bad probably to 8 sec. So I had to create a bootable floppy(It has been about 20 yrs since I dealt with dos and this took about an hour fo rme to get this done, I’m afraid to say). Then I was able to shut down the Synology and remove one disk at a time, and insert it into my pc and remove connections to my real HDDs there, and start to dos, and then run this WDIDLE3 tool. It is also documented on the Synology website at: http://www.synology.com/en-us/support/faq/407

So I have applied correctly and successfully this tool and will be checking my values in smart info. for LLC to see how they are coming along. I am hoping that the two WD Reds that I am expecting tomorrow (1 TB) will not have this issue, and I do not know how to determine it, only that I guess I’ll have to use this tool to apply the timer before I insert them into my new Nas4Free unit that I built from old pc parts.

Thank you to the persons who have replied in this thread, it was very helpful to me, but I still need more insight into all these disk terms and terms of use and implementation, etc.

Thank you,
Debra