New User - Unable to access Dashboard & Home_Nas_Storage_2016

First post in here, apologies if this has been covered, I have searched for a while.

Brand new 3 TB Device, up and running initially with WD Sync, running happily away in the background. I can access all areas of the device via the web interface, using my email login and password created at setup. This is on a Win 7 PC, using Chrome as the browser.

My issues:

1: When I try and manually browse to my Home_Nas_Stariage_2016 Folder, I am prompted for this.

This is is a home PC with no network restrictions that I am aware of.

2: I cannot access the Dashbord, when I browse to the Url, I get a login and password box, the credentials created at initial setup do not work, I have tried all sorts of admin/admin/Admin variations with no success. I have read the Manual, but am stilll struggling big time, it is just a bit frustrating. ETA - I HAVE NOW CURED THIS ISSUE!

Any advise is much appreciated.

If you have forgotten the initial password you created when setting up the My Cloud you can “reset” the My Cloud which will clear the administrator password. Start by performing a 4 second reset described in the WD Support document below:

Next, if you haven’t already done so, it may be wise to read through the WD My Cloud User Manual ( to learn how to setup, configure and use the various features/options of the My Cloud device.

Thanks for the response.

I have already read the manual, although this is for firmware version 4, I seem to be on 2. At no point does it mention anything regarding browsing via file explorer to the Home_Nas_storage_2016 share. Should I be looking at some Win 7 settings perhaps?

Any help is very much appreciated.

The v2.x My Cloud User Manual can be found at the earlier link. Here is a direct link to the v2.x (English version) My Cloud User Manual:

See Chapter 3, Getting to the Public Share were the User Manual explains how to access a Share using Windows File Explorer. You would use that same method to access any Share that one has permission (set via the WD My Cloud Dashboard) to access.

If you have a home network set up then you have a network name and password. See example image below for mine.


The OP’s screen capture in their first post apparently shows they are trying to access Share on their My Cloud, not a router, and are being prompted for a password to access that Share. Further they lost their password used to access the Dashboard.

Please post how you resolved that issue in case it would benefit others.

I did not use the password created on setup, just that these credentials do not allow me to access the Private Share.

ETA, when I finally accessed the Dashboard, I changed the Share Profile to Public, and could then access it through File Explorer.

After much fiddling, I was able to access the Dashboard by using the device name, and no password.

The Dashboard access uses the username and password you chose when you created thge first account, which renames the administrator account. If you do a 40 second reset, this reverts the administrator account to username ‘admin’ and an empty password.

If you access the Public share from windows, windows will connect using your windows user credentials, unless you tell it otherwise. If you then try to connect to a private share, and try to enter your MyCloud user credentials, windows will not let you, because it does not allow connections to network devices using mixed credentials.

The answer is to disconnect all drives mapped to the MyCloud , and then re-map them all using the MyCloud credentials; in your first image, use the ‘Use another account’ box.

@Bennor Please look at the screen capture again and read the first five words, “Windows Security Enter Network Password”.

I know it works, it has worked for me when that is asked for.

As I have told you before I was not responding to you but to the OP.


Given that the OP has run the WD setup program, and downloaded WD Sync and can access their Dashboard, it appears their PC already has access to their local and wide area networks via their router. Thus, I don’t think that dialogue is asking for a WiFi password.

And look at the fact that they are trying to access the WD My Cloud as evidenced by the part highlighted in Red following the first five words.

Now maybe if they used \\<network name>\<password> it might(?) work but my suspicion is they have some sort of issue with the user/login name (highlighted in Yellow in the picture above) that might be causing the log in problems. Generally one does not enter in a email address as a User name or to access the Dashboard from the local network. Unless of course one used an email address as a User name when setting up users in the Dashboard.

Edit to add: The highlighted part in Yellow above might also possibly indicate some sort of Windows Credential issue since its automatically filling in the name while the person tries to access the My Cloud, or it might possibly indicate the My Cloud resides in a different workgroup or network segment.

Perhaps you didn’t read where I have had to use my network password to open up my My Cloud. It has been a while since I had to do that plus I am no longer using Windows 7 as both my computers have been updated to Windows 10.

As I said my reply was to the OP and not you. If what I suggested worked for him fine, if not I guess he has to figure out the right password, however, I suggest to him that the next time this box pops up he try his network password if none of the others work.


I wasn’t aware of a forum rule that says we’re not allowed to comment on other replies if we think they’re wrong. Or am I not allowed to comment on your reply to Bennor…?

These threads are open discussions, not private conversations. If you want a private conversation, send a personal message.

Fine, but why not wait and allow the OP to tell me if what I wrote worked or not. I know it works, yet the two of you are telling me like another person did here that I don’t know what I am talking about.

My WD My Cloud is a part of my home network. I do have a network password. My network is secured. So if something says to enter my network password that is what I will enter.

I have had my My Cloud for over two years now and have made post on this very same thing several times. You spend the time searching for my old post on this because I am not. I know it works and what is being asked for!!!

I hope your suggestion works for the OP; certainly no harm in trying.

However, I’ve just tried mapping a drive to my MyCloud, and the dialogue I get is identical to that in the first post. The device name is that of the MyCloud. The user name is that of the PC user.

Thus, I conclude that the dialogue is trying to enter user credentials for the MyCloud account, and the OP needs to select ‘Use another account’, and enter the username and password for the MyCloud, rather than the PC account details that are presented by default.

If I try to connect to another WiFi network, the dialogue is completely different, with different title text (‘Connect to a Network’), different prompt (‘Type the network security key’), and does not show user details.

Security key, password, pass phrase, are all the same. Do a Google search. Below is one Google result.

The network security key is the password or pass phrase that you use to authenticate with your home network. In order to establish a secure connection with your wireless router, you have to provide the key to prove that you are authorized to do so.

I am sure it would state the same thing in one of my many computer books in my computer library. The last book I completed studying recently is, Technology in Action 12th Edition.

Many thanks for all the responses - apologies for the lateness, been at work.

Anyway, moving on, none of them immediately work, What I have discovered is that I re-enable the share to Private the INFO icon tells me that there will be access issues if there are multiple users on the PC, there are, So, I have put this down to a local PC issue, I am ha[[y to leave the share at public, as it behaves exactly how I want it to then.

Thanks again.


(I will investigate further when less busy, and if I get an answer I will post up the details)

Generally the consumer versions of Windows do not allow one to use multiple different User logins to an NAS drive like the My Cloud, instead one is confined to using a single User login to access that NAS. In the case of the My Cloud this means one can use only one User that was created through the My Cloud Dashboard as the login information from certain Windows PC’s.

There may also be additional settings on the Windows PC preventing access. Sometimes one has to clear the Windows Credentials before they can successfully log into a private share on the My Cloud.