New Release - WD TV Live Plus Firmware Version 1.06.42 (1/17/13)

WD is happy to announce our latest firmware update for the WD TV Live Plus Media Player.

  • Very Important: Rolling back to version 1.05.04 or earlier may break your WDTV.

You may post your experiences in this thread.

1 Like

what are the changes in this firmware?

I’ve lost my network shares (NAS Device). I can still see it through Media but not all my files show up.

After update it cant show 16:9,  just 4:3. And it will not take 12bit color depth…

The 4:3 thing freak me out!!! Movie night to night!!!

:angry:

The changes are shown in the release notes - click on the WD TV Live Plus Media Player link in the first post.

If you want 12 bit (which really does nothing) then go through the HDMI setup in the Audio /Video menu and set Match video framerate to off. You should then be able to select 12bit.

What do you mean about not showing 16/9?

Upgraded firmware, no network shares.  Cursed and kick things a bit but then went into network setup, config, Automatic/Maunal and clicked manual.  Didn’t change anything, just hit OK and it started working.

Hope that helps!

1 Like

Aún no se pueden ver las fotos en Facebook :frowning:

Sería bueno poder ver en flickr las cuentas de uno, entrando con usuario y contraseña. De esta forma se pueden ver las fotos que no son públicas :wink:

En lo demas no note aún problemas…

After the update, I can no longer play _any_ video file via a network share.  play via media station works fine still.

Sigh - I’m going to have to try this roll-back thing.

No problems here after upgrading 2  units. WD Remote works via Smartphone. YouTube Leanback via Smartphone is a delight. 

I immediately went into network settings and switch to manual and auto before trying network shares. 

Sharing from two different NAS devices works just fine when playing MKV files (480p or 1080p).

Sad to see that we’re nowhere closer to an Amazon VoD app, but I think at this stage of the product lifecycle, this is all we’re going to get.

Installed firmware.  Random audio playback is not random.  I’ve waited for what seems an absolute age for this fix and, while it’s claimed to be resolved, it isn’t. 

Took this update about two hours ago and it has completely broken our wireless connectivity.   We’ve tried rebooting everything several times as well as using the hard reset button to no avail.  It is able to find the network but when we attempt to connect after entering our wep key, it fails to connect.  We attempted to connect manually by entering the ip address, subnet, gateway and dns following instructions found elsewhere on these forums and that does not work either and it won’t store any of those numbers.  We are extremely frustrated and out of solutions.  Any help is appreciated.

**Edited to add that after several more hours of troubleshooting, finally decided to throw in the towel and roll back.  I wish I could roll back the hours I lost as well :frowning:  

After upgrading I no long have my network shares…after restarting my network I find my computer…but after it connects it doesn’t show any of my shared folders lt just shows “There is no media in the current folder”

What I mean… when shoosing widesceen nothing happend… it stuck in just showing 4/3, in a bad picture quality.

please help…  As soon as I upgrade the firmware, the picture, after the auto restart, showed 4/3 picture

Anybody else with same experience?

Still don’t understand what you mean. Where are you choosing widescreen? Are you saying that the players menu screen is in 4/3 on your wide screen 16/9 TV (black bars on each side)? Have you tried reset to factory defaults. Are you connected via HDMI?

hmm… Yes there is black bars on each side from the projektor, the projektor and the WDTV player are connected via HDMI…  I tried to reset to factory defaults…

In the menu “setting” i choose “Audio/Video”, then “aspect ratio” then Widescreen or Normal…

I saw one film yesterday, then updated, then blackbars… F%##

Suggestion please?

Is there a safe Firmware Version to roll back to??

mbr107 wrote:

Is there a safe Firmware Version to roll back to??

http://wdc.custhelp.com/app/answers/detail/a_id/5800

You can go back to 1.06.16

  • fw update installed successfully

  • no network access after update :confounded:

  • checked with “ms browser” list and see that the wdlive is listed with an dhcp IP, but I config it with an fix one

so I suppose that  in this update process the following happened

   -> wdlive asked and received dhcp address after first boot and broadcast the new address in network 

   -> wdlive network setup turns back to the old fixed IP that I have setup after second boot

and this I done to solve it:

   -> found with <nbtstat -a “name”> who is in actually “ms browser” and restarted “browser” service on this machine

   -> restarted wdlive and got network access again

till now all works fine with this version

One wonders who WD farmed-out their firmware upgrades too?..China?..or India?..brilliant!

@ R_Daneel. I understand what you say, but the the computer or tablet that you are using to write your post was provably made in China, and some of the best software developers are from India. :wink: But no, as far as I’ve heard, Smartware is an in house software.

1 Like