New Release - WD My Cloud Firmware Release 4.01.03-421 (2/23/15)

sure , when i will have my dashboard again.

when i open the browser and point to WDMYCLOUD , i got white page for 15 minutes and then error the connection was reset.

Unable to connect

Firefox can’t establish a connection to the server at

    The site could be temporarily unavailable or too busy. Try again in a few moments.
    If you are unable to load any pages, check your computer’s network connection.
    If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

Try a 40 second reset. Then you should be able to see your dashboard. It would be a good idea to downgrade your firmware to v3, which is much more stable.

Read this:

Then, disable the unnecessary scanning services. Read about it here:

1 Like

If you stay on version 4 … then set your “Cloud Access” to “Off” due to security issues … just a FYI


Hi dubie

everytime I can not access my network drive i do 40 sec reset , then I get them back , but the dashboard 80 % of the time doesnot work and when it work and I see it , then any menu I click it takes time and the end it give me different error each time.

last time i had problem when I upgrade my code , I used one of your link down to disable scanning and empty some backup that WD safe on the drive , and disabled the media server, and it start to give me better result on the dash board , so i enabled the SSH. and FTP.

now after the new code my dashboard giving me problem , to load , and when its load , I can not enable SSH so I can follow your second link.

WD should make SSH and FTP on by default after restarting the drive 40s it will make maintenance much easier.

I just wonder why every update gives such prblems everytime.?

I work for satellite company , and everytime we have new code release we have SVT team that test the code and be sure that it will work on all units , and that incase customer start to have problem , he can go back  to the old code by some commands. always there is 2 codes inside the machine.



Hi sectorGZ

thanks for advise , I will do it the first time my dashboard will work again.


I understand your problem better now and share your frustration over the previous firmware updates. Do you have any device attached to the USB port? If so, disconnect that before performing the 40 sec reset.

If your dashboard won’t let you enable SSH, I can’t suggest a solution. It’s probably time to contact WD directly and ask for a replacement drive. No doubt they will be sympathetic if their firmware upgrades have wrecked your device.

Hi Streamview, I remember your previous posts now. It does seem that your firmware is corrupted.

If you can possibly get into your dashboard and enable SSH, you will be safer to downgrade the firmware using the SSH method described here:

honestly i will try my best because i dontt like to send and drive with private data to WD .( some time i feel that they are downloading my data secretly) i will try to connect the drive to linux system and see what i can do.


hi dubie ,

yes last time i had big problem and the drive and following users instuction , ( deleting back up that wd keep on drive) and cancelling the media server , and reset 40s , and this helped alot and my drive was 90% stable and i see my drives always but after last update , its again bad  more than before, because dashboard doesnt load in good way.

the software update end with successful message , so I dont think its corrupted. and if its corrupted we should ask why? is there any reason for a software to be corrupted?? unless there is bug with it.

at work many time i saw some upgrade works on some version and corrupted on other , then engineer tweak the software and SVT team re try , untill everything is good , then we send it out.

any way i will keep trying untill the dashboard work again and my SSH worked , then maybe i have to delete the back up files again.

I will downgrade the software and remove auto update.

when i bought it , last year and half, it worked 1 year with no problem at all untill the 3rd upgrade.



sorry…could be silly suggestion but your firmware update hasn’t blown away a static IP address configuration  and issuing DHCP?  Therefore, your presumed address will not be valid, especially if you have ringfenced a static IP range on your router.   You should be able to log in to your router and view any dynamic IP allocations.

Cheers R4M

Hi there, 

I can’t seem to backup to myCloud drive using Time Machine - it gets stuck saying ‘preparing backup’ then nothing happens.

I have downloaded this firmware update and followed your instructions for installation. Unfortunately, I am unable to install as I get an error message saying “invalid firmware package”. Is there any other way to install this? 

What do you suggest?



About a 6 months ago I updated to version 4 but unfortunatly this update slow down my WD MyCloud and I had some weird issues. A long time passed since then and I stick to v03.04.01-230. Shall I upgrade to v4 now? The only issue i have with v3 is the  “Time Machine completed a verification of your backups on “WDMyCloud”. To improve reliability, Time Machine must create a new backup for you.” that im getting every few weeks, and I have to resolve this issue by following some instuctions. Will v4 solve this issue for me?

We just release a new firmware update.  This topic is now closed.