WD, you owe it to your customers–especially repeat customers like myself–to fix this firmware fiasco immediately.

This firmware should never have been released. We are not your testers. We are your clients.

For the love of God, either release a functional version of the firmware, or, at the very least, provide clear, precise, and reliable instructions on how to revert to the previous version.

This just ain’t working. You know this. Do something about it.

pinax wrote:


This just ain’t working. 

Care to give some specifics?   I loaded it yesterday without any issues at all…

TonyPh12345 wrote:

pinax wrote:


This just ain’t working. 

Care to give some specifics?   I loaded it yesterday without any issues at all…


Read the “New FW 4.00.00 upgrade results” thread in its entirety.

It is littered with specifics, including mine.

pinax wrote:Read the “New FW 4.00.00 upgrade results” thread in its entirety.


It is littered with specifics, including mine.

I did – that’s why I’m asking here.  In that thread, you referred everyone to this thread.

But, OK…

MyCloud was never made to install packages. It is made for what it is, a BASIC consumer NAS. if you want to add your own packages, build your own NAS, its not hard. Whatever you install via shell will VOID your warranty. 

News Flash, everyone!

This thread isn’t about package management/installation/whatever.

It’s about that fact that the new firmware update has rendered the My Cloud unusable for people like me, who barely know what a “package” is. People like me who don’t want to touch the command line, but just want the product they bought to work the way it’s supposed to.

My My Cloud worked before the update. Now it’s a mess. I’m at a loss–critical data that I depend on is inaccessible.

This is a very serious issue. So let’s please stop bickering about packages.

Thank you.

WD needs to promise a fix with 5-6 hours for this

Perhaps they would care to comment about that!!!

Mine’s working fine after updating, in fact things seems snappier overall. 

I’m happy with the update.

You’re lucky.

In a way, the success you’ve experienced kind of highlights the problem: the update has generated radically different results for different users.

WD should have run the firmware update through its paces internally, simulating real-world conditions and with the various different configurations that consumers typically have set up (Mac vs. PC, etc.).

This update is totally half-baked. It’s not acceptable to release a firmware update, and then start a forum thread saying, in effect, “Hey, everyone… So how’s it going with the new update? Is it working okay…?”

That’s what WD should have asked of its development team, before releasing the update.

We, the consumers, should not be the ones discovering the problems.

Again, this is very, very serious. People depend on their data. WD has effectively cut me off from mine. You’re very fortunate that that hasn’t happened in your case. But a firmware update needs to be robust. It needs to be rock-solid before it goes public.

Utterly unacceptable.

So why dont you provide us with the specific of your problem? If you did then maybe we can help?

Me too… everything is working as I would expect… but I am not trying to hack it into something that it may or may not be designed to do. Using it as intended by WD.

I have owned a lot of electronic gadgets and it always seems there are those that hack and push the HW to do things for which it was not designed and then complain that it didn’t work right.

OTOH, I have hacked several such devices and share the frustration…  When you are doing it, it seems the mfg should be able to help. But not for these low cost devices… there just isn’t enough money in them to open them up to all the various hackers/tinkerers.

Bottom line… if you want an open device, buy one…

For me - and mine was flaky before too

I have the following problems

Drive dropping from network (yet again)

Doesn’t work remotely via wd2go (just crashes)

Much slower than before when it does connect


As I wrote above, read the “New FW 4.00.00 upgrade results” thread. I detailed my experiences there. Along with lots of other poeple.

Read it from top to bottom.

I did not intend to explain my issues here. I started this thread to draw attention to how just how serious this problem is.

I shouldn’t have to be finding solutions to an out-of-the-box consumer product by plowing through forums. WD needs to issue a fix. That’s my whole point.

My Problems:

Shares no longer accessible by a MAC (OSX Mavericks) - This is a show stopper.

     =>> Because of this Time Machine backups no longer work  - cannot see the drive

Builtin Media Server (Twonky) shares all reset to default and have to be reset up - while not reversible, an indication of shoddyness i believe that the FW removed the config, and really annoying!

So if you are a Mac user, this has pretty much made the NAS useless.

Can WD at least produce a good downgrade guide to the previous firmware? This FW has made is useless for a MAC user. PLEASE PLEASE PLEASE. Downgrade guide/process!

Id second that 0- we need a downgrade option quickly



Come on - just take the old firmware and badge it version 5 so we can use it - this needs to be issued today

Please fix new FW. I get terrible write speeds…

Ive now tested this further - the device is now virtually unusable.  It staggers me that WD has issued this - it can’t have even been remotely tested.

Can we have an urgent update on when EXACTLY A FIX WILL BE ISSUED?

My drive is now 10 times worse than before the update

In april with the old FW I did a simple read/write test and achieved about 40 Mb/s write speed (from local disk to a share).

Since I noticed a horrible performance I repeated that same test and now get only 5 Mb/s, which is 8 times slower.

Same hardware, same files, new firmware.

I assume that everybody has its own wishes and priorities, say stream video, browse pictures, remote acces. For me the two most important things are:

1 - acceptable read/write speed for the shares

2 - uninterupted play of audio files (FLAC)

Both are not working for me right now. Copying files now takes ages, plus playing a FLAC file using Windows Media Player locks up MediaPlayer.

Please please please, let somebody from the support dept respond, act or supply us the old firmware again.

All written in small characters, no bold or underlining, no red colors, no bad words. Hope it helps.

1 Like

Btw, I tried to ignore the slow speed of the MBL and continue to work with it.

So I just started some 1.5 Gb copy of FLAC files, which resulted into a transfer speed of…

[do not laugh]

494 kB/s

estimated time 21 hours…

I do not understand what is going on with just a simple file copy. I wish there was a button in the UI which reads ‘fast mode’ and disables all process that can better be run at night…