Network Performance Over Wired Network Below 10 MBps

For the first month or so, I had no problems with the EX2 but all of a sudden I am getting unacceptable performance for a NAS. I can’t seem to ever get more than 10 MBps (or about 80 Mbps) over Gigabit ethernet and the transfer is super spotty (jumps up to 10 MBps, then drops down to nothing). My whole network is wired. Nothing about the configuration of my network has changed from when it was working to now. I need to transfer 32 GB of data (RAW photos) every couple days to the NAS. This used to take about 5 minutes, and now it takes over an hour not to mention since I use SyncToy, the scan for existing files can take 10 minutes (and used to take a minute or less).

I took a screenshot of what the Rx looks like from the MyCloud. Notice transfer almost never goes above 10 MBps and is almost never consistently transfering. This was taken when SyncToy was transfer files (which are about 25 MB each), not during scanning, so files are being constantly served. I see a similar pattern even if I use a single large file (1 GB+)

Simlar pattern from the Tx side. Note that my machine is physical, there is just a virtual adapter for VMs. Everything is hardwired. Also note that Windows measures in Mbps and the MyCloud in MBps. Overal the speed is about 10x slower than what Gigabit should be with constant ups and downs of the transfer.

MyCloud-SlowTransfer-NetworkSpeedx.png

To show more what the Tx pattern should look like, notice the dotted like below. I only let it run for a about 20 seconds (so the right half of the graph) but this is the same transfer over the same network (literally the same port) but to another computer instead of the MyCloud. There are still slight ups and downs but the transfer is consistently above 200 Mbps and never stalls out and 0. The spikes are up closer to 500 Mbps.

Transfer to Another Machine.png

I don’t expect to sustain 1000 Mbps, but inconsistent 80 Mbps or less isn’t ok. I tried locking the Link Speed of the MyCloud in the network settings to 1000 Mbps but that had no affect. I’d tried different jacks in my house and taps on my switch/router, but no dice (however I doubt this a problem since another machine gets at least 5x performance with no drops). I had to reupload a few hundred GB of data the other data and it had to run for a few days to transfer. I can transfer this fast to an actual cloud service. On my LAN should be much faster.

Any thoughts on what could be going wrong?

Since those screenshots were from a couple weeks ago, I took a couple more as I am trying to transfer 300 GB up to the MyCloud. Here is what my transfers look like so far. Even worse.

I lost a set of photos the other day and had no backup because the MyCloud was still trying to slowly transfer files from a couple days before. Pretty frustrating.

I am not sure why this sudden change of performance happened…but have you tried rebooting the EX2 to see if that made any difference?

BTW, the bigger question is why are you using Hyper-V Virtual Ethernet Adapter?? Why isn’t traffic flowing through your regular ethernet adapter?? Hyper-V is used for virtual machines - do you have virtual machines installed in your system? And the results are clearly not wired ethernet speed results - that speed is of wifi traffic…if you look around on the EX2 board, I just answered another user’s question about slow data transfers by saying that even if you have a wired ethernet plugged in, that does NOT mean Windows is using the wired connection. In your case, it clearly seems to be using the wifi connection. I have no idea why you need the Hyper-V Virtual adapter for.

See this other thread I commented on yesterday with some screenshots to identify whether your wired or wifi connection has precedence (regardless of whther you have a wired ethernet plugged in) ->  http://community.wd.com/t5/WD-My-Cloud-EX2/Extremely-slow-transfer-speeds-can-t-get-FTP-working/td-p/743908

And see this for the Hyper-V Virtual Ethernet Adapter (you may already know why you use it but to the rest of us it is not clear why) ->  [http://social.technet.microsoft.com/Forums/windows/en-US/638caef3-c268-4619-84cc-c4e57ede7f97/what-is-hyperv-virtual-ethernet-adapter?forum=w8itpronetworking

](http://social.technet.microsoft.com/Forums/windows/en-US/638caef3-c268-4619-84cc-c4e57ede7f97/what-is-hyperv-virtual-ethernet-adapter?forum=w8itpronetworking)

And if you are indeed getting these choppy results on the Windows running as a VM, well that right there is your problem. But if your Windows is not running as a VM, then disable that hyper-v adapter and use the regular Local Area Connection adapter for connections - that sould be what Windows should be using for a wired ethernet connection.

Thanks for the suggestions. Rebooting has not helped, I have tried that.

Hyper-V Virtual Ethernet Adapter isn’t an issue. I was going to remove that from the screenshot since I thought someone might pick on that buit was hoping to counter act that conclusion by showing traffic to a different box than the MyCloud working as expected. All the information is from a physical box, not a VM. The box runs the Hyper-V service which has a virtual switch configured on it. How the virtual switch works i just like a physical network switch. The computer is “plugged in” to the virtual switch as are all the virtual machines. That is why the machine thinks its connection is through the virtual switch. It really plays no impact on the situation. Just to prove this, I “disconnected” the virtual switch and routed the physical box directly into the network. You can see the results are the same:

MyCloud-SlowTransfer-VHD-Ethernet.png

No joke, there is in fact a 10 second gap where nothing is transfered. This is a 60 second window of transfering a single 4 GB ISO file.

I also looked at your other thread, but being that this is a desktop with only a wired connection, there is only one option so it is already a properly prioitized connectioned.