NAS server broke, only SSH works

I just opened my new MBL and enabled ssh and tried to install transmission with some resources in wiki, etc.

In the begining NAS server was working fine, I mounted my MBL 3tb via afp server and I can acess MBL via When I was trying to install transmission it was asking me to update many stuffts (like apace server, etc) and I said update and remove the older versions.

Now I can only ssh my MBL, I can see afp server running but I can’t mount the hard drive and also doesn’t response at all.

I was trying to update via apt-get update (according to followed by apt-get build-dep nano. But it ends with error 

Unpacking replacement libc-bin …
dpkg: error processing /var/cache/apt/archives/libc-bin_2.11.3-3_powerpc.deb (–unpack):
trying to overwrite ‘/etc/’, which is also in package wd-lib 01.03.02-67335
Processing triggers for man-db …
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)
E: Failed to process build dependencies

With this error I went on next step “apt-get -b source nano” then I got error

sh: dpkg-source: command not found
Unpack command ‘dpkg-source -x nano_2.2.4-1.dsc’ failed.
Check if the ‘dpkg-dev’ package is installed.
E: Child process failed

It will be great if you can find a solution to restore my MBL. (the reset button on MBL doesn’t help)

Ooops!  :dizzy_face:

You very likely destroyed the internal OS by trying to install the GPL code!

You should never have tried to install that.

The page for FIRMWARE update for the MBL is here:

I can’t acess My Book Live Dashboard. I have to find a way to do this via ssh. You are wright I likely killed the OS on the first day itself (still on warrenty).

I hope some expertise here knows how to do that.

kuruvi wrote:

I have to find a way to do this via ssh.

Search.  There’s plenty of posts on how to update the firmware via SSH.