MyCloudMirror does not appear as a backup target


I bought a MyCloudMirror a few days ago, but have so far been unable to get backing up to work propoerly.

I set up an inital backup when I first got it home and it looked to be working but when I came back to it a few hours later only a small fraction of my files had been backup up.  No problem, I thought, I’ll just try again (Einstein’s definition of insanity right?)

The problem is now MyCloudMirror does not even appear as a backup target and I can’t try again!!

I have tried the solution in this old thread, but nothing seems to work:

Additionally, I don’t see any information about the MyCloudMirror in quickview.  However, I and able to log onto the dashboard and copy file back and forth using the public share.

Anyone have any idea what the problem is?  Help would be appreciated.

That sounds very like an issue I had at the beginning with my Mirror - the root cause was that my router was too old and slow to give a good enough connection for Quickview and Smartware to be able to reliably see the NAS.

A simple way to test if everything is OK with the device itself and your computer set-up (firewalls, AV etc) is OK is to plug your Mirror directly into the Ethernet port on your computer with its supplied cable. If all is well then it should appear under your Network section (I’m presuming here you’re under Windows - if not look in the equivalent section) and also be visible to Smartware and Quickview.

If it is visible then you may need to review your network set-up (the router and/or the network card(s) on your PC) to something a bit quicker. In my own case the NAS was always fully visible to an old desktop machine which was LAN-cable connected to the router, intermittently to one laptop by wifi and almost never to a second netbook connected by wifi. But when I updated my router to a new one (a Netgear D6200 in my case) all three can now always see the NAS without issue.

If it’s not visible by direct connection then you either have a local software issue (most likely a firewall configuration problem, or perhaps an AV issue) or a hardware problem. Although from what you report of it originally working I would suspect it will be visible like mine was when cable-connected directly.

Editted to add - the thread about my original problem is on the link below:

Hi Darren,

Thanks for the help.  If I connect the MyCloudMirror to my laptop directly using an ethernet cable and restart the MyCloudMirror, I can see the device in SmartWare and QuickView.  A assume that means my AV and firewall settings are okay.

My laptop is fairly old, so it may be time for a new one. For the time being, I’ll just do wired backups.

I’ll also have a look at the router and report back if I find anything in case it helps the next person.  

Thanks again

You’re welcome :slight_smile: Feed free to click the star on my post to acknowledge the assistance if you want.

It sounds like you have the same issue that I did. It’s not likely to be your laptop, more likely your router. My machine is a little Acer Aspire One netbook, with a puny 1GHz C-50 processor, so not exactly a speed-demon. It was the router that did it for me as I said before, now all my machines (including the netbook) see the NAS fine.

My new router (a Netgear D6200) wasn’t too expensive (a bit over £100), so something like that may be an option too?